aboutsummaryrefslogtreecommitdiffstats
path: root/packages/uicmoc
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2006-03-24 11:25:53 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-24 11:25:53 +0000
commita579c9f67fe7a324fc798b25a4bf6695f01d7193 (patch)
treeff5cf4962e0ee88241955e4d5928d27339cfdb67 /packages/uicmoc
parent2e51a053eff454d36e943e50610d823e0c5d320d (diff)
downloadopenembedded-a579c9f67fe7a324fc798b25a4bf6695f01d7193.tar.gz
uicmoc-native 2.3.10: apply patch to make it work with gcc 4.1
fixes bug #771
Diffstat (limited to 'packages/uicmoc')
-rw-r--r--packages/uicmoc/uicmoc-native-2.3.10/gcc4_1.patch16
-rw-r--r--packages/uicmoc/uicmoc-native_2.3.10.bb5
2 files changed, 19 insertions, 2 deletions
diff --git a/packages/uicmoc/uicmoc-native-2.3.10/gcc4_1.patch b/packages/uicmoc/uicmoc-native-2.3.10/gcc4_1.patch
new file mode 100644
index 0000000000..550effd7ba
--- /dev/null
+++ b/packages/uicmoc/uicmoc-native-2.3.10/gcc4_1.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- qt-2.3.10/src/tools/qvaluestack.h~gcc4 2005-01-23 15:00:47.000000000 +0100
++++ qt-2.3.10/src/tools/qvaluestack.h 2006-03-19 02:32:56.000000000 +0100
+@@ -54,7 +54,7 @@
+ {
+ T elem( this->last() );
+ if ( !this->isEmpty() )
+- remove( this->fromLast() );
++ this->remove( this->fromLast() );
+ return elem;
+ }
+ T& top() { return this->last(); }
diff --git a/packages/uicmoc/uicmoc-native_2.3.10.bb b/packages/uicmoc/uicmoc-native_2.3.10.bb
index ca959c1579..db884e166a 100644
--- a/packages/uicmoc/uicmoc-native_2.3.10.bb
+++ b/packages/uicmoc/uicmoc-native_2.3.10.bb
@@ -3,12 +3,13 @@ SECTION = "devel"
PRIORITY = "optional"
LICENSE = "GPL QPL"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
-PR = "r0"
+PR = "r1"
SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}-free.tar.gz \
file://fix-makefile.patch;patch=1 \
file://gcc3_4.patch;patch=1" \
- file://gcc4.patch;patch=1"
+ file://gcc4.patch;patch=1 \
+ file://gcc4_1.patch;patch=1"
S = "${WORKDIR}/qt-${PV}"
inherit native qmake-base