aboutsummaryrefslogtreecommitdiffstats
path: root/packages/uicmoc
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2005-08-14 14:44:26 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-08-14 14:44:26 +0000
commitd1ce1ec2f684aa2bee1e1d90bdf7d1a315b7bfb1 (patch)
treebe52c5b4b5573ce3cd6c0db1a77df8bd177b9370 /packages/uicmoc
parent0dd8629cbaad95b0fab1040e8ebd97bd19c6f210 (diff)
downloadopenembedded-d1ce1ec2f684aa2bee1e1d90bdf7d1a315b7bfb1.tar.gz
Qt3 Native builds:
-Add a qt3e.bbclass similiar to the x11 bbclasses for Qt -Use this class in uicmoc3-native, opie-lrelease-native, opie-lupdate-native -Stage the headers of uicmoc3 and the static library to a dedicated qt3e staging directory -Add two .inc files to share common data between the cvs and 1.2.0 bbfile of opie-lupdate and opie-lrelease
Diffstat (limited to 'packages/uicmoc')
-rw-r--r--packages/uicmoc/uicmoc3-native_3.3.2.bb15
1 files changed, 12 insertions, 3 deletions
diff --git a/packages/uicmoc/uicmoc3-native_3.3.2.bb b/packages/uicmoc/uicmoc3-native_3.3.2.bb
index 582fbe80ef..3871c80c04 100644
--- a/packages/uicmoc/uicmoc3-native_3.3.2.bb
+++ b/packages/uicmoc/uicmoc3-native_3.3.2.bb
@@ -8,7 +8,7 @@ SRC_URI = "ftp://ftp.trolltech.com/qt/source/qt-embedded-free-3.3.2.tar.bz2 \
S = "${WORKDIR}/qt-embedded-free-3.3.2"
-inherit native qmake-base
+inherit native qmake-base qt3e
export QTDIR = "${S}"
export OE_QMAKE_LINK="${CXX}"
@@ -28,6 +28,15 @@ do_configure() {
}
do_stage() {
- install -m 0755 bin/moc ${STAGING_BINDIR}/moc3
- install -m 0755 bin/uic ${STAGING_BINDIR}/uic3
+ install -d ${OE_QMAKE_INCDIR_QT}
+ install -d ${OE_QMAKE_LIBDIR_QT}
+
+ install -m 0755 bin/moc ${OE_QMAKE_UIC}
+ install -m 0755 bin/uic ${OE_QMAKE_MOC}
+ install -m 0655 lib/*.a ${OE_QMAKE_LIBDIR_QT}
+
+ for f in include/*.h
+ do
+ install -m 0644 $f ${OE_QMAKE_INCDIR_QT}/
+ done
}