aboutsummaryrefslogtreecommitdiffstats
path: root/packages/unionfs
diff options
context:
space:
mode:
authorChris Lord <chris@openedhand.com>2005-01-25 18:39:55 +0000
committerChris Lord <chris@openedhand.com>2005-01-25 18:39:55 +0000
commit160a9f042a630dae74fa04bc87a3e9de74a953a4 (patch)
tree3ead376fa4e9201585585046eb82554c87365606 /packages/unionfs
parentc00fe624027eb6e258a1e1965d700cec10ae7291 (diff)
downloadopenembedded-160a9f042a630dae74fa04bc87a3e9de74a953a4.tar.gz
Fix DEPENDS/RDEPENDS of unionroot/unionroot-utils
BKrev: 41f6927bDvQ09I9lma81MNeG2-9Xnw
Diffstat (limited to 'packages/unionfs')
-rw-r--r--packages/unionfs/unionroot-utils_0.1.bb42
-rw-r--r--packages/unionfs/unionroot_0.1.bb6
2 files changed, 45 insertions, 3 deletions
diff --git a/packages/unionfs/unionroot-utils_0.1.bb b/packages/unionfs/unionroot-utils_0.1.bb
index e69de29bb2..ec5daecf57 100644
--- a/packages/unionfs/unionroot-utils_0.1.bb
+++ b/packages/unionfs/unionroot-utils_0.1.bb
@@ -0,0 +1,42 @@
+LICENSE = "GPL"
+
+DESCRIPTION = "Tools for administering a system that utilises unionroot."
+DEPENDS = "ipkg-collateral unionroot busybox"
+RDEPENDS = "ipkg-collateral unionroot busybox"
+SECTION = "base"
+PRIORITY = "optional"
+MAINTAINER = "Chris Lord <cwiiis@handhelds.org>"
+PR = "r1"
+
+SRC_URI = "file://mount.unionroot \
+ file://umount.unionroot"
+
+do_install () {
+ install -d ${D}/bin
+ install -m 0755 ${WORKDIR}/mount.unionroot ${D}/bin/
+ install -m 0755 ${WORKDIR}/umount.unionroot ${D}/bin/
+}
+
+pkg_postinst () {
+ update-alternatives --install /bin/mount mount /bin/mount.unionroot 100
+ update-alternatives --install /bin/umount umount /bin/umount.unionroot 100
+
+ # Alter /etc/ipkg.conf
+ mv $D/${sysconfdir}/ipkg.conf $D/${sysconfdir}/ipkg.conf.old
+ awk 'BEGIN { print "# Altered by unionroot" }
+ { if ( $3 == "/" )
+ {
+ print $1 " " $2 " /media/realroot"
+ }
+ else
+ {
+ print $0
+ }
+ }' $D/${sysconfdir}/ipkg.conf.old > $D/${sysconfdir}/ipkg.conf
+}
+
+pkg_prerm () {
+ update-alternatives --remove mount /bin/mount.unionroot
+ update-alternatives --remove umount /bin/umount.unionroot
+}
+
diff --git a/packages/unionfs/unionroot_0.1.bb b/packages/unionfs/unionroot_0.1.bb
index 0adb535511..79b79b5f94 100644
--- a/packages/unionfs/unionroot_0.1.bb
+++ b/packages/unionfs/unionroot_0.1.bb
@@ -1,13 +1,13 @@
LICENSE = "GPL"
DESCRIPTION = "Provides an init script that changes the root file-system to unionfs."
-DEPENDS = "base-files"
-RDEPENDS = "base-files"
+DEPENDS = "busybox base-files"
+RDEPENDS = "busybox base-files"
SECTION = "base"
PRIORITY = "optional"
MAINTAINER = "Chris Lord <cwiiis@handhelds.org>"
-PR = "r1"
+PR = "r2"
SRC_URI = "file://init.unionroot"