aboutsummaryrefslogtreecommitdiffstats
path: root/packages/uqm
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-02-23 12:47:30 +0000
commitdba2b89720b0318a28ebe7778294873b9353f71d (patch)
tree9925d056023ab3aae0687bb17ab5fb27e3eaf513 /packages/uqm
parenteea951fc35679b928aedc6214274de67c031ce12 (diff)
downloadopenembedded-dba2b89720b0318a28ebe7778294873b9353f71d.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/23 12:40:33+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 12:36:37+01:00 uni-frankfurt.de!mickeyl Merge bk://oe-devel@oe-devel.bkbits.net/openembedded into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/02/23 11:34:13+01:00 mn-solutions.de!schurig Merge http://oe-devel@openembedded.bkbits.net/openembedded into mnz66.mn-solutions.de:/usr/src/oe/p 2005/02/23 11:33:31+01:00 mn-solutions.de!schurig fix installation stage 2005/02/23 09:27:44+00:00 (none)!xora New upstream version of kismet, fixes for compilation problems, and change of maintainer with Brunos permission 2005/02/23 01:11:25+01:00 uni-frankfurt.de!mickeyl add a sharprom-compatible distro configuration. relies on an external 2.95.3 toolchain (for now... until someone adds it to OE) and needs further work. It's a start for someone interested though. 2005/02/23 01:09:23+01:00 uni-frankfurt.de!mickeyl bump cvsdate on oz-3.5.3 2005/02/22 17:37:44-06:00 ti.com!kergoth Fix the quilt PATCHCMD to stop rampantly chmod'ing, which made the CVS directories not executable, thereby screwing up the ability to rm -rf tmp. Thanks to holger freyther for pointing it out. BKrev: 421c7b62hBWfitoVhb3IO3ZT5nS71A
Diffstat (limited to 'packages/uqm')
-rw-r--r--packages/uqm/uqm_0.3.bb34
1 files changed, 34 insertions, 0 deletions
diff --git a/packages/uqm/uqm_0.3.bb b/packages/uqm/uqm_0.3.bb
index e69de29bb2..b31fb6af01 100644
--- a/packages/uqm/uqm_0.3.bb
+++ b/packages/uqm/uqm_0.3.bb
@@ -0,0 +1,34 @@
+DESCRIPTION = "Star Control 2 source port using SDL (see sc2.sourceforge.net)"
+SECTION = "games"
+PRIORITY = "optional"
+DEPENDS = "virtual/libsdl libsdl-image libsdl-net libvorbis libogg zlib"
+SECTION = "opie/games"
+PRIORITY = "optional"
+MAINTAINER = "Paul Eggleton <paule@handhelds.org>"
+LICENSE = "GPL"
+
+PR = "r1"
+
+S = "${WORKDIR}/uqm-${PV}"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/sc2/uqm-${PV}-source.tgz \
+ file://build-opts.sh \
+ file://build-oe.patch;patch=1;pnum=0"
+
+do_configure() {
+ install ${WORKDIR}/build-opts.sh ${S}/
+ ./build-opts.sh ${STAGING_DIR} ${STAGING_BINDIR} ${STAGING_LIBDIR}
+}
+
+do_compile() {
+ export ARCH="${TARGET_ARCH}"
+ export CC="${CC}"
+ export STAGING_INCDIR="${STAGING_INCDIR}"
+ export STAGING_LIBDIR="${STAGING_LIBDIR}"
+ ./build.sh uqm
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -m 0755 uqm ${D}${bindir}
+}