aboutsummaryrefslogtreecommitdiffstats
path: root/packages/util-linux
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-11-21 10:43:42 +0000
committerKoen Kooi <koen@openembedded.org>2006-11-21 10:43:42 +0000
commit8292e638ccc07f088a4b88deb1daca1e33342f7a (patch)
tree02bb18847f4a5e29a044febd067819b597f3caa9 /packages/util-linux
parentbad614892f07233e4b89042177862cae503dda10 (diff)
downloadopenembedded-8292e638ccc07f088a4b88deb1daca1e33342f7a.tar.gz
util-linux: add debian patch and patches from #1533, courtesy Gerwin van der Kruis, should close #1533
Diffstat (limited to 'packages/util-linux')
-rw-r--r--packages/util-linux/files/glibc-fix.patch62
-rw-r--r--packages/util-linux/files/util-linux_2.12r-12.diff.gzbin0 -> 100566 bytes
-rw-r--r--packages/util-linux/util-linux_2.12r.bb5
3 files changed, 66 insertions, 1 deletions
diff --git a/packages/util-linux/files/glibc-fix.patch b/packages/util-linux/files/glibc-fix.patch
new file mode 100644
index 0000000000..d72c1701ef
--- /dev/null
+++ b/packages/util-linux/files/glibc-fix.patch
@@ -0,0 +1,62 @@
+--- /tmp/llseek.c 2006-11-21 11:31:31.000000000 +0100
++++ util-linux-2.12r/fdisk/llseek.c 2006-11-21 11:33:21.218554000 +0100
+@@ -31,9 +31,18 @@
+
+ #ifdef __NR__llseek
+
++#ifdef _syscall5
++
+ static _syscall5(int,_llseek,unsigned int,fd,unsigned long,offset_high,
+ unsigned long, offset_low,long long *,result,
+ unsigned int, origin)
++#else
++static int _llseek (unsigned int fd, unsigned long oh,
++ unsigned long ol, long long *result,
++ unsigned int origin) {
++ return syscall (__NR__llseek, fd, oh, ol, result, origin);
++}
++#endif /* _syscall5 */
+
+ #else
+
+--- /tmp/sfdisk.c 2006-11-21 11:36:13.000000000 +0100
++++ util-linux-2.12r/fdisk/sfdisk.c 2006-11-21 11:37:17.678554000 +0100
+@@ -177,9 +177,16 @@
+ #endif
+
+ #ifndef use_lseek
++#ifdef _syscall5
+ static __attribute__used
+ _syscall5(int, _llseek, unsigned int, fd, ulong, hi, ulong, lo,
+ loff_t *, res, unsigned int, wh);
++#else
++int _llseek (unsigned int fd, ulong hi, ulong lo,
++ loff_t *res, unsigned int wh) {
++ return syscall (__NR__llseek, fd, hi, lo, res, wh);
++}
++#endif /* _syscall5 */
+ #endif
+
+ static int
+--- /tmp/cmos.c 2006-11-21 11:38:55.000000000 +0100
++++ util-linux-2.12r/hwclock/cmos.c 2006-11-21 11:41:45.458554000 +0100
+@@ -46,15 +46,16 @@
+
+ #include <unistd.h> /* for geteuid() */
+ #include <fcntl.h> /* for O_RDWR */
++#include <linux/version.h>
+ #include <errno.h>
+ #include "../defines.h" /* for HAVE_sys_io_h */
+ #include "nls.h"
+
+ #if defined(__i386__)
+-#ifdef HAVE_sys_io_h
+-#include <sys/io.h>
++#if LINUX_VERSION_CODE < KERNEL_VERSION(2, 6, 0)
++#include <asm/io.h>
+ #else
+-#include <asm/io.h> /* for inb, outb */
++#include <sys/io.h> /* for inb, outb */
+ #endif
+ #elif defined(__alpha__)
+ /* <asm/io.h> fails to compile, probably because of u8 etc */
diff --git a/packages/util-linux/files/util-linux_2.12r-12.diff.gz b/packages/util-linux/files/util-linux_2.12r-12.diff.gz
new file mode 100644
index 0000000000..a00cedeb15
--- /dev/null
+++ b/packages/util-linux/files/util-linux_2.12r-12.diff.gz
Binary files differ
diff --git a/packages/util-linux/util-linux_2.12r.bb b/packages/util-linux/util-linux_2.12r.bb
index bb874d9573..32cbadae64 100644
--- a/packages/util-linux/util-linux_2.12r.bb
+++ b/packages/util-linux/util-linux_2.12r.bb
@@ -1,3 +1,6 @@
require util-linux.inc
-PR = "r8"
+SRC_URI += "file://util-linux_2.12r-12.diff.gz;patch=1"
+SRC_URI += "file://glibc-fix.patch;patch=1"
+
+PR = "r10"