aboutsummaryrefslogtreecommitdiffstats
path: root/packages/util-linux
diff options
context:
space:
mode:
authorAndreas Oberritter <obi@opendreambox.org>2008-10-22 14:49:04 +0200
committerAndreas Oberritter <obi@opendreambox.org>2008-10-22 14:49:04 +0200
commit0d13b8bf846a7c198dfaf1db71dd1342ea5588eb (patch)
tree3578fef0db2b55c11bd6c869d3dba30c48486d40 /packages/util-linux
parentbc63965c09696a59388c61eef67e3e8dfd5cebcb (diff)
downloadopenembedded-0d13b8bf846a7c198dfaf1db71dd1342ea5588eb.tar.gz
util-linux-native: backport build fixes from dev
Diffstat (limited to 'packages/util-linux')
-rw-r--r--packages/util-linux/files/swapargs.h1
-rw-r--r--packages/util-linux/files/util-linux-2.12r-cramfs-1.patch87
-rw-r--r--packages/util-linux/util-linux-native_2.12r.bb2
3 files changed, 89 insertions, 1 deletions
diff --git a/packages/util-linux/files/swapargs.h b/packages/util-linux/files/swapargs.h
index e960eef05f..52fd10411b 100644
--- a/packages/util-linux/files/swapargs.h
+++ b/packages/util-linux/files/swapargs.h
@@ -1,3 +1,2 @@
#define SWAPON_HAS_TWO_ARGS
-#include <asm/page.h>
#include <sys/swap.h>
diff --git a/packages/util-linux/files/util-linux-2.12r-cramfs-1.patch b/packages/util-linux/files/util-linux-2.12r-cramfs-1.patch
new file mode 100644
index 0000000000..1771bdc528
--- /dev/null
+++ b/packages/util-linux/files/util-linux-2.12r-cramfs-1.patch
@@ -0,0 +1,87 @@
+Submitted by: Jeremy Utley <jeremy@linuxfromscratch.org>
+Date: 2004-12-25
+Initial Package Version: 2.12p (should apply to versions back to at least k)
+Upstream Status: Not Submitted - Test Version
+Origin: Alexander Patrakov, adapted from debian build of cramfs utilities
+Description: Util-Linux fails in cramfs compilation due to changes in the
+linux-libc-headers package 2.6.9 and after. This patch is a proper fix to the
+problem, but may in fact not be accepted upstream.
+
+
+Index: util-linux-2.12r/disk-utils/fsck.cramfs.c
+===================================================================
+--- util-linux-2.12r.orig/disk-utils/fsck.cramfs.c 2008-05-16 00:34:36.000000000 -0700
++++ util-linux-2.12r/disk-utils/fsck.cramfs.c 2008-05-16 09:39:50.000000000 -0700
+@@ -76,8 +76,7 @@
+
+ #define PAD_SIZE 512
+
+-#include <asm/page.h>
+-#define PAGE_CACHE_SIZE (4096)
++#define PAGE_CACHE_SIZE page_size
+
+ /* Guarantee access to at least 8kB at a time */
+ #define ROMBUFFER_BITS 13
+@@ -87,11 +86,13 @@
+ static unsigned long read_buffer_block = ~0UL;
+
+ /* Uncompressing data structures... */
+-static char outbuffer[PAGE_CACHE_SIZE*2];
++static char *outbuffer;
+ z_stream stream;
+
+ #endif /* INCLUDE_FS_TESTS */
+
++static size_t page_size;
++
+ /* Input status of 0 to print help and exit without an error. */
+ static void usage(int status)
+ {
+@@ -456,9 +457,17 @@
+ int c; /* for getopt */
+ int start = 0;
+
++ page_size = sysconf(_SC_PAGESIZE);
++
+ if (argc)
+ progname = argv[0];
+
++ outbuffer = malloc(page_size * 2);
++ if (!outbuffer) {
++ fprintf(stderr, _("failed to allocate outbuffer\n"));
++ exit(8);
++ }
++
+ /* command line options */
+ while ((c = getopt(argc, argv, "hx:v")) != EOF) {
+ switch (c) {
+Index: util-linux-2.12r/disk-utils/mkfs.cramfs.c
+===================================================================
+--- util-linux-2.12r.orig/disk-utils/mkfs.cramfs.c 2004-12-11 06:56:01.000000000 -0800
++++ util-linux-2.12r/disk-utils/mkfs.cramfs.c 2008-05-16 09:38:06.000000000 -0700
+@@ -46,16 +46,8 @@
+ static const char *progname = "mkcramfs";
+ static int verbose = 0;
+
+-#ifdef __ia64__
+-#define PAGE_CACHE_SIZE (16384)
+-#elif defined __alpha__
+-#define PAGE_CACHE_SIZE (8192)
+-#else
+-#define PAGE_CACHE_SIZE (4096)
+-#endif
+-
+ /* The kernel assumes PAGE_CACHE_SIZE as block size. */
+-static unsigned int blksize = PAGE_CACHE_SIZE; /* settable via -b option */
++static unsigned int blksize; /* settable via -b option */
+ static long total_blocks = 0, total_nodes = 1; /* pre-count the root node */
+ static int image_length = 0;
+
+@@ -730,6 +722,7 @@
+ u32 crc = crc32(0L, Z_NULL, 0);
+ int c;
+
++ blksize = sysconf(_SC_PAGESIZE);
+ total_blocks = 0;
+
+ if (argc) {
diff --git a/packages/util-linux/util-linux-native_2.12r.bb b/packages/util-linux/util-linux-native_2.12r.bb
index 862a6716bd..ff06fec39f 100644
--- a/packages/util-linux/util-linux-native_2.12r.bb
+++ b/packages/util-linux/util-linux-native_2.12r.bb
@@ -2,6 +2,7 @@ DESCRIPTION = "Util-linux is a suite of essential utilities for any Linux system
SECTION = "base"
LICENSE = "GPL"
DEPENDS = "zlib-native ncurses-native"
+PR = "r1"
inherit autotools native
@@ -11,6 +12,7 @@ SRC_URI = "ftp://ftp.kernel.org/pub/linux/utils/util-linux/util-linux-${PV}.tar.
file://make_include \
file://swapargs.h \
file://fdiskbsdlabel_thumb.diff;patch=1 \
+ file://util-linux-2.12r-cramfs-1.patch;patch=1 \
file://defines.h"
S="${WORKDIR}/util-linux-${PV}"