aboutsummaryrefslogtreecommitdiffstats
path: root/packages/vlc
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2008-09-20 07:55:21 +0000
committerKoen Kooi <koen@openembedded.org>2008-09-20 07:55:21 +0000
commita3ca858e9ab4cf79bfe2f4aa0f4da97aac6e42de (patch)
tree0235b1dd1fd055d5e4a435c47d6bd403f3b366ec /packages/vlc
parent549c8c122f345a444306115b5f1aaef994e9077e (diff)
downloadopenembedded-a3ca858e9ab4cf79bfe2f4aa0f4da97aac6e42de.tar.gz
vlc: add 0.9.2
Diffstat (limited to 'packages/vlc')
-rw-r--r--packages/vlc/vlc_0.9.2.bb56
1 files changed, 56 insertions, 0 deletions
diff --git a/packages/vlc/vlc_0.9.2.bb b/packages/vlc/vlc_0.9.2.bb
new file mode 100644
index 0000000000..af42a7c957
--- /dev/null
+++ b/packages/vlc/vlc_0.9.2.bb
@@ -0,0 +1,56 @@
+DESCRIPTION = "Video player and streamer - davinci edition"
+HOMEPAGE = "http://www.videolan.org"
+LICENSE = "GPL"
+PRIORITY = "optional"
+SECTION = "multimedia"
+
+DEPENDS = "libtool gettext libgcrypt schroedinger libsdl-x11 qt4-x11-free dbus libxml2 gnutls tremor faad2 ffmpeg flac liba52 libid3tag libmad mpeg2dec"
+
+
+SRC_URI = "http://videolan.mirror.technotop.nl/vlc/0.9.2/vlc-${PV}.tar.bz2"
+
+inherit autotools
+
+EXTRA_OECONF = "\
+ --enable-libtool \
+ --with-contrib \
+ --disable-dvdread \
+ --disable-wxwidgets \
+ --enable-x11 --enable-xvideo \
+ --disable-screen --disable-caca \
+ --disable-httpd --disable-vlm \
+ --enable-freetype \
+ --enable-sdl \
+ --enable-png \
+ --enable-live555 --enable-tremor \
+ --enable-v4l2 --disable-aa --enable-wma --disable-faad \
+ --enable-dbus \
+ --without-contrib \
+ ac_cv_path_MOC=${STAGING_BINDIR_NATIVE}/moc4 \
+"
+
+
+do_configure() {
+ cp ${STAGING_DATADIR}/aclocal/libgcrypt.m4 ${S}/m4/
+ ./bootstrap
+ gnu-configize --force
+ libtoolize --force
+ #autoreconf --force -i
+ cp ${STAGING_DATADIR}/libtool/config.* ${S}/autotools/
+ oe_runconf
+ rm config.log
+ sed -i -e s:-L/usr/lib:-L${STAGING_LIBDIR}/:g vlc-config
+ sed -i -e s:'$(MOC) $(DEFS) $(CPPFLAGS)':'$(MOC) $(DEFS)'\ -I${S}/include\ -DSYS_LINUX:g ${S}/modules/gui/qt4/Makefile
+}
+
+do_stage() {
+ autotools_stage_all
+}
+
+
+FILES_${PN} += "${bindir}/vlc \
+ ${datadir}/applications \
+ ${datadir}/vlc/ \
+ "
+
+FILES_${PN}-dbg += "${libdir}/vlc/*/.debug"