aboutsummaryrefslogtreecommitdiffstats
path: root/packages/w3cam/w3cam_0.7.2.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/w3cam/w3cam_0.7.2.bb
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/w3cam/w3cam_0.7.2.bb')
-rw-r--r--packages/w3cam/w3cam_0.7.2.bb31
1 files changed, 31 insertions, 0 deletions
diff --git a/packages/w3cam/w3cam_0.7.2.bb b/packages/w3cam/w3cam_0.7.2.bb
index e69de29bb2..02e543c507 100644
--- a/packages/w3cam/w3cam_0.7.2.bb
+++ b/packages/w3cam/w3cam_0.7.2.bb
@@ -0,0 +1,31 @@
+DESCRIPTION = "a small and fast cgi program to retrieve images from a V4L device."
+SECTION = "console/network"
+PRIORITY = "optional"
+MAINTAINER = "NSLU2 Linux <nslu2-linux@yahoogroups.com>"
+DEPENDS="jpeg"
+LICENSE = "GPLV2"
+PR = "r0"
+
+SRC_URI = "http://mpx.freeshell.net/w3cam-0.7.2.tar.gz \
+ file://staticpaths.patch;patch=1"
+
+S = "${WORKDIR}/w3cam-0.7.2/"
+
+inherit autotools
+
+LDFLAGS += "-L${STAGING_LIBDIR}"
+CFLAGS += "-L${STAGING_LIBDIR} -I${STAGING_INCDIR}"
+
+EXTRA_OECONF = "--without-x --without-ttf-inc"
+
+do_install() {
+ install -d ${D}${sbindir}
+ install -d ${D}${bindir}
+ install -d ${D}${mandir}/man1
+ install -d ${D}usr/cgi-bin
+ install -m 0755 ${S}w3camd/w3camd ${D}${sbindir}/w3camd
+ install -m 0755 ${S}w3cam.cgi ${D}usr/cgi-bin/w3camd.cgi
+ install -m 0755 ${S}vidcat ${D}${bindir}/vidcat
+ install -m 0644 ${S}vidcat.1 ${D}${mandir}/man1/vidcat.1
+}
+