aboutsummaryrefslogtreecommitdiffstats
path: root/packages/wget
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-06-06 01:40:15 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-06 01:40:15 +0000
commitb5d213c76a69dc12a41d688b78c4dd5344880a28 (patch)
tree261b185e85414d643eb8cc223a68cea02da97aa0 /packages/wget
parentd497e7d0b948032b5d6c00ba6ca3d8f6986e1c92 (diff)
downloadopenembedded-b5d213c76a69dc12a41d688b78c4dd5344880a28.tar.gz
wget 1.9.1: The fix to stop wget searching the system paths didn't work for
unslung/slugsos since an append to EXTRA_OECONF appears to happen before a condidition setting even though the append happens later. We need to pass the same option to disable ssl for unslung/slugsos directly instead of relying on the append.
Diffstat (limited to 'packages/wget')
-rw-r--r--packages/wget/wget_1.9.1.bb12
1 files changed, 5 insertions, 7 deletions
diff --git a/packages/wget/wget_1.9.1.bb b/packages/wget/wget_1.9.1.bb
index 8521655477..f5bf6439dc 100644
--- a/packages/wget/wget_1.9.1.bb
+++ b/packages/wget/wget_1.9.1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "A console URL download utility featuring HTTP, FTP, and more."
SECTION = "console/network"
MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
DEPENDS = ""
-PR = "r5"
+PR = "r6"
LICENSE = "GPL"
SRC_URI = "${GNU_MIRROR}/wget/wget-${PV}.tar.gz \
@@ -12,15 +12,13 @@ S = "${WORKDIR}/wget-${PV}"
inherit autotools gettext
-EXTRA_OECONF = "--enable-ipv6"
+# Disable checking for SSL since that searches the system paths
+EXTRA_OECONF = "--enable-ipv6 --without-ssl"
# The unslung kernel does not support ipv6
-EXTRA_OECONF_unslung = ""
+EXTRA_OECONF_unslung = "--without-ssl"
# SlugOS kernels do not support ipv6. Can be loaded as a module.
-EXTRA_OECONF_slugos = ""
-
-# Disable checking for SSL since that searches the system paths
-EXTRA_OECONF += "--without-ssl"
+EXTRA_OECONF_slugos = "--without-ssl"
do_configure () {
if [ ! -e acinclude.m4 ]; then