aboutsummaryrefslogtreecommitdiffstats
path: root/packages/wifistix
diff options
context:
space:
mode:
authorPhilip Balister <philip@balister.org>2007-10-02 17:03:59 +0000
committerPhilip Balister <philip@balister.org>2007-10-02 17:03:59 +0000
commit08bb9698fca8c2cd911524f85fe901dfd60c5993 (patch)
treeda43921a707cba99e0dc022d193f9d7dba7d96bc /packages/wifistix
parentd1f179f470466c3ff18855ba7c4bc9ca41fab2df (diff)
downloadopenembedded-08bb9698fca8c2cd911524f85fe901dfd60c5993.tar.gz
wifistix-module : Clean up bb file, add configuration file.
Diffstat (limited to 'packages/wifistix')
-rw-r--r--packages/wifistix/wifistix-modules/wifistix.conf4
-rw-r--r--packages/wifistix/wifistix-modules_5.0.16.p0.bb24
2 files changed, 19 insertions, 9 deletions
diff --git a/packages/wifistix/wifistix-modules/wifistix.conf b/packages/wifistix/wifistix-modules/wifistix.conf
new file mode 100644
index 0000000000..b232463975
--- /dev/null
+++ b/packages/wifistix/wifistix-modules/wifistix.conf
@@ -0,0 +1,4 @@
+install pcmcia /sbin/modprobe --ignore-install pcmcia && modprobe pxa2xx-cs
+
+alias mwlan0 mcf25
+
diff --git a/packages/wifistix/wifistix-modules_5.0.16.p0.bb b/packages/wifistix/wifistix-modules_5.0.16.p0.bb
index abd8a8c246..2682ae6cbc 100644
--- a/packages/wifistix/wifistix-modules_5.0.16.p0.bb
+++ b/packages/wifistix/wifistix-modules_5.0.16.p0.bb
@@ -8,6 +8,7 @@ DEPENDS = "virtual/kernel"
PR = "r0"
SRC_URI = "http://files.gumstix.com/cf8385-5.0.16.p0-26306.tbz \
+ file://wifistix.conf \
file://marvell-devicename.patch;patch=1 \
file://marvell-devicetable.patch;patch=1 \
file://marvell-gumstix.patch;patch=1 \
@@ -24,21 +25,26 @@ S = "${WORKDIR}/src_cf8385"
inherit module-base
+EXTRA_OEMAKE = "CONFIG_GUMSTIX=y CONFIG_DEBUG=n KVER=2.6 \
+ KERNELDIR=${KERNEL_SOURCE} ARCH=${TARGET_ARCH} \
+ CC=${KERNEL_CC} EXTRA_CFLAGS=${CFLAGS} \
+ INSTALL_MOD_PATH="${D}"
+
do_compile() {
unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- make CONFIG_GUMSTIX=y CONFIG_DEBUG=n KVER=2.6 KERNELDIR="${KERNEL_SOURCE}" \
- ARCH="${TARGET_ARCH}" CC="${KERNEL_CC}" EXTRA_CFLAGS="${CFLAGS}"
+ oe_runmake
}
do_install() {
unset CFLAGS CPPFLAGS CXXFLAGS LDFLAGS
- make CONFIG_GUMSTIX=y CONFIG_DEBUG=n KVER=2.6 KERNELDIR="${KERNEL_SOURCE}" \
- ARCH="${TARGET_ARCH}" CC="${KERNEL_CC}" EXTRA_CFLAGS="${CFLAGS}" INSTALL_MOD_PATH="${D}" install
-# (grep -q mcf25 ${D}/etc/modprobe.conf || \
-# echo -e 'alias mwlan0 mcf25\n' >> ${D}/etc/modprobe.conf)
-# (grep -q mwlan0 ${D}/etc/network/interfaces || \
-# echo -e '\nauto mwlan0\niface mwlan0 inet dhcp\n pre-up /sbin/iwconfig $$IFACE essid any txpower 100mW\n' >> $(TARGET_DIR)/etc/network/interfaces)
+ oe_runmake install
+
+ install -m 0755 -d ${D}${sysconfdir}/modprobe.d
+ install -m 0644 ${WORKDIR}/wifistix.conf ${D}${sysconfdir}/modprobe.d/wifistix.conf
}
PACKAGES = "${PN}"
-FILES_${PN} = "/lib/modules/"
+FILES_${PN} = "${base_libdir}/modules/"
+FILES_${PN} += "${sysconfdir}/modprobe.d/"
+CONFFILES_${PN} = "${sysconfdir}/modprobe.d/wifistix.conf"
+