aboutsummaryrefslogtreecommitdiffstats
path: root/packages/wireless-tools
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-20 10:40:08 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-01-20 10:40:08 +0000
commit1bb521fd96e47c6437bda16cf922d897a171fc14 (patch)
tree6579b2df48f9bf5f48192b377dd81d1a41c9f85b /packages/wireless-tools
parent52da54beb1ebd89a0fcfdfea8247b357128e8e97 (diff)
downloadopenembedded-1bb521fd96e47c6437bda16cf922d897a171fc14.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/01/20 04:02:25-05:00 handhelds.org!kergoth automake 1.9.x build fixes: ice, libsm, libxcursor, libxfixes, libxft, libxss, xcomposite, xdamage, xpm, xt, xtst. 2005/01/20 04:00:34-05:00 handhelds.org!kergoth Disable PARALLEL_MAKE in opie-tinykate. 2005/01/20 03:58:05-05:00 handhelds.org!kergoth rosetta: inherit gettext and depend on virtual/libintl. 2005/01/20 03:57:40-05:00 handhelds.org!kergoth A few STAGING_KERNEL_DIR and PACKAGE_ARCH fixes for multimachine builds. 2005/01/20 03:53:46-05:00 handhelds.org!kergoth tosa.conf: don't bother installing the real modutils.. the busybox modutils is fine. 2005/01/20 03:52:08-05:00 handhelds.org!kergoth wireless-tools: Apply patch to stop poking into the kernel headers where it shouldnt be, clean things up, use the local wireless.h instead of the kernel's, and split out into more granular ipks. 2005/01/20 03:49:43-05:00 handhelds.org!kergoth Patch ipkg to fix a bug when built for relatively recent uclibc. BKrev: 41ef8a88apPGTS6jqkoO28j6FLNtjg
Diffstat (limited to 'packages/wireless-tools')
-rw-r--r--packages/wireless-tools/wireless-tools/fixheaders.patch0
-rw-r--r--packages/wireless-tools/wireless-tools_27.bb44
2 files changed, 44 insertions, 0 deletions
diff --git a/packages/wireless-tools/wireless-tools/fixheaders.patch b/packages/wireless-tools/wireless-tools/fixheaders.patch
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/wireless-tools/wireless-tools/fixheaders.patch
diff --git a/packages/wireless-tools/wireless-tools_27.bb b/packages/wireless-tools/wireless-tools_27.bb
index e69de29bb2..7142a3de56 100644
--- a/packages/wireless-tools/wireless-tools_27.bb
+++ b/packages/wireless-tools/wireless-tools_27.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "Tools for the Linux Standard Wireless Extension Subsystem"
+HOMEPAGE = "http://www.hpl.hp.com/personal/Jean_Tourrilhes/Linux/Tools.html"
+SECTION = "base"
+PRIORITY = "optional"
+#DEPENDS = "virtual/kernel"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+PR = "r1"
+
+SRC_URI = "http://pcmcia-cs.sourceforge.net/ftp/contrib/wireless_tools.${PV}.tar.gz \
+ file://man.patch;patch=1 \
+ file://fixheaders.patch;patch=1 \
+ file://wireless-tools.if-pre-up"
+S = "${WORKDIR}/wireless_tools.${PV}"
+
+CFLAGS =+ "-I${S}"
+EXTRA_OEMAKE = "-e 'BUILD_SHARED=y' \
+ 'INSTALL_DIR=${D}/sbin' \
+ 'INSTALL_LIB=${D}/${libdir}' \
+ 'INSTALL_INC=${D}/${includedir}' \
+ 'INSTALL_MAN=${D}/${mandir}'"
+
+do_compile() {
+ oe_runmake all libiw.a
+}
+
+do_stage () {
+ install -m 0644 wireless.h ${STAGING_INCDIR}/
+ install -m 0644 iwlib.h ${STAGING_INCDIR}/
+ oe_libinstall -a -so libiw ${STAGING_LIBDIR}/
+}
+
+do_install() {
+ oe_runmake PREFIX=${D} install install-static
+ install -d ${D}/etc/network/if-pre-up.d
+ install ${WORKDIR}/wireless-tools.if-pre-up ${D}/etc/network/if-pre-up.d/wireless-tools
+}
+
+PACKAGES = "libiw libiw-dev libiw-doc ${PN} ${PN}-doc"
+FILES_libiw = "${libdir}/*.so.*"
+FILES_libiw-dev = "${libdir}/*.a ${libdir}/*.so ${includedir}"
+FILES_libiw-doc = "${mandir}/man7"
+FILES_${PN} = "${bindir} ${sbindir} /sbin /bin ${sysconfdir}/network"
+FILES_${PN}-doc = "${mandir}/man8"