aboutsummaryrefslogtreecommitdiffstats
path: root/packages/wt/wt3_2.99.0.bb
diff options
context:
space:
mode:
authorFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-12 11:06:50 +0100
committerFrans Meulenbroeks <fransmeulenbroeks@gmail.com>2009-03-12 11:06:50 +0100
commit9bf2becd7b6596eae1d7078038910ed59a319fa5 (patch)
treeddfeba68e09704f17efca4f0221699e191dfc15b /packages/wt/wt3_2.99.0.bb
parentffe697599f46f5f5e24bc63342d8ddeb288170f2 (diff)
downloadopenembedded-9bf2becd7b6596eae1d7078038910ed59a319fa5.tar.gz
wt3: created: wt 3.* (including 2.99); retain package wt (which is for 2.*) as 2.* and 3.* are not compatible
Diffstat (limited to 'packages/wt/wt3_2.99.0.bb')
-rw-r--r--packages/wt/wt3_2.99.0.bb41
1 files changed, 41 insertions, 0 deletions
diff --git a/packages/wt/wt3_2.99.0.bb b/packages/wt/wt3_2.99.0.bb
new file mode 100644
index 0000000000..fea28494ca
--- /dev/null
+++ b/packages/wt/wt3_2.99.0.bb
@@ -0,0 +1,41 @@
+DESCRIPTION = "A C++ Web Toolkit"
+PRIORITY = "optional"
+SECTION = "devel"
+LICENSE = "GPL"
+HOMEPAGE = "http://www.webtoolkit.eu/wt"
+DEPENDS = "boost zlib openssl"
+PR = "r0"
+
+# package wt3 is for wt 2.99 and wt 3.*
+# the api of these versions is incompatible with 2.*
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/witty/wt-${PV}.tar.gz \
+ file://src.patch;patch=1 \
+ file://ext.patch;patch=1 \
+ file://wgooglemap.patch;patch=1"
+
+CXXFLAGS += "-Dsinl=sin -Dcosl=cos -Dasinl=asin"
+
+FILES_${PN} += "${datadir}/Wt"
+FILES_${PN}-dev += "${datadir}/cmake-2.*"
+
+S = "${WORKDIR}/wt-${PV}"
+
+inherit cmake
+
+STAGE_TEMP = "${WORKDIR}/temp-staging"
+
+do_configure_append() {
+ ${BUILD_CXX} ${BUILD_CXXFLAGS} -o src/filetostring src/web/skeleton/FileToString.C
+}
+
+do_stage() {
+ rm -rf ${STAGE_TEMP}
+ mkdir -p ${STAGE_TEMP}
+ oe_runmake DESTDIR="${STAGE_TEMP}" install
+ cp -pPR ${STAGE_TEMP}/${includedir}/* ${STAGING_INCDIR}
+ cp -pPR ${STAGE_TEMP}/${libdir}/* ${STAGING_LIBDIR}
+ cp -pPR ${STAGE_TEMP}/${datadir}/cmake-2.* ${STAGING_DATADIR}
+ rm -rf ${STAGE_TEMP}
+}
+