aboutsummaryrefslogtreecommitdiffstats
path: root/packages/wvstreams
diff options
context:
space:
mode:
authorFlorian Boor <florian.boor@kernelconcepts.de>2009-01-14 21:49:13 +0100
committerFlorian Boor <florian.boor@kernelconcepts.de>2009-01-15 17:29:17 +0100
commit15fbbc498f81e769e1b75fdf7e3391de295d1dc3 (patch)
tree2f2043740006154fcdc374f1cf3a46c175fc2baa /packages/wvstreams
parented4b44c68fec892b261461444e9306dfb98447af (diff)
downloadopenembedded-15fbbc498f81e769e1b75fdf7e3391de295d1dc3.tar.gz
wvstreams: Add 4.2.2 which is more likely to work on ARM platforms.
Diffstat (limited to 'packages/wvstreams')
-rw-r--r--packages/wvstreams/files/wvstreams-debian.patch49
-rw-r--r--packages/wvstreams/wvstreams_4.2.2.bb40
2 files changed, 89 insertions, 0 deletions
diff --git a/packages/wvstreams/files/wvstreams-debian.patch b/packages/wvstreams/files/wvstreams-debian.patch
new file mode 100644
index 0000000000..5cb4837955
--- /dev/null
+++ b/packages/wvstreams/files/wvstreams-debian.patch
@@ -0,0 +1,49 @@
+--- wvstreams.old/include/wvvector.h 2005-11-24 19:46:46.000000000 +0000
++++ wvstreams-4.2.2/include/wvvector.h 2007-07-24 06:35:55.000000000 +0000
+@@ -358,7 +358,7 @@
+ /** Returns a pointer to the current element */
+ T *ptr() const
+ {
+- return static_cast<T *>(cur()->data);
++ return static_cast<T *>(this->cur()->data);
+ }
+
+ WvIterStuff(T);
+@@ -368,7 +368,7 @@
+ */
+ bool get_autofree() const
+ {
+- return link->get_autofree();
++ return this->link->get_autofree();
+ }
+
+ /**
+@@ -376,7 +376,7 @@
+ */
+ void set_autofree(bool autofree)
+ {
+- link->set_autofree(autofree);
++ this->link->set_autofree(autofree);
+ }
+
+ /**
+@@ -386,7 +386,7 @@
+ */
+ void remove(bool destroy = true)
+ {
+- WvVector::vec.remove(i, destroy);
++ WvVector::vec.remove(this->i, destroy);
+ }
+
+ /**
+@@ -404,8 +404,8 @@
+ */
+ void xremove(bool destroy = true)
+ {
+- WvVector::vec.remove(i, destroy);
+- prev();
++ WvVector::vec.remove(this->i, destroy);
++ this->prev();
+ }
+ };
+ };
diff --git a/packages/wvstreams/wvstreams_4.2.2.bb b/packages/wvstreams/wvstreams_4.2.2.bb
new file mode 100644
index 0000000000..bea2f22c0b
--- /dev/null
+++ b/packages/wvstreams/wvstreams_4.2.2.bb
@@ -0,0 +1,40 @@
+HOMEPAGE = "http://alumnit.ca/wiki/index.php?page=WvStreams"
+LICENSE = "LGPL"
+DESCRIPTION = "WvStreams is a network programming library in C++"
+DEPENDS = "zlib openssl (>= 0.9.8)"
+
+PR = "r0"
+
+SRC_URI = "http://ftp.de.debian.org/debian/pool/main/w/wvstreams/${PN}_${PV}.orig.tar.gz \
+ http://ftp.de.debian.org/debian/pool/main/w/wvstreams/wvstreams_4.2.2-2.2.diff.gz;patch=1 \
+ file://wvstreams-debian.patch;patch=1 \
+ file://build-fixes-and-sanity.patch;patch=1 "
+
+inherit autotools
+
+LDFLAGS_append = " -Wl,-rpath-link,${CROSS_DIR}/${TARGET_SYS}/lib"
+
+EXTRA_AUTORECONF += " -I${S}/gnulib/m4"
+EXTRA_OECONF = " --without-tcl --without-qt --without-pam"
+
+PACKAGES_prepend = "libuniconf libuniconf-dbg "
+PACKAGES_prepend = "uniconfd uniconfd-dbg "
+PACKAGES_prepend = "libwvstreams-base libwvstreams-base-dbg "
+PACKAGES_prepend = "libwvstreams-extras libwvstreams-extras-dbg "
+
+FILES_libuniconf = "${libdir}/libuniconf.so.*"
+FILES_libuniconf-dbg = "${libdir}/.debug/libuniconf.so.*"
+
+FILES_uniconfd = "${sbindir}/uniconfd ${sysconfdir}/uniconf.conf ${localstatedir}/uniconf"
+FILES_uniconfd-dbg = "${sbindir}/.debug/uniconfd"
+
+FILES_libwvstreams-base = "${libdir}/libwvutils.so.*"
+FILES_libwvstreams-base-dbg = "${libdir}/.debug/libwvutils.so.*"
+
+FILES_libwvstreams-extras = "${libdir}/libwvbase.so.* ${libdir}/libwvstreams.so.*"
+FILES_libwvstreams-extras-dbg = "${libdir}/.debug/libwvbase.so.* ${libdir}/.debug/libwvstreams.so.*"
+
+
+do_stage() {
+ autotools_stage_all
+}