aboutsummaryrefslogtreecommitdiffstats
path: root/packages/wxbase/wxbase_2.6.2.bb
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-03-27 13:06:57 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-03-27 13:06:57 +0000
commitc061cac00b68cb66701fba06f2eb3380dd24f4cc (patch)
treeb3a7f37184115c4adf365c4d11128fe8f5ad3e6f /packages/wxbase/wxbase_2.6.2.bb
parentad4e168977abab55356cc865629645609751e990 (diff)
downloadopenembedded-c061cac00b68cb66701fba06f2eb3380dd24f4cc.tar.gz
wxbase: add 2.6.2 and 2.7+cvs, partially fixes OE bug #716
Diffstat (limited to 'packages/wxbase/wxbase_2.6.2.bb')
-rw-r--r--packages/wxbase/wxbase_2.6.2.bb54
1 files changed, 54 insertions, 0 deletions
diff --git a/packages/wxbase/wxbase_2.6.2.bb b/packages/wxbase/wxbase_2.6.2.bb
new file mode 100644
index 0000000000..2a41fdfa65
--- /dev/null
+++ b/packages/wxbase/wxbase_2.6.2.bb
@@ -0,0 +1,54 @@
+DESCRIPTION = "wxBase is a library for programming \
+non-GUI (console) applications using the base wxWidgets functionality."
+HOMEPAGE = "http://www.wxwidgets.org/"
+LICENSE = "GPL"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "jpeg libpng zlib"
+
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/wxwindows/wxBase-${PV}.tar.bz2"
+
+S = "${WORKDIR}/wxBase-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "--enable-largefile"
+
+LEAD_SONAME = "libwx_base-2.6.so*"
+
+do_configure() {
+ oe_runconf
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/wx-2.6/wx
+ cp -pr include/wx ${STAGING_INCDIR}/wx-2.6
+ cp -pr lib/libwx* ${STAGING_LIBDIR}
+ cp -pr lib/wx ${STAGING_LIBDIR}
+ cp -pr build/bakefiles/wxpresets/presets ${STAGING_DATADIR}/bakefile
+ cp -pr wxwin.m4 ${STAGING_DATADIR}/aclocal
+ ln -sf ${STAGING_LIBDIR}/wx/config/${TARGET_PREFIX}base-ansi-release-2.6 ${STAGING_BINDIR}/wx-config
+ sed -e s,'wxconfdir=".*"','wxconfigdir="${STAGING_LIBDIR}/wx/config"', \
+ -e s,'bindir=".*"','bindir="${STAGING_BINDIR}"', \
+ -e s,'libdir=".*"','libdir="${STAGING_LIBDIR}"', \
+ -e s,'includedir=".*"','includedir="${STAGING_INCDIR}"', \
+ -i ${STAGING_LIBDIR}/wx/config/${TARGET_PREFIX}base-ansi-release-2.6
+}
+
+FILES_${PN} += " \
+ ${libdir}/wx/config"
+
+FILES_${PN}-dev += " \
+ ${libdir}/wx/include \
+ ${datadir}/bakefile"
+
+do_install() {
+ oe_runmake 'DESTDIR=${D}' install
+ ln -sf ${libdir}/wx/config/${TARGET_PREFIX}base-ansi-release-2.6 ${D}${bindir}/wx-config
+ install -d ${D}${docdir}/${PN}-${PV}
+ install -m 644 -p CHANGES.txt ${D}${docdir}/${PN}-${PV}
+ install -m 644 -p COPYING.LIB ${D}${docdir}/${PN}-${PV}
+ install -m 644 -p LICENCE.txt ${D}${docdir}/${PN}-${PV}
+ install -m 644 -p README.txt ${D}${docdir}/${PN}-${PV}
+}