aboutsummaryrefslogtreecommitdiffstats
path: root/packages/xfce-mcs-manager
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/xfce-mcs-manager
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/xfce-mcs-manager')
-rw-r--r--packages/xfce-mcs-manager/.mtn2git_empty0
-rw-r--r--packages/xfce-mcs-manager/xfce-mcs-manager.inc24
-rw-r--r--packages/xfce-mcs-manager/xfce-mcs-manager_4.2.0.bb24
-rw-r--r--packages/xfce-mcs-manager/xfce-mcs-manager_4.2.2.bb5
4 files changed, 53 insertions, 0 deletions
diff --git a/packages/xfce-mcs-manager/.mtn2git_empty b/packages/xfce-mcs-manager/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xfce-mcs-manager/.mtn2git_empty
diff --git a/packages/xfce-mcs-manager/xfce-mcs-manager.inc b/packages/xfce-mcs-manager/xfce-mcs-manager.inc
index e69de29bb2..d913910d69 100644
--- a/packages/xfce-mcs-manager/xfce-mcs-manager.inc
+++ b/packages/xfce-mcs-manager/xfce-mcs-manager.inc
@@ -0,0 +1,24 @@
+# xfce-mcs-manager OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="XFCE4 Settings manager."
+DEPENDS="libxfcegui4 libxfce4mcs"
+SECTION = "x11"
+
+inherit xfce
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/xfce4
+ install -d ${STAGING_INCDIR}/xfce4/xfce-mcs-manager
+ install -m 644 xfce-mcs-manager/manager-plugin.h ${STAGING_INCDIR}/xfce4/xfce-mcs-manager
+}
+
+# xfce-mcs-manager.pc uses ${libdir} to indicate where the mcs plugins live
+# the standard pkgconfig mangling was confusing us. Mangling is not required
+# for this particular .pc, so the following will suffice:
+
+do_stage_append () {
+ install -d ${PKG_CONFIG_PATH}
+ install -m 0644 ${S}/xfce-mcs-manager/xfce-mcs-manager.pc ${PKG_CONFIG_PATH}/xfce-mcs-manager.pc
+}
diff --git a/packages/xfce-mcs-manager/xfce-mcs-manager_4.2.0.bb b/packages/xfce-mcs-manager/xfce-mcs-manager_4.2.0.bb
index e69de29bb2..521d47697e 100644
--- a/packages/xfce-mcs-manager/xfce-mcs-manager_4.2.0.bb
+++ b/packages/xfce-mcs-manager/xfce-mcs-manager_4.2.0.bb
@@ -0,0 +1,24 @@
+# xfce-mcs-manager OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION="XFCE4 Settings manager."
+
+DEPENDS="libxfcegui4 libxfce4mcs"
+
+inherit xfce
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/xfce4
+ install -d ${STAGING_INCDIR}/xfce4/xfce-mcs-manager
+ install -m 644 xfce-mcs-manager/manager-plugin.h ${STAGING_INCDIR}/xfce4/xfce-mcs-manager
+}
+
+# xfce-mcs-manager.pc uses ${libdir} to indicate where the mcs plugins live
+# the standard pkgconfig mangling was confusing us. Mangling is not required
+# for this particular .pc, so the following will suffice:
+
+do_stage_append () {
+ install -d ${PKG_CONFIG_PATH}
+ install -m 0644 ${S}/xfce-mcs-manager/xfce-mcs-manager.pc ${PKG_CONFIG_PATH}/xfce-mcs-manager.pc
+}
diff --git a/packages/xfce-mcs-manager/xfce-mcs-manager_4.2.2.bb b/packages/xfce-mcs-manager/xfce-mcs-manager_4.2.2.bb
index e69de29bb2..c768b4e760 100644
--- a/packages/xfce-mcs-manager/xfce-mcs-manager_4.2.2.bb
+++ b/packages/xfce-mcs-manager/xfce-mcs-manager_4.2.2.bb
@@ -0,0 +1,5 @@
+# xfce-mcs-manager OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+include ${PN}.inc