aboutsummaryrefslogtreecommitdiffstats
path: root/packages/xmms
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2006-08-12 22:38:06 +0000
committerGraeme Gregory <dp@xora.org.uk>2006-08-12 22:38:06 +0000
commit67cb83c71e87de100063eb46afd809a8bccb967c (patch)
tree1a69828b11e269992ec83a4b4e074c2512ffe633 /packages/xmms
parent882ac39db1a56db202a8ab964e4b3f264b8bf2de (diff)
downloadopenembedded-67cb83c71e87de100063eb46afd809a8bccb967c.tar.gz
xmms_1.2.10.bb : improve autotools situation so we dont need to override
do_configure and do_compile. Enable vorbis and mikmod as per TODO stage the dev files so we can build plugins.
Diffstat (limited to 'packages/xmms')
-rw-r--r--packages/xmms/files/acinclude.m436
-rw-r--r--packages/xmms/xmms_1.2.10.bb28
2 files changed, 53 insertions, 11 deletions
diff --git a/packages/xmms/files/acinclude.m4 b/packages/xmms/files/acinclude.m4
new file mode 100644
index 0000000000..099d55b0b2
--- /dev/null
+++ b/packages/xmms/files/acinclude.m4
@@ -0,0 +1,36 @@
+dnl XMMS_FUNC_POSIX(FUNCTION... [, ACTION-IF-FOUND [, ACTION-IF-NOT-FOUND]])
+dnl Test for functions in posix libraries, and define POSIX_LIBS
+AC_DEFUN(XMMS_FUNC_POSIX,
+[dnl
+ xmms_posix4=no
+ xmms_rt=no
+ for xmms_func in $1
+ do
+ xmms_have_func=no
+ AC_CHECK_FUNC($xmms_func,xmms_have_func=yes,[
+ dnl try in libposix4 if not found in current LIBS
+ AC_CHECK_LIB(posix4,$xmms_func,[xmms_have_func=yes xmms_posix4=yes],[
+ dnl try in librt, if not found so far
+ AC_CHECK_LIB(rt,$xmms_func,[xmms_have_func=yes xmms_rt=yes])
+ ])
+ ])
+ if test $xmms_have_func = yes; then
+ changequote(, )dnl
+ xmms_tr_func=HAVE_`echo $xmms_func | tr 'abcdefghijklmnopqrstuvwxyz' 'ABCDEFGHIJKLMNOPQRSTUVWXYZ'`
+ changequote([, ])dnl
+ AC_DEFINE_UNQUOTED($xmms_tr_func)
+ ifelse([$2], , :, [$2])
+ else
+ ifelse([$3], , :, [$3])
+ fi
+ done
+ POSIX_LIBS=
+ if test $xmms_posix4 = yes; then
+ POSIX_LIBS=-lposix4
+ fi
+ if test $xmms_rt = yes; then
+ POSIX_LIBS="$POSIX_LIBS -lrt"
+ fi
+ AC_SUBST(POSIX_LIBS)
+])
+
diff --git a/packages/xmms/xmms_1.2.10.bb b/packages/xmms/xmms_1.2.10.bb
index 05bfb1dc3e..c24039ce85 100644
--- a/packages/xmms/xmms_1.2.10.bb
+++ b/packages/xmms/xmms_1.2.10.bb
@@ -2,22 +2,28 @@ DESCRIPTION = "The X MultiMedia System"
HOMEPAGE = "http://www.xmms.org/"
LICENSE = "GPL"
SECTION = "x11/multimedia"
-# TODO add esd mikmod vorbis
-DEPENDS = "gtk+-1.2"
+# TODO add esd
+DEPENDS = "gtk+-1.2 libvorbis mikmod"
SRC_URI = "http://www.xmms.org/files/1.2.x/xmms-${PV}.tar.bz2 \
- file://gcc4.patch;patch=1"
+ file://gcc4.patch;patch=1 \
+ file://acinclude.m4"
+PR = "r1"
-inherit autotools
+inherit autotools binconfig
-# TODO enable esd mikmod vorbis
-EXTRA_OECONF = "--disable-opengl --disable-esd --disable-mikmod --disable-vorbis"
+# TODO enable esd
+EXTRA_OECONF = "--disable-opengl --disable-esd \
+ --with-vorbis-includes=${STAGING_INCDIR} \
+ --with-ogg-includes=${STAGING_INCDIR} \
+ --with-vorbis-libraries=${STAGING_LIBDIR} \
+ --with-ogg-libraries=${STAGING_LIBDIR}"
-do_configure() {
- oe_runconf
+do_configure_prepend() {
+ cp ${WORKDIR}/acinclude.m4 ${S}
+ rm ${S}/libxmms/acinclude.m4
}
-do_compile() {
- oe_runmake LIBTOOL=${STAGING_BINDIR}/${TARGET_PREFIX}libtool
+do_stage() {
+ autotools_stage_all
}
-