aboutsummaryrefslogtreecommitdiffstats
path: root/packages/xorg-app
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-08-02 07:15:30 +0000
committerKoen Kooi <koen@openembedded.org>2007-08-02 07:15:30 +0000
commitb3e110eff605bd2361ea92bd748f59e48d508f33 (patch)
tree585a741d28885236452581e718ba458c6fd02c3d /packages/xorg-app
parent81ded5cd087778af9e1a13e7a207b55b5448e07b (diff)
downloadopenembedded-b3e110eff605bd2361ea92bd748f59e48d508f33.tar.gz
xorg mega commit: merge in change from poky
Diffstat (limited to 'packages/xorg-app')
-rw-r--r--packages/xorg-app/x11perf_1.4.1.bb6
-rw-r--r--packages/xorg-app/xauth_1.0.2.bb9
-rw-r--r--packages/xorg-app/xdpyinfo_1.0.2.bb6
-rw-r--r--packages/xorg-app/xev-1.0.2/.mtn2git_empty0
-rw-r--r--packages/xorg-app/xev-1.0.2/diet-x11.patch80
-rw-r--r--packages/xorg-app/xev_1.0.2.bb7
-rw-r--r--packages/xorg-app/xhost_1.0.2.bb6
-rw-r--r--packages/xorg-app/xinit_1.0.4.bb6
-rw-r--r--packages/xorg-app/xmodmap_1.0.2.bb5
-rw-r--r--packages/xorg-app/xorg-app-common.inc17
-rw-r--r--packages/xorg-app/xrandr/resolve_symbol_clash.patch16
-rw-r--r--packages/xorg-app/xrandr_1.2.2.bb8
-rw-r--r--packages/xorg-app/xrdb_1.0.3.bb3
-rw-r--r--packages/xorg-app/xset_1.0.2.bb11
-rw-r--r--packages/xorg-app/xvinfo_1.0.1.bb5
15 files changed, 154 insertions, 31 deletions
diff --git a/packages/xorg-app/x11perf_1.4.1.bb b/packages/xorg-app/x11perf_1.4.1.bb
new file mode 100644
index 0000000000..35680e7925
--- /dev/null
+++ b/packages/xorg-app/x11perf_1.4.1.bb
@@ -0,0 +1,6 @@
+require xorg-app-common.inc
+
+DESCRIPTION = "X11 server performance test program"
+DEPENDS += "libxmu libxrender libxft libxext fontconfig"
+PR = "r1"
+PE = "1"
diff --git a/packages/xorg-app/xauth_1.0.2.bb b/packages/xorg-app/xauth_1.0.2.bb
index 45aaafb1ce..93ddf7e828 100644
--- a/packages/xorg-app/xauth_1.0.2.bb
+++ b/packages/xorg-app/xauth_1.0.2.bb
@@ -1,7 +1,6 @@
require xorg-app-common.inc
-PE = "1"
-
-#DESCRIPTION = ""
-
-DEPENDS += " virtual/libx11 libxau libxext libxmu"
+DESCRIPTION = "X authority file utility"
+DEPENDS += "libxau libxext libxmu"
+PR = "r1"
+PE = "1"
diff --git a/packages/xorg-app/xdpyinfo_1.0.2.bb b/packages/xorg-app/xdpyinfo_1.0.2.bb
index 62825e5a0f..4764a7089f 100644
--- a/packages/xorg-app/xdpyinfo_1.0.2.bb
+++ b/packages/xorg-app/xdpyinfo_1.0.2.bb
@@ -1,10 +1,10 @@
require xorg-app-common.inc
-PE = "1"
DESCRIPTION = "X display information utility"
LICENSE = "MIT"
-
-DEPENDS += " libxtst libxext virtual/libx11 libxxf86vm libxxf86dga libxxf86misc libxi libxrender libxinerama libdmx libxp"
+DEPENDS += "libxtst libxext libxxf86vm libxxf86dga libxxf86misc libxi libxrender libxinerama libdmx libxp libxau"
+PR = "r1"
+PE = "1"
SRC_URI += "file://disable-xkb.patch;patch=1"
diff --git a/packages/xorg-app/xev-1.0.2/.mtn2git_empty b/packages/xorg-app/xev-1.0.2/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xorg-app/xev-1.0.2/.mtn2git_empty
diff --git a/packages/xorg-app/xev-1.0.2/diet-x11.patch b/packages/xorg-app/xev-1.0.2/diet-x11.patch
new file mode 100644
index 0000000000..9f515e8c73
--- /dev/null
+++ b/packages/xorg-app/xev-1.0.2/diet-x11.patch
@@ -0,0 +1,80 @@
+---
+ xev.c | 16 ++++++++--------
+ 1 file changed, 8 insertions(+), 8 deletions(-)
+
+Index: xev-1.0.2/xev.c
+===================================================================
+--- xev-1.0.2.orig/xev.c 2006-06-02 00:25:44.000000000 +0100
++++ xev-1.0.2/xev.c 2007-05-10 15:22:07.000000000 +0100
+@@ -109,7 +109,7 @@ do_KeyPress (XEvent *eventp)
+ nbytes = XLookupString (e, str, 256, &ks, NULL);
+
+ /* not supposed to call XmbLookupString on a key release event */
+- if (e->type == KeyPress && xic) {
++ /*if (e->type == KeyPress && xic) {
+ do {
+ nmbbytes = XmbLookupString (xic, e, buf, bsize - 1, &ks, &status);
+ buf[nmbbytes] = '\0';
+@@ -119,7 +119,7 @@ do_KeyPress (XEvent *eventp)
+ buf = realloc (buf, bsize);
+ }
+ } while (status == XBufferOverflow);
+- }
++ }*/
+
+ if (ks == NoSymbol)
+ ksname = "NoSymbol";
+@@ -149,7 +149,7 @@ do_KeyPress (XEvent *eventp)
+ }
+
+ /* not supposed to call XmbLookupString on a key release event */
+- if (e->type == KeyPress && xic) {
++ /*if (e->type == KeyPress && xic) {
+ printf (" XmbLookupString gives %d bytes: ", nmbbytes);
+ if (nmbbytes > 0) {
+ dump (buf, nmbbytes);
+@@ -157,7 +157,7 @@ do_KeyPress (XEvent *eventp)
+ } else {
+ printf ("\n");
+ }
+- }
++ } */
+
+ printf (" XFilterEvent returns: %s\n",
+ XFilterEvent (eventp, e->window) ? "True" : "False");
+@@ -804,7 +804,7 @@ main (int argc, char **argv)
+ fprintf (stderr, "%s: XSetLocaleModifiers failed\n", ProgramName);
+ }
+
+- xim = XOpenIM (dpy, NULL, NULL, NULL);
++ /*xim = XOpenIM (dpy, NULL, NULL, NULL);
+ if (xim == NULL) {
+ fprintf (stderr, "%s: XOpenIM failed\n", ProgramName);
+ }
+@@ -831,7 +831,7 @@ main (int argc, char **argv)
+ }
+ XFree (xim_styles);
+ }
+- }
++ }*/
+
+ screen = DefaultScreen (dpy);
+
+@@ -891,7 +891,7 @@ main (int argc, char **argv)
+ printf ("Outer window is 0x%lx, inner window is 0x%lx\n", w, subw);
+ }
+
+- if (xim && xim_style) {
++ /*if (xim && xim_style) {
+ xic = XCreateIC (xim,
+ XNInputStyle, xim_style,
+ XNClientWindow, w,
+@@ -901,7 +901,7 @@ main (int argc, char **argv)
+ if (xic == NULL) {
+ fprintf (stderr, "XCreateIC failed\n");
+ }
+- }
++ }*/
+
+ for (done = 0; !done; ) {
+ XEvent event;
diff --git a/packages/xorg-app/xev_1.0.2.bb b/packages/xorg-app/xev_1.0.2.bb
new file mode 100644
index 0000000000..b7a4070a8f
--- /dev/null
+++ b/packages/xorg-app/xev_1.0.2.bb
@@ -0,0 +1,7 @@
+require xorg-app-common.inc
+
+DESCRIPTION = "X Event Viewer"
+LICENSE = "MIT"
+PE = "1"
+
+SRC_URI += "file://diet-x11.patch;patch=1"
diff --git a/packages/xorg-app/xhost_1.0.2.bb b/packages/xorg-app/xhost_1.0.2.bb
new file mode 100644
index 0000000000..af5beadd79
--- /dev/null
+++ b/packages/xorg-app/xhost_1.0.2.bb
@@ -0,0 +1,6 @@
+require xorg-app-common.inc
+
+DESCRIPTION = "Server access control program for X"
+LICENSE = "MIT"
+DEPENDS += "libxmu libxau"
+PE = "1"
diff --git a/packages/xorg-app/xinit_1.0.4.bb b/packages/xorg-app/xinit_1.0.4.bb
new file mode 100644
index 0000000000..ce82fb05d4
--- /dev/null
+++ b/packages/xorg-app/xinit_1.0.4.bb
@@ -0,0 +1,6 @@
+require xorg-app-common.inc
+
+DESCRIPTION = "X Window System initializer"
+PE = "1"
+
+FILES_${PN} += "${libdir}X11/xinit"
diff --git a/packages/xorg-app/xmodmap_1.0.2.bb b/packages/xorg-app/xmodmap_1.0.2.bb
index b934ebfa48..4b031293a2 100644
--- a/packages/xorg-app/xmodmap_1.0.2.bb
+++ b/packages/xorg-app/xmodmap_1.0.2.bb
@@ -1,8 +1,5 @@
require xorg-app-common.inc
-PE = "1"
DESCRIPTION = "utility for modifying keymaps and pointer button mappings in X"
LICENSE = "MIT"
-
-DEPENDS += " virtual/libx11"
-
+PE = "1"
diff --git a/packages/xorg-app/xorg-app-common.inc b/packages/xorg-app/xorg-app-common.inc
index a33d107675..cd7f654be2 100644
--- a/packages/xorg-app/xorg-app-common.inc
+++ b/packages/xorg-app/xorg-app-common.inc
@@ -1,18 +1,19 @@
DESCRIPTION = "X application"
-HOMEPAGE = "http://www.x.org"
-SECTION = "x11/applications"
+HOMEPAGE = "http://www.x.org/"
+SECTION = "x11/apps"
LICENSE = "MIT-X"
+DEPENDS = "util-macros-native virtual/libx11"
-DEPENDS = "util-macros"
XORG_PN = "${PN}"
-XORG_RELEASE = "${@["individual",bb.data.getVar('PV', d, 1)[0:7]+"/src"][bb.data.getVar('PV', d, 1)[0:4] == "X11R"]}"
-SRC_URI = "${XORG_MIRROR}/${XORG_RELEASE}/app/${XORG_PN}-${PV}.tar.bz2"
-S = "${WORKDIR}/${XORG_PN}-${PV}"
-FILES_${PN} += " /usr/lib/X11/${XORG_PN}"
+SRC_URI = "${XORG_MIRROR}/individual/app/${XORG_PN}-${PV}.tar.bz2"
+
+S = "${WORKDIR}/${XORG_PN}-${PV}"
inherit autotools pkgconfig
do_stage() {
- autotools_stage_all
+ autotools_stage_all
}
+
+FILES_${PN} += " /usr/lib/X11/${XORG_PN}"
diff --git a/packages/xorg-app/xrandr/resolve_symbol_clash.patch b/packages/xorg-app/xrandr/resolve_symbol_clash.patch
index 80d8960c94..1ecf9563f6 100644
--- a/packages/xorg-app/xrandr/resolve_symbol_clash.patch
+++ b/packages/xorg-app/xrandr/resolve_symbol_clash.patch
@@ -2,11 +2,9 @@
xrandr.c | 6 +++---
1 file changed, 3 insertions(+), 3 deletions(-)
-Index: xrandr-1.2.0/xrandr.c
-===================================================================
---- xrandr-1.2.0.orig/xrandr.c 2007-02-19 05:26:50.000000000 +0000
-+++ xrandr-1.2.0/xrandr.c 2007-05-28 19:22:30.000000000 +0100
-@@ -163,7 +163,7 @@ reflection_name (Rotation rotation)
+--- xrandr-1.2.2.orig/xrandr.c
++++ xrandr-1.2.2/xrandr.c
+@@ -189,7 +189,7 @@
#if HAS_RANDR_1_2
typedef enum _policy {
@@ -15,16 +13,16 @@ Index: xrandr-1.2.0/xrandr.c
} policy_t;
typedef enum _relation {
-@@ -1398,7 +1398,7 @@ main (int argc, char **argv)
+@@ -1602,7 +1602,7 @@
+ int ret = 0;
#if HAS_RANDR_1_2
output_t *output = NULL;
- char *crtc;
- policy_t policy = clone;
+ policy_t policy = policy_clone;
Bool setit_1_2 = False;
Bool query_1_2 = False;
- Bool query_1 = False;
-@@ -1634,7 +1634,7 @@ main (int argc, char **argv)
+ Bool modeit = False;
+@@ -1863,7 +1863,7 @@
continue;
}
if (!strcmp ("--clone", argv[i])) {
diff --git a/packages/xorg-app/xrandr_1.2.2.bb b/packages/xorg-app/xrandr_1.2.2.bb
new file mode 100644
index 0000000000..05ef6af95d
--- /dev/null
+++ b/packages/xorg-app/xrandr_1.2.2.bb
@@ -0,0 +1,8 @@
+require xorg-app-common.inc
+
+DESCRIPTION = "X Resize and Rotate extension command."
+LICENSE= "BSD-X"
+DEPENDS += "libxrandr libxrender"
+PE = "1"
+
+SRC_URI += "file://resolve_symbol_clash.patch;patch=1"
diff --git a/packages/xorg-app/xrdb_1.0.3.bb b/packages/xorg-app/xrdb_1.0.3.bb
index d8a3cee728..177d3ab23b 100644
--- a/packages/xorg-app/xrdb_1.0.3.bb
+++ b/packages/xorg-app/xrdb_1.0.3.bb
@@ -2,6 +2,5 @@ require xorg-app-common.inc
DESCRIPTION = "X server resource database utility"
LICENSE = "xrdb"
-
-DEPENDS += " libxmu virtual/libx11 libxext"
+DEPENDS += "libxmu"
PE = "1"
diff --git a/packages/xorg-app/xset_1.0.2.bb b/packages/xorg-app/xset_1.0.2.bb
new file mode 100644
index 0000000000..fa2e4c25a2
--- /dev/null
+++ b/packages/xorg-app/xset_1.0.2.bb
@@ -0,0 +1,11 @@
+require xorg-app-common.inc
+
+DESCRIPTION = "user preference utility for X"
+LICENSE = "MIT"
+DEPENDS += "libxext libxxf86misc libxfontcache libxmu libxp libxau"
+PE = "1"
+
+SRC_URI += "file://disable-xkb.patch;patch=1"
+
+CFLAGS += "-D_GNU_SOURCE"
+EXTRA_OECONF = "--disable-xkb"
diff --git a/packages/xorg-app/xvinfo_1.0.1.bb b/packages/xorg-app/xvinfo_1.0.1.bb
new file mode 100644
index 0000000000..ac27f13f34
--- /dev/null
+++ b/packages/xorg-app/xvinfo_1.0.1.bb
@@ -0,0 +1,5 @@
+require xorg-app-common.inc
+
+DESCRIPTION = "Print out X-Video extension adaptor information"
+DEPENDS += " libxv"
+PE = "1"