aboutsummaryrefslogtreecommitdiffstats
path: root/packages/xorg-xserver
diff options
context:
space:
mode:
authorRaymond Danks <raymond@edanks.com>2006-07-24 22:06:25 +0000
committerRaymond Danks <raymond@edanks.com>2006-07-24 22:06:25 +0000
commit217ec5647c0dc3a86b51113f73884d7035097474 (patch)
tree16d978e66d99aacb21cd39c3637e63b1b0ce2e91 /packages/xorg-xserver
parentc22634f6db6454821a2afeff303bf897ed949573 (diff)
downloadopenembedded-217ec5647c0dc3a86b51113f73884d7035097474.tar.gz
xorg-xserver: Update for X11R7.0 and X11R7.1.
Diffstat (limited to 'packages/xorg-xserver')
-rw-r--r--packages/xorg-xserver/xorg-xserver-common.inc43
-rw-r--r--packages/xorg-xserver/xserver-xorg/drmfix.patch13
-rw-r--r--packages/xorg-xserver/xserver-xorg/miext_layer_shadow_h.patch11
-rw-r--r--packages/xorg-xserver/xserver-xorg/xorg.conf149
-rw-r--r--packages/xorg-xserver/xserver-xorg/xpconfig-parentdir.patch30
-rw-r--r--packages/xorg-xserver/xserver-xorg_X11R7.0-1.0.1.bb9
-rw-r--r--packages/xorg-xserver/xserver-xorg_X11R7.1-1.1.0.bb7
7 files changed, 262 insertions, 0 deletions
diff --git a/packages/xorg-xserver/xorg-xserver-common.inc b/packages/xorg-xserver/xorg-xserver-common.inc
new file mode 100644
index 0000000000..6c1bbd34a9
--- /dev/null
+++ b/packages/xorg-xserver/xorg-xserver-common.inc
@@ -0,0 +1,43 @@
+HOMEPAGE = "http://www.x.org"
+SECTION = "x11/base"
+#MAINTAINER = ""
+LICENSE = "MIT-X"
+
+RPROVIDES = "virtual/xserver"
+PROVIDES = "virtual/xserver"
+
+DEPENDS = "fontconfig freetype flex-native lbxutil kbproto \
+xf86driproto drm glproto randrproto renderproto fixesproto damageproto \
+xcmiscproto xextproto xproto xf86miscproto xf86vidmodeproto xf86bigfontproto \
+scrnsaverproto bigreqsproto resourceproto fontsproto inputproto \
+xf86dgaproto videoproto compositeproto trapproto recordproto dmxproto \
+resourceproto xineramaproto xtrans evieext libxkbfile libxfont libxau \
+libfontenc libxdmcp libxxf86vm libxaw libxmu libxt libxpm libxext libx11 \
+libxkbui libxxf86misc libxi libdmx libxtst libxres mesa"
+
+REPENDS="rgb"
+
+XORG_PN = "xorg-server"
+SRC_URI = "${XORG_MIRROR}/${@bb.data.getVar('PV', d, 1)[0:7]}/src/xserver/${XORG_PN}-${PV}.tar.gz \
+ file://xorg.conf"
+
+S = "${WORKDIR}/${XORG_PN}-${PV}"
+
+inherit autotools pkgconfig
+
+PACKAGES =+ "${PN}-xprint ${PN}-xvfb ${PN}-utils"
+
+FILES_${PN}-xprint = "${libdir}/X11/xserver/*/print"
+FILES_${PN}-xvfb = "${bindir}/Xvfb"
+FILES_${PN}-utils = "${bindir}/scanpci ${bindir}/pcitweak ${bindir}/ioport ${bindir}/in[bwl] ${bindir}/out[bwl] ${bindir}/mmap[rw] ${bindir}/gtf ${bindir}/getconfig ${bindir}/getconfig.pl"
+FILES_${PN} = "${bindir} ${libdir}/X11/Options ${libdir}/X11/Cards ${libdir}/X11/getconfig ${libdir}/X11/etc ${libdir}/xserver/SecurityPolicy ${libdir}/modules ${libdir}/xorg/modules /etc/X11 "
+FILES_${PN}-doc += "${libdir}/X11/doc /usr/share/X11/xkb/compiled/README.compiled"
+
+do_stage() {
+ autotools_stage_all
+}
+
+do_install_append () {
+ install -d ${D}/etc/X11
+ install -m0644 ${WORKDIR}/xorg.conf ${D}/etc/X11/
+}
diff --git a/packages/xorg-xserver/xserver-xorg/drmfix.patch b/packages/xorg-xserver/xserver-xorg/drmfix.patch
new file mode 100644
index 0000000000..04b0c1ae4f
--- /dev/null
+++ b/packages/xorg-xserver/xserver-xorg/drmfix.patch
@@ -0,0 +1,13 @@
+Index: xorg-server-X11R7.0-1.0.1/hw/xfree86/os-support/linux/Makefile.am
+===================================================================
+--- xorg-server-X11R7.0-1.0.1.orig/hw/xfree86/os-support/linux/Makefile.am
++++ xorg-server-X11R7.0-1.0.1/hw/xfree86/os-support/linux/Makefile.am
+@@ -24,7 +24,7 @@ liblinux_la_SOURCES = lnx_init.c lnx_vid
+
+ AM_CFLAGS = -DUSESTDRES -DHAVE_SYSV_IPC $(XORG_CFLAGS) @SERVER_DEFINES@ @LOADER_DEFINES@
+
+-INCLUDES = $(XORG_INCS) -I/usr/include/drm # FIXME this last part is crack
++INCLUDES = $(XORG_INCS) $(LIBDRM_CFLAGS)
+
+ # FIXME: These need to be added to the build
+ LNX_EXTRA_SOURCES = \
diff --git a/packages/xorg-xserver/xserver-xorg/miext_layer_shadow_h.patch b/packages/xorg-xserver/xserver-xorg/miext_layer_shadow_h.patch
new file mode 100644
index 0000000000..fbade4319a
--- /dev/null
+++ b/packages/xorg-xserver/xserver-xorg/miext_layer_shadow_h.patch
@@ -0,0 +1,11 @@
+--- temp/xorg-server-X11R7.0-1.0.1/miext/layer/Makefile.am 2005-12-01 23:02:44.000000000 -0700
++++ xorg-server-X11R7.0-1.0.1/miext/layer/Makefile.am 2006-04-18 23:16:04.315823560 -0600
+@@ -2,7 +2,7 @@
+
+ AM_CFLAGS = $(DIX_CFLAGS) @SERVER_DEFINES@ @MODULE_DEFINES@ @LOADER_DEFINES@
+
+-INCLUDES = -I$(top_srcdir)/hw/xfree86/os-support
++INCLUDES = -I$(top_srcdir)/miext/shadow -I$(top_srcdir)/hw/xfree86/os-support
+
+ liblayer_la_SOURCES = \
+ layer.h \
diff --git a/packages/xorg-xserver/xserver-xorg/xorg.conf b/packages/xorg-xserver/xserver-xorg/xorg.conf
new file mode 100644
index 0000000000..34f4465764
--- /dev/null
+++ b/packages/xorg-xserver/xserver-xorg/xorg.conf
@@ -0,0 +1,149 @@
+
+# xorg configuration
+
+Section "ServerLayout"
+ Identifier "Default Layout"
+ Screen 0 "Screen0" 0 0
+ InputDevice "Mouse0" "CorePointer"
+ InputDevice "Keyboard0" "CoreKeyboard"
+EndSection
+
+Section "Files"
+
+# RgbPath is the location of the RGB database. Note, this is the name of the
+# file minus the extension (like ".txt" or ".db"). There is normally
+# no need to change the default.
+# Multiple FontPath entries are allowed (they are concatenated together)
+# By default, Red Hat 6.0 and later now use a font server independent of
+# the X server to render fonts.
+# FontPath "unix/:7100"
+ FontPath "/usr/lib/X11/fonts/misc"
+EndSection
+
+Section "Module"
+ Load "dbe"
+ Load "extmod"
+ Load "fbdevhw"
+# Load "glx"
+ Load "record"
+ Load "freetype"
+ Load "type1"
+# to enable Xv, link /dev/videox to video device, eg. ln -s video0 /dev/videox
+# Load "z4l"
+EndSection
+
+Section "InputDevice"
+
+# Specify which keyboard LEDs can be user-controlled (eg, with xset(1))
+# Option "Xleds" "1 2 3"
+# To disable the XKEYBOARD extension, uncomment XkbDisable.
+# Option "XkbDisable"
+# To customise the XKB settings to suit your keyboard, modify the
+# lines below (which are the defaults). For example, for a non-U.S.
+# keyboard, you will probably want to use:
+# Option "XkbModel" "pc102"
+# If you have a US Microsoft Natural keyboard, you can use:
+# Option "XkbModel" "microsoft"
+#
+# Then to change the language, change the Layout setting.
+# For example, a german layout can be obtained with:
+# Option "XkbLayout" "de"
+# or:
+# Option "XkbLayout" "de"
+# Option "XkbVariant" "nodeadkeys"
+#
+# If you'd like to switch the positions of your capslock and
+# control keys, use:
+# Option "XkbOptions" "ctrl:swapcaps"
+# Or if you just want both to be control, use:
+# Option "XkbOptions" "ctrl:nocaps"
+#
+ Identifier "Keyboard0"
+ Driver "keyboard"
+ Option "XkbModel" "pc105"
+ Option "XkbLayout" "us"
+EndSection
+
+Section "InputDevice"
+ Identifier "Mouse0"
+ Driver "mouse"
+ Option "Protocol" "PS/2"
+# Option "Protocol" "IMPS/2"
+ Option "Device" "/dev/psaux"
+# Option "Device" "/dev/input/mice"
+ Option "ZAxisMapping" "4 5"
+ Option "Emulate3Buttons" "yes"
+EndSection
+
+Section "Monitor"
+ Identifier "Monitor0"
+ VendorName "Monitor Vendor"
+ ModelName "NEC FP2141SB"
+# DisplaySize 400 300
+# Note: setting HorizSync/VertRefresh will override DDC probe
+# HorizSync 30.0 - 140.0
+# VertRefresh 25.0 - 160.0
+ Option "dpms"
+EndSection
+
+Section "Monitor"
+ Identifier "Monitor1"
+ VendorName "Generic Vendor"
+ ModelName "Generic Monitor"
+ HorizSync 28-50
+ VertRefresh 43-73
+ Modeline "800x600-60" 40.0000 800 840 976 1056 600 601 605 628
+ Modeline "800x600-72" 50.0000 800 856 976 1040 600 637 643 666
+ Modeline "640x480-60" 25.1749 640 656 744 800 480 490 492 525 -HSync -VSync
+ Modeline "640x480-72" 31.5000 640 664 704 832 480 489 492 520 -HSync -VSync
+ Option "dpms"
+EndSection
+
+
+Section "Device"
+ Identifier "Videocard0"
+ Driver "s3"
+# Driver "nv"
+ VendorName "Videocard vendor"
+ BoardName "S3 driver"
+ #BoardName "NVidia driver"
+EndSection
+
+Section "Device"
+ Identifier "FBDev"
+ Driver "fbdev"
+ #Option "shadowfb" "off"
+ VideoRam 4096
+EndSection
+
+Section "Screen"
+ Identifier "Screen0"
+ Device "Videocard0"
+ Monitor "Monitor0"
+# DefaultDepth 8
+ DefaultDepth 16
+# DefaultDepth 24
+
+ SubSection "Display"
+ Depth 8
+ Modes "1024x768" "800x600" "640x480"
+ EndSubsection
+
+ SubSection "Display"
+ Depth 16
+ Modes "1024x768" "800x600" "640x480"
+ EndSubsection
+
+ SubSection "Display"
+ Depth 24
+ FbBpp 32
+ Modes "1024x768" "800x600" "640x480"
+ EndSubsection
+
+EndSection
+
+Section "DRI"
+ Group 0
+ Mode 0666
+EndSection
+
diff --git a/packages/xorg-xserver/xserver-xorg/xpconfig-parentdir.patch b/packages/xorg-xserver/xserver-xorg/xpconfig-parentdir.patch
new file mode 100644
index 0000000000..17d05d3ff8
--- /dev/null
+++ b/packages/xorg-xserver/xserver-xorg/xpconfig-parentdir.patch
@@ -0,0 +1,30 @@
+--- xorg-server-X11R7.0-1.0.1/XpConfig/C/print/models/HPLJ4050-PS/fonts/Makefile.am.orig 2006-06-23 10:20:42.126095128 -0600
++++ xorg-server-X11R7.0-1.0.1/XpConfig/C/print/models/HPLJ4050-PS/fonts/Makefile.am 2006-06-23 10:20:50.923757680 -0600
+@@ -1,6 +1,6 @@
+ xpcdir = @xpconfigdir@/C/print/models/HPLJ4050-PS/fonts
+
+-parentdir = $(DESTDIR)/@xpconfigdir@/C/print/models/PSdefault/fonts
++parentdir = @xpconfigdir@/C/print/models/PSdefault/fonts
+
+ XPFONTS = \
+ AvantGarde-Book.pmf \
+--- xorg-server-X11R7.0-1.0.1/XpConfig/C/print/models/CANONC3200-PS/fonts/Makefile.am.orig 2006-06-23 10:21:02.877940368 -0600
++++ xorg-server-X11R7.0-1.0.1/XpConfig/C/print/models/CANONC3200-PS/fonts/Makefile.am 2006-06-23 10:21:11.903568264 -0600
+@@ -1,6 +1,6 @@
+ xpcdir = @xpconfigdir@/C/print/models/CANONC3200-PS/fonts
+
+-parentdir = $(DESTDIR)/@xpconfigdir@/C/print/models/PSdefault/fonts
++parentdir = @xpconfigdir@/C/print/models/PSdefault/fonts
+
+ XPFONTS = \
+ AvantGarde-Book.pmf \
+--- xorg-server-X11R7.0-1.0.1/XpConfig/C/print/models/SPSPARC2/fonts/Makefile.am.orig 2006-06-23 10:21:22.893897480 -0600
++++ xorg-server-X11R7.0-1.0.1/XpConfig/C/print/models/SPSPARC2/fonts/Makefile.am 2006-06-23 10:21:28.412058592 -0600
+@@ -1,6 +1,6 @@
+ xpcdir = @xpconfigdir@/C/print/models/SPSPARC2/fonts
+
+-parentdir = $(DESTDIR)/@xpconfigdir@/C/print/models/PSdefault/fonts
++parentdir = @xpconfigdir@/C/print/models/PSdefault/fonts
+
+ XPFONTS = \
+ Courier-Bold.pmf \
diff --git a/packages/xorg-xserver/xserver-xorg_X11R7.0-1.0.1.bb b/packages/xorg-xserver/xserver-xorg_X11R7.0-1.0.1.bb
new file mode 100644
index 0000000000..bfde2f732e
--- /dev/null
+++ b/packages/xorg-xserver/xserver-xorg_X11R7.0-1.0.1.bb
@@ -0,0 +1,9 @@
+include xorg-xserver-common.inc
+
+#DESCRIPTION = ""
+
+#DEPENDS += " "
+
+SRC_URI += " file://miext_layer_shadow_h.patch;patch=1 \
+ file://xpconfig-parentdir.patch;patch=1"
+
diff --git a/packages/xorg-xserver/xserver-xorg_X11R7.1-1.1.0.bb b/packages/xorg-xserver/xserver-xorg_X11R7.1-1.1.0.bb
new file mode 100644
index 0000000000..674f1e5e64
--- /dev/null
+++ b/packages/xorg-xserver/xserver-xorg_X11R7.1-1.1.0.bb
@@ -0,0 +1,7 @@
+include xorg-xserver-common.inc
+
+SRC_URI += "file://drmfix.patch;patch=1"
+
+#DESCRIPTION = ""
+
+#DEPENDS += " "