aboutsummaryrefslogtreecommitdiffstats
path: root/packages/xserver-common
diff options
context:
space:
mode:
authorMatthias Hentges <oe@hentges.net>2006-04-13 17:58:36 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-04-13 17:58:36 +0000
commit8519af8d84d717ca002b76b566d9d428c3c1b0b8 (patch)
treeb2dedb8ec27c928ccc38e39ec02a0e2ed694c50c /packages/xserver-common
parentdf0341184ea4343576ee864926c1a99db4d10e41 (diff)
downloadopenembedded-8519af8d84d717ca002b76b566d9d428c3c1b0b8.tar.gz
xserver-common: Add 200DPI fix and zaurusd/calibrate fix from .oz354x
Diffstat (limited to 'packages/xserver-common')
-rw-r--r--packages/xserver-common/files/Xdefaults-200DPI.patch7
-rw-r--r--packages/xserver-common/files/calibrate_zaurusd.patch12
-rw-r--r--packages/xserver-common/files/setDPI.sh92
-rw-r--r--packages/xserver-common/xserver-common_1.8.bb12
4 files changed, 111 insertions, 12 deletions
diff --git a/packages/xserver-common/files/Xdefaults-200DPI.patch b/packages/xserver-common/files/Xdefaults-200DPI.patch
deleted file mode 100644
index 8931bfd0a9..0000000000
--- a/packages/xserver-common/files/Xdefaults-200DPI.patch
+++ /dev/null
@@ -1,7 +0,0 @@
---- xserver-common-1.8/X11/Xdefaults.orig 2006-04-08 11:08:35.158478256 +0200
-+++ xserver-common-1.8/X11/Xdefaults 2006-04-08 11:08:42.711330048 +0200
-@@ -1,3 +1,2 @@
- Rxvt*scrollBar_right: true
--Rxvt*font: xft:Mono:pixelsize=9
--Xft.dpi: 100
-+Rxvt*font: xft:Mono:pixelsize=12
diff --git a/packages/xserver-common/files/calibrate_zaurusd.patch b/packages/xserver-common/files/calibrate_zaurusd.patch
new file mode 100644
index 0000000000..6a7e3b02b7
--- /dev/null
+++ b/packages/xserver-common/files/calibrate_zaurusd.patch
@@ -0,0 +1,12 @@
+--- xserver-common-1.8/X11/Xinit.d/30xTs_Calibrate.orig 2006-04-09 15:12:16.167950472 +0200
++++ xserver-common-1.8/X11/Xinit.d/30xTs_Calibrate 2006-04-09 15:14:51.511334688 +0200
+@@ -2,4 +2,9 @@
+
+ if [ ! -f /etc/pointercal ]; then
+ /usr/bin/run-calibrate.sh
++
++ if [ -x /etc/init.d/zaurusd ]; then
++ /etc/init.d/zaurusd stop
++ /etc/init.d/zaurusd start
++ fi
+ fi
diff --git a/packages/xserver-common/files/setDPI.sh b/packages/xserver-common/files/setDPI.sh
new file mode 100644
index 0000000000..04a2edd6c6
--- /dev/null
+++ b/packages/xserver-common/files/setDPI.sh
@@ -0,0 +1,92 @@
+#! /bin/sh
+#
+# Copyright Matthias Hentges <devel@hentges.net> (c) 2006
+# License: GPL (see http://www.gnu.org/licenses/gpl.txt for a copy of the license)
+#
+# Filename: setDPI.sh
+# Date: 09-Apr-06
+
+# This script configures Xft.dpi dependent on your screens DPI. This insures that the same font-size
+# setting of 7 can be used on all machines.
+
+
+XDEFAULTS="/etc/X11/Xdefaults"
+
+
+
+set_dpi() {
+
+ CURRENT_SETTING="`cat ${XDEFAULTS} | sed -n "/Xft.dpi\:/s/.*\:\(.*\)/\1/p" | sed -n "s/\ //p"`"
+
+ if test "$CURRENT_SETTING" != "$1"
+ then
+ echo "Using Xft.dpi of $SET_SCREEN_DPI for your $SCREEN_DPI DPI screen"
+
+ if grep -q "Xft.dpi" "$XDEFAULTS"
+ then
+ cat "${XDEFAULTS}" | sed "s/^Xft.dpi\:.*/Xft.dpi\: $SET_SCREEN_DPI/" > "${XDEFAULTS}_"
+ mv "${XDEFAULTS}_" "${XDEFAULTS}"
+ else
+ echo -e "Xft.dpi: $SET_SCREEN_DPI\n" >> "$XDEFAULTS"
+ fi
+ else
+ echo "Your $SCREEN_DPI DPI screen is already configured."
+ fi
+}
+
+set_rxvt_font() {
+
+ CURRENT_SETTING="`cat ${XDEFAULTS} | sed -n "/Rxvt\*font/s/\(.*\pixelsize=\)\(.*\)/\2/p"`"
+
+ if test "$1" -gt 100
+ then
+
+ # Configure the rxvt font-size for your screen here:
+ test "$1" -gt 180 -a "$1" -lt "221" && RXVT_FONT_SIZE=16
+
+ if test -z "$RXVT_FONT_SIZE"
+ then
+ echo "WARNING: No rxvt font-size configured for a $SCREEN_DPI DPI screen!"
+ echo "Defaulting to size 9"
+ RXVT_FONT_SIZE=9
+ fi
+
+ if test "$CURRENT_SETTING" != "$RXVT_FONT_SIZE"
+ then
+ echo "Using a rxvt font-size of $RXVT_FONT_SIZE"
+ cat ${XDEFAULTS} | sed "/Rxvt\*font/s/\(.*\pixelsize\)\(=*.*\)/\1=$RXVT_FONT_SIZE/" > ${XDEFAULTS}_
+ mv ${XDEFAULTS}_ ${XDEFAULTS}
+ else
+ echo "The rxvt font-size is already configured"
+ fi
+ fi
+}
+
+if test -z "$DISPLAY"
+then
+ echo "DISPLAY is not set, aborting..."
+ exit 0
+fi
+
+SCREEN_DPI="`/usr/bin/xdpyinfo | grep "dots per inch" | awk '{print $2}'| sed -n "s/\(.*\)x\(.*\)/\2/p"`"
+
+if test -z "$SCREEN_DPI"
+then
+ echo "WARNING: Couldn't read your screens DPI, defaulting to 100"
+ SCREEN_DPI=100
+fi
+
+# Configure your screen here:
+test "$SCREEN_DPI" -gt 180 -a "$SCREEN_DPI" -lt "221" && SET_SCREEN_DPI=160
+test "$SCREEN_DPI" -gt 90 -a "$SCREEN_DPI" -lt "121" && SET_SCREEN_DPI=100
+
+
+if test -z "$SET_SCREEN_DPI"
+then
+ echo "WARNING: No default configuration found for your $SCREEN_DPI DPI screen!"
+ echo "Using 100 DPI"
+ SET_SCREEN_DPI=100
+fi
+
+set_dpi "$SET_SCREEN_DPI"
+set_rxvt_font "$SCREEN_DPI"
diff --git a/packages/xserver-common/xserver-common_1.8.bb b/packages/xserver-common/xserver-common_1.8.bb
index 19ae2ba851..b7b3f554f3 100644
--- a/packages/xserver-common/xserver-common_1.8.bb
+++ b/packages/xserver-common/xserver-common_1.8.bb
@@ -3,14 +3,16 @@ DESCRIPTION = "Common X11 scripts and support files"
LICENSE = "GPL"
SECTION = "x11"
RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo xtscal"
-PR = "r1"
+PR = "r2"
PACKAGE_ARCH = "all"
# we are using a gpe-style Makefile
inherit gpe
-SRC_URI_append_akita = " file://Xdefaults-200DPI.patch;patch=1"
-SRC_URI_append_spitz = " file://Xdefaults-200DPI.patch;patch=1"
-SRC_URI_append_c7x0 = " file://Xdefaults-200DPI.patch;patch=1"
-SRC_URI_append_tosa = " file://Xdefaults-200DPI.patch;patch=1"
+SRC_URI_append = " file://setDPI.sh \
+ file://calibrate_zaurusd.patch;patch=1"
+
+do_install_append() {
+ install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"
+}