aboutsummaryrefslogtreecommitdiffstats
path: root/packages/xserver-common
diff options
context:
space:
mode:
authorGraeme Gregory <dp@xora.org.uk>2007-01-07 22:27:20 +0000
committerGraeme Gregory <dp@xora.org.uk>2007-01-07 22:27:20 +0000
commitecff50f02bd9522581e48a0b81f06d5589b54224 (patch)
treef73adb96eca912af8032a66df0b92c7036b47871 /packages/xserver-common
parent1fc4abac48c1245a2ea53fc270ab2a07fb2606f8 (diff)
downloadopenembedded-ecff50f02bd9522581e48a0b81f06d5589b54224.tar.gz
xserver-common_1.13.bb : add Ximageon support
Diffstat (limited to 'packages/xserver-common')
-rw-r--r--packages/xserver-common/files/xserver-imageon.patch14
-rw-r--r--packages/xserver-common/xserver-common_1.13.bb5
2 files changed, 17 insertions, 2 deletions
diff --git a/packages/xserver-common/files/xserver-imageon.patch b/packages/xserver-common/files/xserver-imageon.patch
new file mode 100644
index 0000000000..6a0447a31f
--- /dev/null
+++ b/packages/xserver-common/files/xserver-imageon.patch
@@ -0,0 +1,14 @@
+Index: xserver-common-1.13/X11/Xserver
+===================================================================
+--- xserver-common-1.13.orig/X11/Xserver
++++ xserver-common-1.13/X11/Xserver
+@@ -17,6 +17,9 @@ fi
+ if [ -f /usr/bin/Xw100 ]; then
+ XSERVER=Xw100
+ fi
++if [ -f /usr/bin/Ximageon ]; then
++ XSERVER=Ximageon
++fi
+
+ . /etc/profile
+
diff --git a/packages/xserver-common/xserver-common_1.13.bb b/packages/xserver-common/xserver-common_1.13.bb
index d14cad725b..b051b5aea2 100644
--- a/packages/xserver-common/xserver-common_1.13.bb
+++ b/packages/xserver-common/xserver-common_1.13.bb
@@ -2,14 +2,15 @@ DESCRIPTION = "Common X11 scripts and support files"
LICENSE = "GPL"
SECTION = "x11"
RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo xtscal"
-PR = "r0"
+PR = "r1"
PACKAGE_ARCH = "all"
# we are using a gpe-style Makefile
inherit gpe
-SRC_URI_append = " file://setDPI.sh"
+SRC_URI_append = " file://setDPI.sh \
+ file://xserver-imageon.patch;patch=1"
do_install_append() {
install -m 0755 "${WORKDIR}/setDPI.sh" "${D}/etc/X11/Xinit.d/50setdpi"