aboutsummaryrefslogtreecommitdiffstats
path: root/packages/xserver-common
diff options
context:
space:
mode:
authorJustin Patrin <papercrane@gmail.com>2005-09-12 18:44:46 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-12 18:44:46 +0000
commit609098b39f1aa30e84e10d94bc49439915aa9d5a (patch)
treec1db4d12f2c7774513d58f78f29753b21e254430 /packages/xserver-common
parentc0d3aa46af8159efdbe9e6b95a74dae11701fd86 (diff)
downloadopenembedded-609098b39f1aa30e84e10d94bc49439915aa9d5a.tar.gz
xserver-common: fix portrait startup rotation for Cxx00
Diffstat (limited to 'packages/xserver-common')
-rw-r--r--packages/xserver-common/files/.mtn2git_empty0
-rw-r--r--packages/xserver-common/files/cxk-rotation.patch24
-rw-r--r--packages/xserver-common/xserver-common_1.1.bb3
3 files changed, 26 insertions, 1 deletions
diff --git a/packages/xserver-common/files/.mtn2git_empty b/packages/xserver-common/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/xserver-common/files/.mtn2git_empty
diff --git a/packages/xserver-common/files/cxk-rotation.patch b/packages/xserver-common/files/cxk-rotation.patch
new file mode 100644
index 0000000000..f29d052d8d
--- /dev/null
+++ b/packages/xserver-common/files/cxk-rotation.patch
@@ -0,0 +1,24 @@
+diff -Nur xserver-common-1.1~/X11/Xinit.d/11zaurus xserver-common-1.1/X11/Xinit.d/11zaurus
+--- xserver-common-1.1~/X11/Xinit.d/11zaurus 2005-08-29 03:52:46.000000000 -0700
++++ xserver-common-1.1/X11/Xinit.d/11zaurus 2005-09-12 11:03:37.000000000 -0700
+@@ -5,8 +5,19 @@
+ exit 0
+ fi
+
++module_id() {
++ # Get model name
++ echo `grep "^Hardware" /proc/cpuinfo | sed -e "s/.*: *//" | tr a-z A-Z`
++}
++
+ chkhinge -e
+ if [ $? = 12 ]; then
+- xrandr -o right
++ case `module_id` in
++ *SPITZ | *AKITA | *BORZOI)
++ DIRECTION="left" ;;
++ default)
++ DIRECTION="right" ;;
++ esac
++ xrandr -o $DIRECTION
+ fi
+
diff --git a/packages/xserver-common/xserver-common_1.1.bb b/packages/xserver-common/xserver-common_1.1.bb
index 70e689c9d8..76bd376365 100644
--- a/packages/xserver-common/xserver-common_1.1.bb
+++ b/packages/xserver-common/xserver-common_1.1.bb
@@ -4,8 +4,9 @@ LICENSE = "GPL"
SECTION = "x11"
DEPENDS = "xmodmap xrandr xdpyinfo xtscal"
RDEPENDS_${PN} = "xmodmap xrandr xdpyinfo xtscal"
-PR = "r2"
+PR = "r3"
# we are using a gpe-style Makefile
inherit gpe
+SRC_URI += "file://cxk-rotation.patch;patch=1" \ No newline at end of file