aboutsummaryrefslogtreecommitdiffstats
path: root/packages/xserver-kdrive-common
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-11-23 18:04:45 +0000
committerKoen Kooi <koen@openembedded.org>2007-11-23 18:04:45 +0000
commit45599d4b4e1f51d0f4ca45dafd6a5d04c928141a (patch)
tree7d6c0384fff579e6b4face2be441bc8820fc7b74 /packages/xserver-kdrive-common
parent5e6c914ed64c0806f598be4cb5f8c751c5f6bac5 (diff)
downloadopenembedded-45599d4b4e1f51d0f4ca45dafd6a5d04c928141a.tar.gz
xserver-kdrive-common: use Xglamo for gta02, remove some of the bogus Xserver checks
* if a Xserver is in /usr/bin doesn't mean the it's the right server for the job
Diffstat (limited to 'packages/xserver-kdrive-common')
-rw-r--r--packages/xserver-kdrive-common/xserver-kdrive-common/Xserver20
-rw-r--r--packages/xserver-kdrive-common/xserver-kdrive-common_0.1.bb2
2 files changed, 15 insertions, 7 deletions
diff --git a/packages/xserver-kdrive-common/xserver-kdrive-common/Xserver b/packages/xserver-kdrive-common/xserver-kdrive-common/Xserver
index c5c0fd6cac..a9893cdadf 100644
--- a/packages/xserver-kdrive-common/xserver-kdrive-common/Xserver
+++ b/packages/xserver-kdrive-common/xserver-kdrive-common/Xserver
@@ -2,7 +2,6 @@
#
# note xinit needs full server path
-XSERVER=/usr/bin/Xipaq
if [ -f /usr/bin/Xfbdev ]; then
XSERVER=/usr/bin/Xfbdev
fi
@@ -12,9 +11,6 @@ fi
if [ -f /usr/bin/Xorg ]; then
XSERVER=/usr/bin/Xorg
fi
-if [ -f /usr/bin/Xomap ]; then
- XSERVER=/usr/bin/Xomap
-fi
. /etc/profile
@@ -104,15 +100,27 @@ case `module_id` in
"Compulab CM-x270")
modprobe mbxfb
ARGS="$ARGS -fb /dev/fb1" ;;
- "GTA01" | "GTA02")
+ "GTA01")
if [ `screen_width` -gt 330 ] ; then
DPI=285
else
DPI=140
fi
ARGS="$ARGS -dpi ${DPI} -screen ${SCREEN_SIZE}" ;;
+ "GTA02")
+ if [ `screen_width` -gt 330 ] ; then
+ DPI=285
+ else
+ DPI=140
+ fi
+ ARGS="$ARGS -dpi ${DPI} -screen ${SCREEN_SIZE}"
+ XSERVER=/usr/bin/Xglamo ;;
+ "Nokia N770")
+ ARGS="$ARGS -dpi 225 -screen ${SCREEN_SIZE} -mouse tslib"
+ XSERVER=/usr/bin/Xomap ;;
"Nokia N800")
- ARGS="$ARGS -dpi 225 -screen ${SCREEN_SIZE} -mouse tslib" ;;
+ ARGS="$ARGS -dpi 225 -screen ${SCREEN_SIZE} -mouse tslib"
+ XSERVER=/usr/bin/Xomap ;;
"Motorola Ezx Platform")
ARGS="$ARGS -dpi 170 -screen ${SCREEN_SIZE}" ;;
*)
diff --git a/packages/xserver-kdrive-common/xserver-kdrive-common_0.1.bb b/packages/xserver-kdrive-common/xserver-kdrive-common_0.1.bb
index 93b9d9e83d..1adc5b3cc5 100644
--- a/packages/xserver-kdrive-common/xserver-kdrive-common_0.1.bb
+++ b/packages/xserver-kdrive-common/xserver-kdrive-common_0.1.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "Common X11 scripts"
LICENSE = "GPL"
SECTION = "x11"
RDEPENDS_${PN} = "xmodmap libxrandr xdpyinfo xtscal xinit"
-PR = "r21"
+PR = "r22"
SRC_URI = "\
file://Xdefaults \