aboutsummaryrefslogtreecommitdiffstats
path: root/packages/zaurus-updater/zaurus-updater.bb
diff options
context:
space:
mode:
authorRichard Purdie <rpurdie@rpsys.net>2005-09-11 19:29:12 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-09-11 19:29:12 +0000
commit5bab83c6066bec5243b74e0842d6017e345fa141 (patch)
tree18f1e0be615b0971b7cf21036118e5c713135361 /packages/zaurus-updater/zaurus-updater.bb
parent39c4dfc4f4d95abef3a32cb4197a693d2789b410 (diff)
downloadopenembedded-5bab83c6066bec5243b74e0842d6017e345fa141.tar.gz
zaurus-updater: The tar utility found on the Sharp inbuilt root filesystems used for reflashing the devices has bugs, one being that it won't create device files. We therefore need an external sane tar binary to successfully extract the root filesystem onto the device. This adds such a binary for spitz and borzoi.
Diffstat (limited to 'packages/zaurus-updater/zaurus-updater.bb')
-rw-r--r--packages/zaurus-updater/zaurus-updater.bb11
1 files changed, 10 insertions, 1 deletions
diff --git a/packages/zaurus-updater/zaurus-updater.bb b/packages/zaurus-updater/zaurus-updater.bb
index c4db1055d5..7707e48eeb 100644
--- a/packages/zaurus-updater/zaurus-updater.bb
+++ b/packages/zaurus-updater/zaurus-updater.bb
@@ -3,7 +3,8 @@ DEPENDS = "encdec-updater-native"
LICENSE = "zaurus-updater"
PR = "r2"
-SRC_URI = "file://updater.sh"
+SRC_URI = "file://updater.sh \
+ file://gnu-tar.gz"
S = "${WORKDIR}"
do_compile() {
@@ -13,6 +14,14 @@ do_compile() {
do_deploy() {
install -d ${DEPLOY_DIR}/images/
install -m 0755 updater.sh ${DEPLOY_DIR}/images/updater.sh.${MACHINE}
+
+ case ${MACHINE} in
+ spitz | borzoi )
+ install -m 0755 gnu-tar ${DEPLOY_DIR}/images/gnu-tar
+ ;;
+ *)
+ ;;
+ esac
}
addtask deploy before do_build after do_compile