aboutsummaryrefslogtreecommitdiffstats
path: root/packages/zcip
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2005-06-30 08:19:37 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2005-06-30 08:19:37 +0000
commitc8e5702127e507e82e6f68a4b8c546803accea9d (patch)
tree00583491f40ecc640f2b28452af995e3a63a09d7 /packages/zcip
parent87ec8ca4d2e2eb4d1c1e1e1a6b46a395d56805b9 (diff)
downloadopenembedded-c8e5702127e507e82e6f68a4b8c546803accea9d.tar.gz
import clean BK tree at cset 1.3670
Diffstat (limited to 'packages/zcip')
-rw-r--r--packages/zcip/.mtn2git_empty0
-rw-r--r--packages/zcip/zcip-4/.mtn2git_empty0
-rw-r--r--packages/zcip/zcip-4/char-signed-idiocy.patch16
-rw-r--r--packages/zcip/zcip-4/compile.patch125
-rw-r--r--packages/zcip/zcip-4/linux-types.patch15
5 files changed, 156 insertions, 0 deletions
diff --git a/packages/zcip/.mtn2git_empty b/packages/zcip/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/zcip/.mtn2git_empty
diff --git a/packages/zcip/zcip-4/.mtn2git_empty b/packages/zcip/zcip-4/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/zcip/zcip-4/.mtn2git_empty
diff --git a/packages/zcip/zcip-4/char-signed-idiocy.patch b/packages/zcip/zcip-4/char-signed-idiocy.patch
index e69de29bb2..109efc2349 100644
--- a/packages/zcip/zcip-4/char-signed-idiocy.patch
+++ b/packages/zcip/zcip-4/char-signed-idiocy.patch
@@ -0,0 +1,16 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- zcip-4/zcip.c~char-signed-idiocy
++++ zcip-4/zcip.c
+@@ -1243,7 +1243,7 @@
+
+ int main(int argc, char *argv[]) {
+ int r, rand_seed = 0;
+- char c;
++ int c;
+ char ebuf[LIBNET_ERRBUF_SIZE];
+
+ struct option longopts[] = {
diff --git a/packages/zcip/zcip-4/compile.patch b/packages/zcip/zcip-4/compile.patch
index e69de29bb2..a8cfa32cd8 100644
--- a/packages/zcip/zcip-4/compile.patch
+++ b/packages/zcip/zcip-4/compile.patch
@@ -0,0 +1,125 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- zcip-4/Makefile~compile
++++ zcip-4/Makefile
+@@ -5,21 +5,17 @@
+ CPPFLAGS=`libnet-config --cflags` `libnet-config --defines`
+ CFLAGS=-O2 -Wall -W -I/usr/local/contrib/include -I/usr/local/include/pcap
+ LDFLAGS=-L/usr/local/contrib/lib -L/usr/local/lib -static
+-
+-
++LIBS=-lpcap `libnet-config --libs`
+ OBJS=zcip.o
+
+-
+-
+-
+ all: zcip make-arp
+
+
+ make-arp: make-arp.o
+- $(CC) make-arp.o $(LDFLAGS) -o make-arp -lpcap `libnet-config --libs`
++ $(CC) make-arp.o $(LDFLAGS) -o make-arp $(LIBS)
+
+ zcip: $(OBJS)
+- $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o zcip -lpcap `libnet-config --libs`
++ $(CC) -Wall -W $(OBJS) $(LDFLAGS) -o zcip $(LIBS)
+
+
+ clean:
+--- zcip-4/zcip.c~compile
++++ zcip-4/zcip.c
+@@ -1204,14 +1204,14 @@
+ }
+
+ void version(void) {
+- printf("zcip release " RELEASE "
+-Copyright (C) 2001-2002 Various authors
+-zcip comes with NO WARRANTY,
+-to the extent permitted by law.
+-You may redistribute copies of zcip
+-under the terms of the 3-clause BSD license.
+-For more information about these matters,
+-see the file named Copyright.
++ printf("zcip release " RELEASE "\n\
++Copyright (C) 2001-2002 Various authors\n\
++zcip comes with NO WARRANTY,\n\
++to the extent permitted by law.\n\
++You may redistribute copies of zcip\n\
++under the terms of the 3-clause BSD license.\n\
++For more information about these matters,\n\
++see the file named Copyright.\n\
+ ");
+
+ exit (0);
+@@ -1219,19 +1219,19 @@
+
+
+ void usage(int exit_code) {
+- printf("usage: zcip [OPTIONS]
+-Zeroconf IPv4 Link-Local Address Configuration
+-OPTIONS:
+- -h, --help Print this help, and exit.
+- -i, --interface IFNAME Use interface IFNAME.
+- If not provided it uses 'eth0'.
+- -r, --randseed Seeds RNG with random # rather than MAC address.
+- -s, --syslog Output to syslog instead of stdout.
+- -v, --version Print the version information, and exit.
+-
+-This program does the ad-hoc link-local IPv4 auto-configuration trick, as
+-described in the IETF Internet Draft 'Dynamic Configuration of IPv4
+-Link-Local Addresses'.
++ printf("usage: zcip [OPTIONS]\n\
++Zeroconf IPv4 Link-Local Address Configuration\n\
++OPTIONS:\n\
++ -h, --help Print this help, and exit.\n\
++ -i, --interface IFNAME Use interface IFNAME.\n\
++ If not provided it uses 'eth0'.\n\
++ -r, --randseed Seeds RNG with random # rather than MAC address.\n\
++ -s, --syslog Output to syslog instead of stdout.\n\
++ -v, --version Print the version information, and exit.\n\
++\n\
++This program does the ad-hoc link-local IPv4 auto-configuration trick, as\n\
++described in the IETF Internet Draft 'Dynamic Configuration of IPv4\n\
++Link-Local Addresses'.\n\
+ ");
+
+ exit (exit_code);
+--- zcip-4/make-arp.c~compile
++++ zcip-4/make-arp.c
+@@ -106,19 +106,19 @@
+
+
+ void usage(int exit_code) {
+- printf("
+-make-arp -- sends arbitrary ARP Requests
+-
+-usage: make-arp [OPTIONS] [sea=SOURCE-EA] [sip=SOURCE-IP] tea=TARGET-EA tip=TARGET-IP
+-
+-OPTIONS:
+-
+- -h Print this help.
+-
+-
+-Only ARP Requests for now. In the Ethernet header, the source EA is
+-mine and the target EA is the broadcast address FF:FF:FF:FF:FF:FF.
+-
++ printf("\n\
++make-arp -- sends arbitrary ARP Requests\n\
++\n\
++usage: make-arp [OPTIONS] [sea=SOURCE-EA] [sip=SOURCE-IP] tea=TARGET-EA tip=TARGET-IP\n\
++\n\
++OPTIONS:\n\
++\n\
++ -h Print this help.\n\
++\n\
++\n\
++Only ARP Requests for now. In the Ethernet header, the source EA is\n\
++mine and the target EA is the broadcast address FF:FF:FF:FF:FF:FF.\n\
++\n\
+ ");
+
+ exit (exit_code);
diff --git a/packages/zcip/zcip-4/linux-types.patch b/packages/zcip/zcip-4/linux-types.patch
index e69de29bb2..5ca388cafc 100644
--- a/packages/zcip/zcip-4/linux-types.patch
+++ b/packages/zcip/zcip-4/linux-types.patch
@@ -0,0 +1,15 @@
+
+#
+# Patch managed by http://www.mn-logistik.de/unsupported/pxa250/patcher
+#
+
+--- zcip-4/zcip.c~linux-types
++++ zcip-4/zcip.c
+@@ -163,6 +163,7 @@
+ #endif
+
+ #ifdef CHECK_KERNEL_SOCKETFILTERS
++#include <linux/types.h>
+ #include <linux/filter.h>
+
+ //