aboutsummaryrefslogtreecommitdiffstats
path: root/packages/zd1211
diff options
context:
space:
mode:
authorOyvind Repvik <nail@nslu2-linux.org>2006-02-10 09:25:19 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-02-10 09:25:19 +0000
commitf1ce6e581e05f2a41170a6ffb562104ffb9ed3e0 (patch)
treea7ab9bf09937ae895a326cb60f9ac06f08ae007d /packages/zd1211
parent5475414a7806c4f9e82beb940caedfd60a1db74b (diff)
downloadopenembedded-f1ce6e581e05f2a41170a6ffb562104ffb9ed3e0.tar.gz
zd1211: Add transmitkey index fix
Diffstat (limited to 'packages/zd1211')
-rw-r--r--packages/zd1211/zd1211-r52/transmitkey.index.fix.diff16
-rw-r--r--packages/zd1211/zd1211_r52.bb3
2 files changed, 18 insertions, 1 deletions
diff --git a/packages/zd1211/zd1211-r52/transmitkey.index.fix.diff b/packages/zd1211/zd1211-r52/transmitkey.index.fix.diff
new file mode 100644
index 0000000000..a225d37698
--- /dev/null
+++ b/packages/zd1211/zd1211-r52/transmitkey.index.fix.diff
@@ -0,0 +1,16 @@
+--- zd1211-driver-r52/src/zd1205.c.orig 2006-02-10 10:02:56.000000000 +0100
++++ zd1211-driver-r52/src/zd1205.c 2006-02-10 10:02:56.000000000 +0100
+@@ -5693,7 +5693,12 @@
+ /* Check if the key is not marked as invalid */
+ if (!(erq->flags & IW_ENCODE_NOKEY)) { // for command: key xxxxxxxxxx [n]
+ // ZD1211DEBUG(0, "Set contents of key %d\n", index+1);
+- pSetting->EncryKeyId = index;
++ /* We change the transmit key only if we are
++ * transitioning from a no-encrypt state. This
++ * behavior is deduced from the iwconfig man page */
++ if (pSetting->EncryOnOff == 0) {
++ pSetting->EncryKeyId = index;
++ }
+ memcpy(&pSetting->keyVector[index][0], key, pSetting->WepKeyLen);
+ zd1205_config_wep_keys(macp);
+ } else { // For command: key on
diff --git a/packages/zd1211/zd1211_r52.bb b/packages/zd1211/zd1211_r52.bb
index f8d9c78a9a..21982ad64f 100644
--- a/packages/zd1211/zd1211_r52.bb
+++ b/packages/zd1211/zd1211_r52.bb
@@ -3,7 +3,7 @@ PRIORITY = "optional"
SECTION = "kernel/modules"
MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org>"
LICENSE = "GPL"
-PR = "r3"
+PR = "r4"
RDEPENDS = "wireless-tools"
SRC_URI = "http://zd1211.ath.cx/download/zd1211-driver-${PV}.tgz \
@@ -11,6 +11,7 @@ SRC_URI = "http://zd1211.ath.cx/download/zd1211-driver-${PV}.tgz \
file://firmware.patch;patch=1 \
file://zd1205.c.diff;patch=1 \
file://zdhci.c.diff;patch=1 \
+ file://transmitkey.index.fix.diff;patch=1 \
"
S = "${WORKDIR}/zd1211-driver-${PV}"