aboutsummaryrefslogtreecommitdiffstats
path: root/packages/zlib
diff options
context:
space:
mode:
authornslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-03-01 18:55:57 +0000
committernslu2-linux.adm@bkbits.net <nslu2-linux.adm@bkbits.net>2005-03-01 18:55:57 +0000
commit3c507a3ffad0aaa68cdf977ffcdf09e4e7c93730 (patch)
tree86f9ffd77817699ee2444cf7019b6701bcadb367 /packages/zlib
parent6d0574317a676b24ceffb57764f72be11440478c (diff)
downloadopenembedded-3c507a3ffad0aaa68cdf977ffcdf09e4e7c93730.tar.gz
Merge bk://oe-devel.bkbits.net/openembedded
into bkbits.net:/repos/n/nslu2-linux/openembedded 2005/02/28 19:16:14-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/projects/oe/openembedded 2005/03/01 01:15:28+01:00 dyndns.org!reenoo Merge oe-devel@oe-devel.bkbits.net:openembedded into sugarcube.dyndns.org:/home2/oe/bakery/openembedded 2005/02/28 19:15:51-06:00 ti.com!kergoth Another zlib visibility fix. It's fixed now. Really, it is! 2005/03/01 01:15:11+01:00 dyndns.org!reenoo package_ipk.bbclass: strip whitespace in Source: 2005/02/28 18:53:23-06:00 ti.com!kergoth Merge oe-devel@oe-devel.bkbits.net:openembedded into odin.sc.ti.com:/home/kergoth/code/projects/oe/openembedded 2005/02/28 18:53:11-06:00 ti.com!kergoth Fix up the zlib visibility bits, and apply that patch again. BKrev: 4224babdbJA27U4xliOayBB7Yypnaw
Diffstat (limited to 'packages/zlib')
-rw-r--r--packages/zlib/files/visibility.patch510
-rw-r--r--packages/zlib/zlib_1.2.2.bb7
2 files changed, 501 insertions, 16 deletions
diff --git a/packages/zlib/files/visibility.patch b/packages/zlib/files/visibility.patch
index 86e4bb3c11..ba1a2a6fef 100644
--- a/packages/zlib/files/visibility.patch
+++ b/packages/zlib/files/visibility.patch
@@ -1,10 +1,462 @@
-
-#
-# Patch managed by http://www.holgerschurig.de/patcher.html
-#
-
---- zlib-1.2.2/zconf.in.h~visibility.patch
-+++ zlib-1.2.2/zconf.in.h
+--- tmp/work/arm-linux-uclibc/zlib-1.2.2-r5/zlib-1.2.2/adler32.c 2003-11-17 15:24:27.000000000 -0600
++++ zlib-1.2.2/adler32.c 2005-02-28 19:04:09.000000000 -0600
+@@ -44,7 +44,7 @@
+ #endif
+
+ /* ========================================================================= */
+-uLong ZEXPORT adler32(adler, buf, len)
++ZEXPORT uLong adler32(adler, buf, len)
+ uLong adler;
+ const Bytef *buf;
+ uInt len;
+--- tmp/work/arm-linux-uclibc/zlib-1.2.2-r5/zlib-1.2.2/compress.c 2003-07-07 00:37:56.000000000 -0500
++++ zlib-1.2.2/compress.c 2005-02-28 19:04:09.000000000 -0600
+@@ -19,7 +19,7 @@
+ memory, Z_BUF_ERROR if there was not enough room in the output buffer,
+ Z_STREAM_ERROR if the level parameter is invalid.
+ */
+-int ZEXPORT compress2 (dest, destLen, source, sourceLen, level)
++ZEXPORT int compress2 (dest, destLen, source, sourceLen, level)
+ Bytef *dest;
+ uLongf *destLen;
+ const Bytef *source;
+@@ -59,7 +59,7 @@
+
+ /* ===========================================================================
+ */
+-int ZEXPORT compress (dest, destLen, source, sourceLen)
++ZEXPORT int compress (dest, destLen, source, sourceLen)
+ Bytef *dest;
+ uLongf *destLen;
+ const Bytef *source;
+@@ -72,7 +72,7 @@
+ If the default memLevel or windowBits for deflateInit() is changed, then
+ this function needs to be updated.
+ */
+-uLong ZEXPORT compressBound (sourceLen)
++ZEXPORT uLong compressBound (sourceLen)
+ uLong sourceLen;
+ {
+ return sourceLen + (sourceLen >> 12) + (sourceLen >> 14) + 11;
+--- tmp/work/arm-linux-uclibc/zlib-1.2.2-r5/zlib-1.2.2/crc32.c 2004-10-03 21:29:30.000000000 -0500
++++ zlib-1.2.2/crc32.c 2005-02-28 19:04:09.000000000 -0600
+@@ -198,7 +198,7 @@
+ /* =========================================================================
+ * This function can be used by asm versions of crc32()
+ */
+-const unsigned long FAR * ZEXPORT get_crc_table()
++ZEXPORT const unsigned long FAR * get_crc_table()
+ {
+ #ifdef DYNAMIC_CRC_TABLE
+ if (crc_table_empty)
+@@ -212,7 +212,7 @@
+ #define DO8 DO1; DO1; DO1; DO1; DO1; DO1; DO1; DO1
+
+ /* ========================================================================= */
+-unsigned long ZEXPORT crc32(crc, buf, len)
++ZEXPORT unsigned long crc32(crc, buf, len)
+ unsigned long crc;
+ const unsigned char FAR *buf;
+ unsigned len;
+--- tmp/work/arm-linux-uclibc/zlib-1.2.2-r5/zlib-1.2.2/deflate.c 2004-09-15 09:28:14.000000000 -0500
++++ zlib-1.2.2/deflate.c 2005-02-28 19:04:09.000000000 -0600
+@@ -201,7 +201,7 @@
+ zmemzero((Bytef *)s->head, (unsigned)(s->hash_size-1)*sizeof(*s->head));
+
+ /* ========================================================================= */
+-int ZEXPORT deflateInit_(strm, level, version, stream_size)
++ZEXPORT int deflateInit_(strm, level, version, stream_size)
+ z_streamp strm;
+ int level;
+ const char *version;
+@@ -213,7 +213,7 @@
+ }
+
+ /* ========================================================================= */
+-int ZEXPORT deflateInit2_(strm, level, method, windowBits, memLevel, strategy,
++ZEXPORT int deflateInit2_(strm, level, method, windowBits, memLevel, strategy,
+ version, stream_size)
+ z_streamp strm;
+ int level;
+@@ -311,7 +311,7 @@
+ }
+
+ /* ========================================================================= */
+-int ZEXPORT deflateSetDictionary (strm, dictionary, dictLength)
++ZEXPORT int deflateSetDictionary (strm, dictionary, dictLength)
+ z_streamp strm;
+ const Bytef *dictionary;
+ uInt dictLength;
+@@ -355,7 +355,7 @@
+ }
+
+ /* ========================================================================= */
+-int ZEXPORT deflateReset (strm)
++ZEXPORT int deflateReset (strm)
+ z_streamp strm;
+ {
+ deflate_state *s;
+@@ -391,7 +391,7 @@
+ }
+
+ /* ========================================================================= */
+-int ZEXPORT deflatePrime (strm, bits, value)
++ZEXPORT int deflatePrime (strm, bits, value)
+ z_streamp strm;
+ int bits;
+ int value;
+@@ -403,7 +403,7 @@
+ }
+
+ /* ========================================================================= */
+-int ZEXPORT deflateParams(strm, level, strategy)
++ZEXPORT int deflateParams(strm, level, strategy)
+ z_streamp strm;
+ int level;
+ int strategy;
+@@ -457,7 +457,7 @@
+ * But even the conservative upper bound of about 14% expansion does not
+ * seem onerous for output buffer allocation.
+ */
+-uLong ZEXPORT deflateBound(strm, sourceLen)
++ZEXPORT uLong deflateBound(strm, sourceLen)
+ z_streamp strm;
+ uLong sourceLen;
+ {
+@@ -520,7 +520,7 @@
+ }
+
+ /* ========================================================================= */
+-int ZEXPORT deflate (strm, flush)
++ZEXPORT int deflate (strm, flush)
+ z_streamp strm;
+ int flush;
+ {
+@@ -696,7 +696,7 @@
+ }
+
+ /* ========================================================================= */
+-int ZEXPORT deflateEnd (strm)
++ZEXPORT int deflateEnd (strm)
+ z_streamp strm;
+ {
+ int status;
+@@ -726,7 +726,7 @@
+ * To simplify the source, this is not supported for 16-bit MSDOS (which
+ * doesn't have enough memory anyway to duplicate compression states).
+ */
+-int ZEXPORT deflateCopy (dest, source)
++ZEXPORT int deflateCopy (dest, source)
+ z_streamp dest;
+ z_streamp source;
+ {
+--- tmp/work/arm-linux-uclibc/zlib-1.2.2-r5/zlib-1.2.2/gzio.c 2004-10-03 21:30:37.000000000 -0500
++++ zlib-1.2.2/gzio.c 2005-02-28 19:06:11.000000000 -0600
+@@ -205,7 +205,7 @@
+ /* ===========================================================================
+ Opens a gzip (.gz) file for reading or writing.
+ */
+-gzFile ZEXPORT gzopen (path, mode)
++ZEXPORT gzFile gzopen (path, mode)
+ const char *path;
+ const char *mode;
+ {
+@@ -216,7 +216,7 @@
+ Associate a gzFile with the file descriptor fd. fd is not dup'ed here
+ to mimic the behavio(u)r of fdopen.
+ */
+-gzFile ZEXPORT gzdopen (fd, mode)
++ZEXPORT gzFile gzdopen (fd, mode)
+ int fd;
+ const char *mode;
+ {
+@@ -231,7 +231,7 @@
+ /* ===========================================================================
+ * Update the compression level and strategy
+ */
+-int ZEXPORT gzsetparams (file, level, strategy)
++ZEXPORT int gzsetparams (file, level, strategy)
+ gzFile file;
+ int level;
+ int strategy;
+@@ -391,7 +391,7 @@
+ Reads the given number of uncompressed bytes from the compressed file.
+ gzread returns the number of bytes actually read (0 for end of file).
+ */
+-int ZEXPORT gzread (file, buf, len)
++ZEXPORT int gzread (file, buf, len)
+ gzFile file;
+ voidp buf;
+ unsigned len;
+@@ -500,7 +500,7 @@
+ Reads one byte from the compressed file. gzgetc returns this byte
+ or -1 in case of end of file or error.
+ */
+-int ZEXPORT gzgetc(file)
++ZEXPORT int gzgetc(file)
+ gzFile file;
+ {
+ unsigned char c;
+@@ -512,7 +512,7 @@
+ /* ===========================================================================
+ Push one byte back onto the stream.
+ */
+-int ZEXPORT gzungetc(c, file)
++ZEXPORT int gzungetc(c, file)
+ int c;
+ gzFile file;
+ {
+@@ -537,7 +537,7 @@
+
+ The current implementation is not optimized at all.
+ */
+-char * ZEXPORT gzgets(file, buf, len)
++ZEXPORT char * gzgets(file, buf, len)
+ gzFile file;
+ char *buf;
+ int len;
+@@ -556,7 +556,7 @@
+ Writes the given number of uncompressed bytes into the compressed file.
+ gzwrite returns the number of bytes actually written (0 in case of error).
+ */
+-int ZEXPORT gzwrite (file, buf, len)
++ZEXPORT int gzwrite (file, buf, len)
+ gzFile file;
+ voidpc buf;
+ unsigned len;
+@@ -600,7 +600,7 @@
+ #ifdef STDC
+ #include <stdarg.h>
+
+-int ZEXPORTVA gzprintf (gzFile file, const char *format, /* args */ ...)
++ZEXPORTVA int gzprintf (gzFile file, const char *format, /* args */ ...)
+ {
+ char buf[Z_PRINTF_BUFSIZE];
+ va_list va;
+@@ -634,7 +634,7 @@
+ }
+ #else /* not ANSI C */
+
+-int ZEXPORTVA gzprintf (file, format, a1, a2, a3, a4, a5, a6, a7, a8, a9, a10,
++ZEXPORT intVA gzprintf (file, format, a1, a2, a3, a4, a5, a6, a7, a8, a9, a10,
+ a11, a12, a13, a14, a15, a16, a17, a18, a19, a20)
+ gzFile file;
+ const char *format;
+@@ -675,7 +675,7 @@
+ Writes c, converted to an unsigned char, into the compressed file.
+ gzputc returns the value that was written, or -1 in case of error.
+ */
+-int ZEXPORT gzputc(file, c)
++ZEXPORT int gzputc(file, c)
+ gzFile file;
+ int c;
+ {
+@@ -690,7 +690,7 @@
+ the terminating null character.
+ gzputs returns the number of characters written, or -1 in case of error.
+ */
+-int ZEXPORT gzputs(file, s)
++ZEXPORT int gzputs(file, s)
+ gzFile file;
+ const char *s;
+ {
+@@ -743,7 +743,7 @@
+ return s->z_err == Z_STREAM_END ? Z_OK : s->z_err;
+ }
+
+-int ZEXPORT gzflush (file, flush)
++ZEXPORT int gzflush (file, flush)
+ gzFile file;
+ int flush;
+ {
+@@ -764,7 +764,7 @@
+ SEEK_END is not implemented, returns error.
+ In this version of the library, gzseek can be extremely slow.
+ */
+-z_off_t ZEXPORT gzseek (file, offset, whence)
++ZEXPORT z_off_t gzseek (file, offset, whence)
+ gzFile file;
+ z_off_t offset;
+ int whence;
+@@ -854,7 +854,7 @@
+ /* ===========================================================================
+ Rewinds input file.
+ */
+-int ZEXPORT gzrewind (file)
++ZEXPORT int gzrewind (file)
+ gzFile file;
+ {
+ gz_stream *s = (gz_stream*)file;
+@@ -878,7 +878,7 @@
+ given compressed file. This position represents a number of bytes in the
+ uncompressed data stream.
+ */
+-z_off_t ZEXPORT gztell (file)
++ZEXPORT z_off_t gztell (file)
+ gzFile file;
+ {
+ return gzseek(file, 0L, SEEK_CUR);
+@@ -888,7 +888,7 @@
+ Returns 1 when EOF has previously been detected reading the given
+ input stream, otherwise zero.
+ */
+-int ZEXPORT gzeof (file)
++ZEXPORT int gzeof (file)
+ gzFile file;
+ {
+ gz_stream *s = (gz_stream*)file;
+@@ -938,7 +938,7 @@
+ Flushes all pending output if necessary, closes the compressed file
+ and deallocates all the (de)compression state.
+ */
+-int ZEXPORT gzclose (file)
++ZEXPORT int gzclose (file)
+ gzFile file;
+ {
+ int err;
+@@ -967,7 +967,7 @@
+ errnum is set to Z_ERRNO and the application may consult errno
+ to get the exact error code.
+ */
+-const char * ZEXPORT gzerror (file, errnum)
++ZEXPORT const char * gzerror (file, errnum)
+ gzFile file;
+ int *errnum;
+ {
+@@ -997,7 +997,7 @@
+ /* ===========================================================================
+ Clear the error and end-of-file flags, and do the same for the real file.
+ */
+-void ZEXPORT gzclearerr (file)
++ZEXPORT void gzclearerr (file)
+ gzFile file;
+ {
+ gz_stream *s = (gz_stream*)file;
+--- tmp/work/arm-linux-uclibc/zlib-1.2.2-r5/zlib-1.2.2/infback.c 2004-10-03 21:31:20.000000000 -0500
++++ zlib-1.2.2/infback.c 2005-02-28 19:04:09.000000000 -0600
+@@ -25,7 +25,7 @@
+ windowBits is in the range 8..15, and window is a user-supplied
+ window and output buffer that is 2**windowBits bytes.
+ */
+-int ZEXPORT inflateBackInit_(strm, windowBits, window, version, stream_size)
++ZEXPORT int inflateBackInit_(strm, windowBits, window, version, stream_size)
+ z_stream FAR *strm;
+ int windowBits;
+ unsigned char FAR *window;
+@@ -237,7 +237,7 @@
+ inflateBack() can also return Z_STREAM_ERROR if the input parameters
+ are not correct, i.e. strm is Z_NULL or the state was not initialized.
+ */
+-int ZEXPORT inflateBack(strm, in, in_desc, out, out_desc)
++ZEXPORT int inflateBack(strm, in, in_desc, out, out_desc)
+ z_stream FAR *strm;
+ in_func in;
+ void FAR *in_desc;
+@@ -610,7 +610,7 @@
+ return ret;
+ }
+
+-int ZEXPORT inflateBackEnd(strm)
++ZEXPORT int inflateBackEnd(strm)
+ z_stream FAR *strm;
+ {
+ if (strm == Z_NULL || strm->state == Z_NULL || strm->zfree == (free_func)0)
+--- tmp/work/arm-linux-uclibc/zlib-1.2.2-r5/zlib-1.2.2/inflate.c 2004-10-03 21:33:51.000000000 -0500
++++ zlib-1.2.2/inflate.c 2005-02-28 19:04:09.000000000 -0600
+@@ -100,7 +100,7 @@
+ local unsigned syncsearch OF((unsigned FAR *have, unsigned char FAR *buf,
+ unsigned len));
+
+-int ZEXPORT inflateReset(strm)
++ZEXPORT int inflateReset(strm)
+ z_streamp strm;
+ {
+ struct inflate_state FAR *state;
+@@ -122,7 +122,7 @@
+ return Z_OK;
+ }
+
+-int ZEXPORT inflateInit2_(strm, windowBits, version, stream_size)
++ZEXPORT int inflateInit2_(strm, windowBits, version, stream_size)
+ z_streamp strm;
+ int windowBits;
+ const char *version;
+@@ -165,7 +165,7 @@
+ return inflateReset(strm);
+ }
+
+-int ZEXPORT inflateInit_(strm, version, stream_size)
++ZEXPORT int inflateInit_(strm, version, stream_size)
+ z_streamp strm;
+ const char *version;
+ int stream_size;
+@@ -532,7 +532,7 @@
+ will return Z_BUF_ERROR if it has not reached the end of the stream.
+ */
+
+-int ZEXPORT inflate(strm, flush)
++ZEXPORT int inflate(strm, flush)
+ z_streamp strm;
+ int flush;
+ {
+@@ -1085,7 +1085,7 @@
+ return ret;
+ }
+
+-int ZEXPORT inflateEnd(strm)
++ZEXPORT int inflateEnd(strm)
+ z_streamp strm;
+ {
+ struct inflate_state FAR *state;
+@@ -1099,7 +1099,7 @@
+ return Z_OK;
+ }
+
+-int ZEXPORT inflateSetDictionary(strm, dictionary, dictLength)
++ZEXPORT int inflateSetDictionary(strm, dictionary, dictLength)
+ z_streamp strm;
+ const Bytef *dictionary;
+ uInt dictLength;
+@@ -1171,7 +1171,7 @@
+ return next;
+ }
+
+-int ZEXPORT inflateSync(strm)
++ZEXPORT int inflateSync(strm)
+ z_streamp strm;
+ {
+ unsigned len; /* number of bytes to look at or looked at */
+@@ -1222,7 +1222,7 @@
+ block. When decompressing, PPP checks that at the end of input packet,
+ inflate is waiting for these length bytes.
+ */
+-int ZEXPORT inflateSyncPoint(strm)
++ZEXPORT int inflateSyncPoint(strm)
+ z_streamp strm;
+ {
+ struct inflate_state FAR *state;
+@@ -1232,7 +1232,7 @@
+ return state->mode == STORED && state->bits == 0;
+ }
+
+-int ZEXPORT inflateCopy(dest, source)
++ZEXPORT int inflateCopy(dest, source)
+ z_streamp dest;
+ z_streamp source;
+ {
+--- tmp/work/arm-linux-uclibc/zlib-1.2.2-r5/zlib-1.2.2/uncompr.c 2003-07-07 00:36:56.000000000 -0500
++++ zlib-1.2.2/uncompr.c 2005-02-28 19:04:09.000000000 -0600
+@@ -23,7 +23,7 @@
+ enough memory, Z_BUF_ERROR if there was not enough room in the output
+ buffer, or Z_DATA_ERROR if the input data was corrupted.
+ */
+-int ZEXPORT uncompress (dest, destLen, source, sourceLen)
++ZEXPORT int uncompress (dest, destLen, source, sourceLen)
+ Bytef *dest;
+ uLongf *destLen;
+ const Bytef *source;
+--- tmp/work/arm-linux-uclibc/zlib-1.2.2-r5/zlib-1.2.2/zconf.in.h 2004-05-30 15:38:00.000000000 -0500
++++ zlib-1.2.2/zconf.in.h 2005-02-28 19:04:09.000000000 -0600
@@ -198,11 +198,9 @@
*/
# ifdef ZLIB_DLL
@@ -20,7 +472,7 @@
# endif
# endif /* ZLIB_DLL */
/* If building or using zlib with the WINAPI/WINAPIV calling convention,
-@@ -223,30 +221,39 @@
+@@ -223,30 +221,45 @@
# define ZEXPORTVA FAR CDECL
# endif
# endif
@@ -36,10 +488,12 @@
-# define ZEXPORT __declspec(dllimport)
-# define ZEXPORTVA __declspec(dllimport)
-# endif
-+# define ZDLLLOCAL __declspec(dllimport)
++# define ZDLLIMPORT __declspec(dllimport)
+# define ZDLLPUBLIC __declspec(dllexport)
++# define ZDLLLOCAL
+# endif
+#else
++# define ZDLLIMPORT
+# ifdef GCC_HASCLASSVISIBILITY
+# define ZDLLLOCAL __attribute__ ((visibility("hidden")))
+# define ZDLLPUBLIC __attribute__ ((visibility("default")))
@@ -58,6 +512,10 @@
-#ifndef ZEXPORTVA
-# define ZEXPORTVA
+#ifdef ZLIB_INTERNAL
++# ifndef ZLIB_DLL
++# define ZEXPORT
++# define ZEXPORTVA
++# endif
+# ifndef ZEXPORT
+# define ZEXPORT ZDLLPUBLIC
+# endif
@@ -66,18 +524,18 @@
+# endif
+#else
+# ifndef ZEXPORT
-+# define ZEXPORT ZDLLLOCAL
++# define ZEXPORT ZDLLIMPORT
+# endif
+# ifndef ZEXPORTVA
-+# define ZEXPORTVA ZDLLLOCAL
++# define ZEXPORTVA ZDLLIMPORT
+# endif
#endif
-
#ifndef FAR
# define FAR
#endif
---- zlib-1.2.2/zlib.h~visibility.patch
-+++ zlib-1.2.2/zlib.h
+--- tmp/work/arm-linux-uclibc/zlib-1.2.2-r5/zlib-1.2.2/zlib.h 2004-10-03 21:57:26.000000000 -0500
++++ zlib-1.2.2/zlib.h 2005-02-28 19:04:09.000000000 -0600
@@ -184,7 +184,7 @@
/* basic functions */
@@ -536,3 +994,29 @@
#ifdef __cplusplus
}
+--- tmp/work/arm-linux-uclibc/zlib-1.2.2-r5/zlib-1.2.2/zutil.c 2003-08-27 21:34:34.000000000 -0500
++++ zlib-1.2.2/zutil.c 2005-02-28 19:04:09.000000000 -0600
+@@ -28,12 +28,12 @@
+ ""};
+
+
+-const char * ZEXPORT zlibVersion()
++ZEXPORT const char * zlibVersion()
+ {
+ return ZLIB_VERSION;
+ }
+
+-uLong ZEXPORT zlibCompileFlags()
++ZEXPORT uLong zlibCompileFlags()
+ {
+ uLong flags;
+
+@@ -134,7 +134,7 @@
+ /* exported to allow conversion of error code to string for compress() and
+ * uncompress()
+ */
+-const char * ZEXPORT zError(err)
++ZEXPORT const char * zError(err)
+ int err;
+ {
+ return ERR_MSG(err);
diff --git a/packages/zlib/zlib_1.2.2.bb b/packages/zlib/zlib_1.2.2.bb
index 385fbbf57c..bdacf9ef8e 100644
--- a/packages/zlib/zlib_1.2.2.bb
+++ b/packages/zlib/zlib_1.2.2.bb
@@ -4,14 +4,15 @@ PRIORITY = "required"
MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
HOMEPAGE = "http://www.gzip.org/zlib/"
LICENSE = "zlib"
-PR = "r2"
+PR = "r5"
-SRC_URI = "http://www.libpng.org/pub/png/src/zlib-${PV}.tar.gz "
+SRC_URI = "http://www.libpng.org/pub/png/src/zlib-${PV}.tar.gz \
+ file://visibility.patch;patch=1"
S = "${WORKDIR}/zlib-${PV}"
export LDSHARED = "${CC} -shared -Wl,-soname,libz.so.1"
LDFLAGS_append = " -L. -lz"
-CFLAGS_prepend = "-fPIC "
+CFLAGS_prepend = "-fPIC -DZLIB_DLL "
AR_append = " rc"
EXTRA_OEMAKE = ""