aboutsummaryrefslogtreecommitdiffstats
path: root/packages/zuc
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2004-12-13 22:50:35 +0000
committerMichael Lauer <mickey@vanille-media.de>2004-12-13 22:50:35 +0000
commit8c45dce3743063bf4f15c5c17597fbeb15061d5f (patch)
treee750d16c90751fa3554fa27e92f8685394fa16aa /packages/zuc
parent23b259bb62c5a77b257e1c36cce3a51407997761 (diff)
downloadopenembedded-8c45dce3743063bf4f15c5c17597fbeb15061d5f.tar.gz
ship a more recent unit definition for zuc
BKrev: 41be1cbbJTK8voJN4yOLQBL7PxJm3w
Diffstat (limited to 'packages/zuc')
-rw-r--r--packages/zuc/zuc_1.1.2ern.bb29
1 files changed, 29 insertions, 0 deletions
diff --git a/packages/zuc/zuc_1.1.2ern.bb b/packages/zuc/zuc_1.1.2ern.bb
index e69de29bb2..f69861a6fc 100644
--- a/packages/zuc/zuc_1.1.2ern.bb
+++ b/packages/zuc/zuc_1.1.2ern.bb
@@ -0,0 +1,29 @@
+DESCRIPTION = "A Unit Conversion Tool"
+SECTION = "opie/applications"
+PRIORITY = "optional"
+MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
+LICENSE = "GPL"
+APPTYPE = "binary"
+APPNAME = "zuc"
+APPDESKTOP = "${S}"
+PR = "r1"
+
+SRC_URI = "http://www.linux-solutions.at/projects/zaurus/source/zuc_V${PV}.tar.gz \
+ http://nick.kreucher.net/zuc/zuc_units"
+S = "${WORKDIR}/zuc_V${PV}"
+
+inherit opie
+
+export OE_QMAKE_LINK="${CXX}"
+
+do_configure_append() {
+ echo "#define VERSION \""${PV}"\"" > version.h
+ echo "#define BUILDTIME \""`date +%Y%m%d%H%M`"\"" >> version.h
+}
+
+do_install() {
+ install -d ${D}/${palmtopdir}/pics/
+ install -m 0644 *.png ${D}/${palmtopdir}/pics/
+ install -d ${D}/${palmtopdir}/etc/
+ install -m 0644 ${WORKDIR}/nick.kreucher.net/zuc_units ${D}/${palmtopdir}/etc/
+}