aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-01-21 04:16:09 +0100
committerMichael 'Mickey' Lauer <mickey@vanille-media.de>2009-01-21 04:16:09 +0100
commit591bc386af2d50c85da59825132704b35ecb9ab3 (patch)
tree6c1f2312777b3e47fd038000ad373ef50386620b /packages
parent8d0c1ff094b5e3fde3935fe7a5dba0a03e9d5b1f (diff)
downloadopenembedded-591bc386af2d50c85da59825132704b35ecb9ab3.tar.gz
bluez4: 4.7 -> 4.27; improve package granularity and fix DEPENDS
Diffstat (limited to 'packages')
-rw-r--r--packages/bluez/bluez4_4.27.bb46
-rw-r--r--packages/bluez/bluez4_4.7.bb11
2 files changed, 46 insertions, 11 deletions
diff --git a/packages/bluez/bluez4_4.27.bb b/packages/bluez/bluez4_4.27.bb
new file mode 100644
index 0000000000..a54d656e5f
--- /dev/null
+++ b/packages/bluez/bluez4_4.27.bb
@@ -0,0 +1,46 @@
+DESCRIPTION = "Linux Bluetooth Stack Userland V4"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS = "gst-plugins-base alsa-libs"
+HOMEPAGE = "http://www.bluez.org"
+LICENSE = "GPL"
+PR = "r0"
+
+SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz"
+S = "${WORKDIR}/bluez-${PV}"
+
+inherit autotools pkgconfig
+
+EXTRA_OECONF = "\
+ --enable-gstreamer \
+ --enable-alsa \
+ --disable-usb \
+ --enable-netlink \
+ --enable-tools \
+ --enable-bccmd \
+ --enable-hid2hci \
+ --enable-dfutool \
+ --enable-hidd \
+ --enable-pandd \
+ --enable-dund \
+ --disable-cups \
+ --enable-test \
+ --enable-manpages \
+ --enable-configfiles \
+ --enable-initscripts \
+ --disable-pcmciarules \
+"
+
+PACKAGES =+ "gst-plugin-bluez libasound-module-bluez"
+
+FILES_gst-plugin-bluez = "${libdir}/gstreamer-0.10/lib*.so"
+FILES_libasound-module-bluez = "${libdir}/alsa-lib/lib*.so"
+FILES_${PN} += "${libdir}/bluetooth/plugins/*.so"
+FILES_${PN}-dev += "\
+ ${libdir}/bluetooth/plugins/*.la \
+ ${libdir}/gstreamer-0.10/lib*.la \
+"
+FILES_${PN}-dbg += "\
+ ${libdir}/bluetooth/plugins/.debug \
+ ${libdir}/gstreamer-0.10/.debug \
+"
diff --git a/packages/bluez/bluez4_4.7.bb b/packages/bluez/bluez4_4.7.bb
deleted file mode 100644
index ae579dd0ae..0000000000
--- a/packages/bluez/bluez4_4.7.bb
+++ /dev/null
@@ -1,11 +0,0 @@
-DESCRIPTION = "Linux Bluetooth Stack Userland."
-SECTION = "libs"
-PRIORITY = "optional"
-HOMEPAGE = "http://www.bluez.org"
-LICENSE = "GPL"
-PR = "r0"
-
-SRC_URI = "http://www.kernel.org/pub/linux/bluetooth/bluez-${PV}.tar.gz"
-S = "${WORKDIR}/bluez-${PV}"
-
-inherit autotools pkgconfig