aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2008-10-08 14:13:03 +0000
committerMichael Lauer <mickey@vanille-media.de>2008-10-08 14:13:03 +0000
commit8a3e21cc84fb3fc6c661089156287b82099eede5 (patch)
treeea9884e118e7852e7b2a3a70edc734058f7983df /packages
parent2dca5cdc6f9b240731b253d69c604034674ad314 (diff)
parent44a478fb3839cc629053f61c33952ab30a3f65ac (diff)
downloadopenembedded-8a3e21cc84fb3fc6c661089156287b82099eede5.tar.gz
merge of 'b2f17b7b5e7d3d3578983194a6e5733cc0d72d2b'
and 'c03724e1451ef9439e526ac8b27ec4af5defecf9'
Diffstat (limited to 'packages')
-rw-r--r--packages/totem/totem-pl-parser_2.24.1.bb15
-rw-r--r--packages/totem/totem_2.24.2.bb70
2 files changed, 85 insertions, 0 deletions
diff --git a/packages/totem/totem-pl-parser_2.24.1.bb b/packages/totem/totem-pl-parser_2.24.1.bb
new file mode 100644
index 0000000000..7f3cd861e9
--- /dev/null
+++ b/packages/totem/totem-pl-parser_2.24.1.bb
@@ -0,0 +1,15 @@
+DESCRIPTION = "Playlist parser for Totem, a GTK2 based media player"
+HOMEPAGE = "http://www.gnome.org/projects/totem/"
+LICENSE = "GPL"
+
+DEPENDS = "eds-dbus"
+
+inherit gnome
+
+AUTOTOOLS_STAGE_PKGCONFIG = "1"
+
+do_stage() {
+ autotools_stage_all
+}
+
+
diff --git a/packages/totem/totem_2.24.2.bb b/packages/totem/totem_2.24.2.bb
new file mode 100644
index 0000000000..a0de5705cf
--- /dev/null
+++ b/packages/totem/totem_2.24.2.bb
@@ -0,0 +1,70 @@
+# totem OE build file
+# Copyright (C) 2004, Advanced Micro Devices, Inc. All Rights Reserved
+# Released under the MIT license (see packages/COPYING)
+
+DESCRIPTION = "A GTK2 based media player"
+HOMEPAGE = "http://www.gnome.org/projects/totem/"
+LICENSE = "GPL"
+
+DEPENDS = " totem-pl-parser gtk+ dbus bluez-libs libglade gconf libxml2 gst-ffmpeg gst-plugins-bad gst-plugins-base"
+RDEPENDS_${PN} += "iso-codes"
+RRECOMMENDS_${PN} += "gst-plugin-playbin \
+ gst-plugin-gconfelements \
+ gst-plugin-decodebin \
+ gst-plugin-decodebin2 \
+ gst-ffmpeg \
+ gst-plugin-audioresample \
+ gst-plugin-ximagesink \
+ gst-plugin-xvimagesink \
+ gst-plugin-alsa \
+ gst-plugin-avi \
+ gst-plugin-ffmpegcolorspace \
+ gst-plugin-flvdemux \
+ gst-plugin-nuvdemux \
+ gst-plugin-videoscale \
+ gst-plugin-a52dec \
+ gst-plugin-mpegaudioparse \
+ gst-plugin-ossaudio \
+ gst-plugin-pulse \
+ gst-plugin-autodetect \
+ "
+
+inherit gnome
+
+SRC_URI += "file://gst-detect.diff;patch=1"
+
+EXTRA_OECONF=" --disable-schemas-install \
+ --enable-gtk \
+ --disable-iso-codes \
+ --disable-debug \
+ --enable-gstreamer \
+ --enable-browser-plugins \
+ --disable-run-in-source-tree \
+ --disable-python \
+ --disable-vala \
+ --with-dbus \
+ "
+
+do_configure_prepend() {
+ sed -i -e s:help::g ${S}/Makefile.am
+}
+
+PACKAGES += "totem-plugin-bemused totem-plugin-gromit totem-plugin-lirc totem-plugin-media-player-keys totem-plugin-mythtv totem-plugin-ontop totem-plugin-properties totem-plugin-screensaver totem-plugin-skipto totem-plugin-thumbnail totem-plugin-youtube totem-browser-plugin-dbg totem-browser-plugin"
+
+FILES_totem-plugin-bemused += "${libdir}/totem/plugins/bemused/*"
+FILES_totem-plugin-gromit += "${libdir}/totem/plugins/gromit/*"
+FILES_totem-plugin-lirc += "${libdir}/totem/plugins/lirc/*"
+FILES_totem-plugin-media-player-keys += "${libdir}/totem/plugins/media-player-keys/*"
+FILES_totem-plugin-mythtv += "${libdir}/totem/plugins/mythtv/*"
+FILES_totem-plugin-ontop += "${libdir}/totem/plugins/ontop/*"
+FILES_totem-plugin-properties += "${libdir}/totem/plugins/properties/*"
+FILES_totem-plugin-screensaver += "${libdir}/totem/plugins/screensaver/*"
+FILES_totem-plugin-skipto += "${libdir}/totem/plugins/skipto/*"
+FILES_totem-plugin-thumbnail += "${libdir}/totem/plugins/thumbnail/*"
+FILES_totem-plugin-youtube += "${libdir}/totem/plugins/youtube/*"
+
+FILES_${PN} = "${bindir}/* ${sysconfdir} ${libdir}/lib*.so.* ${libexecdir} ${datadir}/icons ${datadir}/totem ${datadir}/applications"
+FILES_${PN}-dbg += "${libdir}/totem/plugins/*/.debug"
+FILES_${PN}-dev += "${libdir}/totem/plugins/*/*a"
+FILES_totem-browser-plugin-dbg += "${libdir}/mozilla/plugins/.debug"
+FILES_totem-browser-plugin += "${libdir}/mozilla/plugins/"