aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2005-04-03 13:48:55 +0000
committerMichael Lauer <mickey@vanille-media.de>2005-04-03 13:48:55 +0000
commit8b166bdd9e0cf0328e80393fbd8785191c36cd11 (patch)
tree97b22bc413e5279130cc1bcfa7fb6ffb544583a7 /packages
parent07f1adeae8247f49c61330ba008635b820b758d6 (diff)
downloadopenembedded-8b166bdd9e0cf0328e80393fbd8785191c36cd11.tar.gz
Merge bk://oe-devel@oe-devel.bkbits.net/openembedded
into gandalf.tm.informatik.uni-frankfurt.de:/local/pkg/oe/packages 2005/04/03 15:48:27+02:00 uni-frankfurt.de!mickeyl improve update-qtfontdir to only run if necessary, i.e. when its timestamp is older than anything in QTDIR/fonts/ BKrev: 424ff447OlzQOKD9EGJ4PtRiMqzZGg
Diffstat (limited to 'packages')
-rw-r--r--packages/meta/opie-kdepim-image.bb11
-rw-r--r--packages/qpf-fonts/files/update-qtfontdir70
-rw-r--r--packages/qpf-fonts/qpf-font-common_1.0.bb2
-rw-r--r--packages/qte-fonts-common/qte-fonts-common/update-qtfontdir70
-rw-r--r--packages/qte-fonts-common/qte-fonts-common_3.3.3.bb2
5 files changed, 144 insertions, 11 deletions
diff --git a/packages/meta/opie-kdepim-image.bb b/packages/meta/opie-kdepim-image.bb
index c3c84af26c..380ba70346 100644
--- a/packages/meta/opie-kdepim-image.bb
+++ b/packages/meta/opie-kdepim-image.bb
@@ -1,6 +1,6 @@
+include opie-image.bb
+
export IMAGE_BASENAME = "opie-kdepim-image"
-export IMAGE_LINGUAS = ""
-include opie-collections.inc
#
# Putting it altogether. Better state IPKG_INSTALL and DEPENDS twice, because library names != package names.
@@ -16,10 +16,3 @@ DEPENDS = "task-bootstrap ${OPIE_LIBS_DEPENDS} ${OPIE_BASE} ${OPIE_BASE_APPLETS}
${OPIE_BASE_SETTINGS} ${OPIE_BASE_APPS} ${OPIE_BASE_DEPENDS} ${KDE_PIM_DEPENDS} \
${OPIE_EXTRA_APPLETS} ${OPIE_EXTRA_SETTINGS} ${OPIE_EXTRA_APPS} \
${OPIE_BASE_STYLES} ${OPIE_BASE_DECOS} ${OPIE_BASE_INPUTMETHODS}"
-
-
-# zap the root password
-#IMAGE_POSTPROCESS_COMMAND = "zap_root_password"
-
-inherit image_ipk
-LICENSE = MIT
diff --git a/packages/qpf-fonts/files/update-qtfontdir b/packages/qpf-fonts/files/update-qtfontdir
index e69de29bb2..788c0b307d 100644
--- a/packages/qpf-fonts/files/update-qtfontdir
+++ b/packages/qpf-fonts/files/update-qtfontdir
@@ -0,0 +1,70 @@
+#!/bin/sh
+
+usage()
+{
+ echo "usage: $0 [font directory, defaults to QTDIR/lib/fonts]"
+ exit 1
+}
+
+setVar()
+{
+ eval "$1='$2'"
+}
+
+getVar()
+{
+ eval "echo \$$1"
+}
+
+handleQPF()
+{
+ base=`basename $1`
+ family=`echo $base|cut -d_ -f1`
+ pt=`echo $base|cut -d_ -f2`
+ weight=`echo $base|cut -d_ -f3|sed -e 's,i$,,'`
+ if (echo $base|cut -d_ -f3|grep -q 'i$'); then
+ italic="y"
+ else
+ italic="n"
+ fi
+ echo "$family $base.qpf QPF $italic $weight $pt u"
+}
+
+if [ -z "$1" ]; then
+ if [ -n "$QTDIR" ]; then
+ fontdir=$QTDIR/lib/fonts
+ else
+ fontdir=/opt/QtPalmtop/lib/fonts
+ fi
+else
+ fontdir=$1
+fi
+
+if ! [ -d $fontdir ]; then
+ echo Error: $fontdir not a directory
+ exit 1
+fi
+
+if [ -e $fontdir/fontdir ]; then
+ if find $fontdir -newer $fontdir/fontdir | grep "\(qpf\|ttf\)"; then
+ echo "fontdir needs updating..."
+ else
+ echo "fontdir already up to date - exiting"
+ exit 0
+ fi
+ cat $fontdir/fontdir | grep -v '\.qpf' > $fontdir/fontdir.new
+else
+ echo "fontdir not existing. creating..."
+fi
+
+(
+ for file in `ls $fontdir/*.qpf|sed -e's,\.qpf$,,; s,_t[^_]*$,,;'|sort -u`; do
+ handleQPF $file
+ done
+) >> $fontdir/fontdir.new
+
+mv $fontdir/fontdir.new $fontdir/fontdir
+
+exit 0
+
+# vim:ai:et:sts=4:sw=4:tw=0:
diff --git a/packages/qpf-fonts/qpf-font-common_1.0.bb b/packages/qpf-fonts/qpf-font-common_1.0.bb
index f06ea7a76a..c3801c27ce 100644
--- a/packages/qpf-fonts/qpf-font-common_1.0.bb
+++ b/packages/qpf-fonts/qpf-font-common_1.0.bb
@@ -3,7 +3,7 @@ SECTION = "opie/fonts"
PRIORITY = "optional"
MAINTAINER = "Michael 'Mickey' Lauer <mickey@Vanille.de>"
LICENSE = "GPL QPL"
-PR = "r0"
+PR = "r1"
SRC_URI = "file://update-qtfontdir"
S = "${WORKDIR}/qt-${PV}"
diff --git a/packages/qte-fonts-common/qte-fonts-common/update-qtfontdir b/packages/qte-fonts-common/qte-fonts-common/update-qtfontdir
index e69de29bb2..788c0b307d 100644
--- a/packages/qte-fonts-common/qte-fonts-common/update-qtfontdir
+++ b/packages/qte-fonts-common/qte-fonts-common/update-qtfontdir
@@ -0,0 +1,70 @@
+#!/bin/sh
+
+usage()
+{
+ echo "usage: $0 [font directory, defaults to QTDIR/lib/fonts]"
+ exit 1
+}
+
+setVar()
+{
+ eval "$1='$2'"
+}
+
+getVar()
+{
+ eval "echo \$$1"
+}
+
+handleQPF()
+{
+ base=`basename $1`
+ family=`echo $base|cut -d_ -f1`
+ pt=`echo $base|cut -d_ -f2`
+ weight=`echo $base|cut -d_ -f3|sed -e 's,i$,,'`
+ if (echo $base|cut -d_ -f3|grep -q 'i$'); then
+ italic="y"
+ else
+ italic="n"
+ fi
+ echo "$family $base.qpf QPF $italic $weight $pt u"
+}
+
+if [ -z "$1" ]; then
+ if [ -n "$QTDIR" ]; then
+ fontdir=$QTDIR/lib/fonts
+ else
+ fontdir=/opt/QtPalmtop/lib/fonts
+ fi
+else
+ fontdir=$1
+fi
+
+if ! [ -d $fontdir ]; then
+ echo Error: $fontdir not a directory
+ exit 1
+fi
+
+if [ -e $fontdir/fontdir ]; then
+ if find $fontdir -newer $fontdir/fontdir | grep "\(qpf\|ttf\)"; then
+ echo "fontdir needs updating..."
+ else
+ echo "fontdir already up to date - exiting"
+ exit 0
+ fi
+ cat $fontdir/fontdir | grep -v '\.qpf' > $fontdir/fontdir.new
+else
+ echo "fontdir not existing. creating..."
+fi
+
+(
+ for file in `ls $fontdir/*.qpf|sed -e's,\.qpf$,,; s,_t[^_]*$,,;'|sort -u`; do
+ handleQPF $file
+ done
+) >> $fontdir/fontdir.new
+
+mv $fontdir/fontdir.new $fontdir/fontdir
+
+exit 0
+
+# vim:ai:et:sts=4:sw=4:tw=0:
diff --git a/packages/qte-fonts-common/qte-fonts-common_3.3.3.bb b/packages/qte-fonts-common/qte-fonts-common_3.3.3.bb
index 1cda5ac913..803d6923be 100644
--- a/packages/qte-fonts-common/qte-fonts-common_3.3.3.bb
+++ b/packages/qte-fonts-common/qte-fonts-common_3.3.3.bb
@@ -3,7 +3,7 @@ DESCRIPTION= "Tools to update the Qt fontdir"
MAINTAINER = "M&N Solutions <info@mn-solutions.de>"
LICENSE = "GPL/QPL"
PACKAGE_ARCH = "all"
-PR = "r1"
+PR = "r2"
SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-free-${PV}.tar.gz"
SRC_URI += "file://update-qtfontdir"