aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorPhilippe De Swert <philippedeswert@scarlet.be>2007-01-05 18:25:11 +0000
committerPhilippe De Swert <philippedeswert@scarlet.be>2007-01-05 18:25:11 +0000
commit5bdc794c895e99957ffeaac38182d920b1bbe2c2 (patch)
treef61af79e10871c037f236e3ac34286c8bc07723f /packages
parentca9518a2be26b3d957c5cfb8e906ab51ed4e3324 (diff)
downloadopenembedded-5bdc794c895e99957ffeaac38182d920b1bbe2c2.tar.gz
packages/gnome/gnome-vfs_2.16.3.bb : remove kerberos detection to avoid host includes
* added patch gnome-vfs-no-kerberos.patch that removes the test from configure.in * bumped to r1
Diffstat (limited to 'packages')
-rw-r--r--packages/gnome/gnome-vfs-2.16.3/gnome-vfs-no-kerberos.patch51
-rw-r--r--packages/gnome/gnome-vfs_2.16.3.bb5
2 files changed, 54 insertions, 2 deletions
diff --git a/packages/gnome/gnome-vfs-2.16.3/gnome-vfs-no-kerberos.patch b/packages/gnome/gnome-vfs-2.16.3/gnome-vfs-no-kerberos.patch
new file mode 100644
index 0000000000..e25ecdd66f
--- /dev/null
+++ b/packages/gnome/gnome-vfs-2.16.3/gnome-vfs-no-kerberos.patch
@@ -0,0 +1,51 @@
+removes kerberos completely to avoid conflicts with installed kerberos
+--- configure.in.orig 2007-01-05 19:42:26.418541610 +0200
++++ configure.in 2007-01-05 19:42:56.604261797 +0200
+@@ -436,47 +436,6 @@
+ ])
+ AM_CONDITIONAL(HAVE_CDDA, test $have_cdda = yes)
+ AC_SUBST(CDDA_LIBS)
+-
+-dnl GSSAPI
+-dnl Check for Kerberos installation
+-have_gssapi=no
+-AC_PATH_PROG([KRB5_CONFIG], krb5-config, none, $PATH:/usr/kerberos/bin)
+-
+-if test "x$KRB5_CONFIG" != "xnone"; then
+- GSSAPI_LIBS="`${KRB5_CONFIG} --libs gssapi`"
+- GSSAPI_CFLAGS="`${KRB5_CONFIG} --cflags gssapi`"
+-
+- saved_CPPFLAGS="$CPPFLAGS"
+- saved_LIBS="$LIBS"
+- LIBS="$LIBS $GSSAPI_LIBS"
+- CPPFLAGS="$CPPFLAGS $GSSAPI_CFLAGS"
+- # MIT and Heimdal put gssapi.h in different places
+- AC_CHECK_HEADERS(gssapi/gssapi.h gssapi.h, [
+- AC_CHECK_FUNCS(gss_init_sec_context, [
+- AC_MSG_NOTICE([GSSAPI authentication support enabled])
+- AC_DEFINE(HAVE_GSSAPI, 1, [Define if GSSAPI support is enabled])
+- AC_CHECK_HEADERS(gssapi/gssapi_generic.h)
+- have_gssapi=yes
+-
+- # MIT Kerberos lacks GSS_C_NT_HOSTBASED_SERVICE
+- AC_CHECK_DECL([GSS_C_NT_HOSTBASED_SERVICE],,
+- [AC_DEFINE([GSS_C_NT_HOSTBASED_SERVICE], gss_nt_service_name,
+- [Define if GSS_C_NT_HOSTBASED_SERVICE is not defined otherwise])
+- ], [
+- #ifdef HAVE_GSSAPI_GSSAPI_H
+- #include <gssapi/gssapi.h>
+- #else
+- #include <gssapi.h>
+- #endif
+- ])
+- ])
+- break
+- ])
+- LIBS="$saved_LIBS"
+- CPPFLAGS="$saved_CPPFLAGS"
+-fi
+-AC_SUBST(GSSAPI_LIBS)
+-AC_SUBST(GSSAPI_CFLAGS)
+
+ dnl ******************************
+ dnl http-method (neon checks)
diff --git a/packages/gnome/gnome-vfs_2.16.3.bb b/packages/gnome/gnome-vfs_2.16.3.bb
index a0180fdbb2..6efbe7249d 100644
--- a/packages/gnome/gnome-vfs_2.16.3.bb
+++ b/packages/gnome/gnome-vfs_2.16.3.bb
@@ -2,7 +2,7 @@ LICENSE = "GPL"
DEPENDS = "libxml2 gconf gnutls avahi dbus bzip2 gnome-mime-data zlib"
RRECOMMENDS = "gnome-vfs-plugin-file gnome-mime-data shared-mime-info"
-PR = "r0"
+PR = "r1"
inherit gnome
@@ -10,7 +10,8 @@ inherit gnome
PROVIDES = "gnome-vfs-plugin-dbus"
RRPEPLACES = "gnome-vfs-dbus"
-SRC_URI += "file://gconftool-lossage.patch;patch=1;pnum=1"
+SRC_URI += "file://gconftool-lossage.patch;patch=1;pnum=1 \
+ file://gnome-vfs-no-kerberos.patch;patch=1;pnum=0"
EXTRA_OECONF = " \
--disable-openssl \