aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-02-16 04:31:54 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2007-02-16 04:31:54 +0000
commitf0c79817df40871bc27a5668c95da41f4a2eff09 (patch)
tree297570b4a3aab9cc846e668712052c0a0426d5b0 /packages
parent342f01d322bcc1ee34549fdc8f8db7555568b329 (diff)
parent75f39ca295443f2a448c077b65be29855aecc6a9 (diff)
downloadopenembedded-f0c79817df40871bc27a5668c95da41f4a2eff09.tar.gz
merge of 'd283e920162c9ff5c4a3392010a4376d56a02b3c'
and 'ff4a9eec58fba61dc8cafa4957305ccd0140430a'
Diffstat (limited to 'packages')
-rw-r--r--packages/libxml/libxml2-native_2.6.26.bb20
-rw-r--r--packages/libxslt/libxslt-native_1.1.17.bb4
2 files changed, 24 insertions, 0 deletions
diff --git a/packages/libxml/libxml2-native_2.6.26.bb b/packages/libxml/libxml2-native_2.6.26.bb
new file mode 100644
index 0000000000..74ddfeb33a
--- /dev/null
+++ b/packages/libxml/libxml2-native_2.6.26.bb
@@ -0,0 +1,20 @@
+DESCRIPTION = "GNOME XML library"
+
+SRC_URI = "ftp://xmlsoft.org/libxml2/libxml2-${PV}.tar.gz \
+ file://no-testapi.patch;patch=1"
+
+DEPENDS = "python-native"
+
+FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/libxml2-${PV}"
+S = "${WORKDIR}/libxml2-${PV}"
+
+inherit autotools native pkgconfig
+
+EXTRA_OECONF = "--with-python=${STAGING_INCDIR}/python2.4 --without-debug --without-legacy --without-schemas --without-catalog --without-docbook --without-c14n"
+
+headers = "DOCBparser.h HTMLparser.h HTMLtree.h SAX.h SAX2.h c14n.h catalog.h chvalid.h debugXML.h dict.h encoding.h entities.h globals.h hash.h list.h nanoftp.h nanohttp.h parser.h parserInternals.h pattern.h relaxng.h schemasInternals.h threads.h tree.h uri.h valid.h xinclude.h xlink.h xmlIO.h xmlautomata.h xmlerror.h xmlexports.h xmlmemory.h xmlreader.h xmlregexp.h xmlschemas.h xmlschemastypes.h xmlstring.h xmlunicode.h xmlversion.h xmlwriter.h xpath.h xpathInternals.h xpointer.h"
+
+do_stage () {
+ oe_runmake install
+}
+
diff --git a/packages/libxslt/libxslt-native_1.1.17.bb b/packages/libxslt/libxslt-native_1.1.17.bb
new file mode 100644
index 0000000000..6134b2bf57
--- /dev/null
+++ b/packages/libxslt/libxslt-native_1.1.17.bb
@@ -0,0 +1,4 @@
+require libxslt_${PV}.bb
+inherit native
+
+DEPENDS = "libxml2-native (>=2.6.25)"