aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2008-03-12 10:35:31 +0000
committerHolger Freyther <zecke@selfish.org>2008-03-12 10:35:31 +0000
commit093d01d708c2f09213f1667ca45cd165c282e435 (patch)
tree828f9ba5a0a4636b304c5e116f488427f30aebcb /packages
parent7c162428143a230e9980879fb8d55ceb5c018a5f (diff)
downloadopenembedded-093d01d708c2f09213f1667ca45cd165c282e435.tar.gz
directfb: Remove potential dangerous sed invocation. Add a -I in front and replace it with nothing
It is still compiling and packaging.
Diffstat (limited to 'packages')
-rw-r--r--packages/directfb/++dfb_1.0.0.bb2
-rw-r--r--packages/directfb/directfb-examples_1.0.0.bb4
2 files changed, 3 insertions, 3 deletions
diff --git a/packages/directfb/++dfb_1.0.0.bb b/packages/directfb/++dfb_1.0.0.bb
index f440e117ff..020cbfe3eb 100644
--- a/packages/directfb/++dfb_1.0.0.bb
+++ b/packages/directfb/++dfb_1.0.0.bb
@@ -11,7 +11,7 @@ RV = "0.9-25"
inherit autotools pkgconfig
do_configure_append() {
- find ${S} -type f | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
+ find ${S} -type f | xargs sed -i 's:-I/usr/include::g'
}
do_stage() {
diff --git a/packages/directfb/directfb-examples_1.0.0.bb b/packages/directfb/directfb-examples_1.0.0.bb
index 064a808273..e59e4ecf2e 100644
--- a/packages/directfb/directfb-examples_1.0.0.bb
+++ b/packages/directfb/directfb-examples_1.0.0.bb
@@ -11,8 +11,8 @@ S = "${WORKDIR}/DirectFB-examples-${PV}"
inherit autotools
do_configure_append() {
-# find ${S} -type f | xargs sed -i 's:/usr/lib:${STAGING_LIBDIR}:'
- find ${S} -type f | xargs sed -i 's:/usr/include:${STAGING_INCDIR}:'
+# find ${S} -type f | xargs sed -i 's:-L/usr/lib::g'
+ find ${S} -type f | xargs sed -i 's:-I/usr/include::g'
}
do_stage() {