aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMike Westerhof <mwester@dls.net>2007-08-10 03:35:00 +0000
committerMike Westerhof <mwester@dls.net>2007-08-10 03:35:00 +0000
commit0d3a5538a353661a41389e6ca5495d67048198c2 (patch)
tree682fbbf9c63a48f5b8cef20d951af012572e8fbc /packages
parentc60f2a2305c217e0e45b98c58f0329c9c39e7ffb (diff)
downloadopenembedded-0d3a5538a353661a41389e6ca5495d67048198c2.tar.gz
fakeroot: upgrade to 1.7.1 version, fixes odd caching anomolies on some
newer build host distros.
Diffstat (limited to 'packages')
-rw-r--r--packages/fakeroot/fakeroot-native_1.7.1.bb21
-rw-r--r--packages/fakeroot/fakeroot_1.7.1.bb16
-rw-r--r--packages/fakeroot/files/work-with-older-libtool.patch11
3 files changed, 48 insertions, 0 deletions
diff --git a/packages/fakeroot/fakeroot-native_1.7.1.bb b/packages/fakeroot/fakeroot-native_1.7.1.bb
new file mode 100644
index 0000000000..6f2969e181
--- /dev/null
+++ b/packages/fakeroot/fakeroot-native_1.7.1.bb
@@ -0,0 +1,21 @@
+SECTION = "base"
+require fakeroot_${PV}.bb
+inherit native
+RDEPENDS="util-linux-native"
+
+SRC_URI += "file://fix-prefix.patch;patch=1 \
+ file://work-with-older-libtool.patch;patch=1"
+S = "${WORKDIR}/fakeroot-${PV}"
+
+EXTRA_OECONF = " --program-prefix="
+
+# Compatability for the rare systems not using or having SYSV
+python () {
+ if bb.data.getVar('HOST_NONSYSV', d, True) and bb.data.getVar('HOST_NONSYSV', d, True) != '0':
+ bb.data.setVar('EXTRA_OECONF', ' --with-ipc=tcp --program-prefix= ', d)
+}
+
+do_stage_append () {
+ oe_libinstall -so libfakeroot ${STAGING_LIBDIR}/libfakeroot/
+}
+
diff --git a/packages/fakeroot/fakeroot_1.7.1.bb b/packages/fakeroot/fakeroot_1.7.1.bb
new file mode 100644
index 0000000000..486bf93a46
--- /dev/null
+++ b/packages/fakeroot/fakeroot_1.7.1.bb
@@ -0,0 +1,16 @@
+DESCRIPTION = "Gives a fake root environment"
+SECTION = "base"
+LICENSE = "GPL"
+# fakeroot needs getopt which is provided by the util-linux package
+RDEPENDS = "util-linux"
+PR = "r1"
+
+SRC_URI = "ftp://ftp.debian.org/debian/pool/main/f/fakeroot/fakeroot_${PV}.tar.gz"
+
+inherit autotools
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/fakeroot
+ install -m 644 *.h ${STAGING_INCDIR}/fakeroot
+ autotools_stage_all
+}
diff --git a/packages/fakeroot/files/work-with-older-libtool.patch b/packages/fakeroot/files/work-with-older-libtool.patch
new file mode 100644
index 0000000000..05f9be87b6
--- /dev/null
+++ b/packages/fakeroot/files/work-with-older-libtool.patch
@@ -0,0 +1,11 @@
+--- fakeroot-1.7.1/configure.ac.orig 2007-08-09 16:03:34.000000000 -0500
++++ fakeroot-1.7.1/configure.ac 2007-08-09 18:26:11.000000000 -0500
+@@ -7,8 +7,6 @@
+ AC_CONFIG_HEADERS([config.h])
+ AC_PROG_MAKE_SET
+ AM_PROG_LIBTOOL
+-LT_INIT
+-LT_LANG(C)
+
+ AC_ARG_WITH([ipc],
+ AS_HELP_STRING([--with-ipc@<:@=IPCTYPE@:>@],