aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorKhem Raj <raj.khem@gmail.com>2007-08-08 17:55:14 +0000
committerKhem Raj <raj.khem@gmail.com>2007-08-08 17:55:14 +0000
commit23565dca658348d15acb9fc272be7d9e8d28a6e2 (patch)
tree7f31a13d3d745a1c8508cea67277372848a05fdc /packages
parent89f4a812b9defa0977d3c2fa3416a96a2772a92b (diff)
parente49a537b2df2adc6ffda01e674960c63bddd4a40 (diff)
downloadopenembedded-23565dca658348d15acb9fc272be7d9e8d28a6e2.tar.gz
merge of '70aa18fe06d3e3a4ad005666e02d3c53f91a5fa1'
and '9337a5ff3440772705d464c123d99b9bcbe72cd0'
Diffstat (limited to 'packages')
-rw-r--r--packages/ffmpeg/ffmpeg_svn.bb21
1 files changed, 13 insertions, 8 deletions
diff --git a/packages/ffmpeg/ffmpeg_svn.bb b/packages/ffmpeg/ffmpeg_svn.bb
index 4098d721f9..b8bd365d51 100644
--- a/packages/ffmpeg/ffmpeg_svn.bb
+++ b/packages/ffmpeg/ffmpeg_svn.bb
@@ -2,7 +2,7 @@ DESCRIPTION = "ffmpeg"
SECTION = "libs"
PRIORITY = "optional"
LICENSE = "GPL"
-DEPENDS = "zlib libvorbis faac liba52 lame"
+DEPENDS = "libogg zlib libvorbis faac liba52 lame"
PV = "0.4.9+svn${SRCDATE}"
DEFAULT_PREFERENCE = "-1"
@@ -11,17 +11,18 @@ SRC_URI = "svn://svn.mplayerhq.hu/ffmpeg/;module=trunk"
S = "${WORKDIR}/trunk"
-inherit autotools
+inherit autotools pkgconfig
TARGET_LDFLAGS_append = " -lm -la52 "
EXTRA_OECONF = " \
- --enable-mp3lame \
- --enable-vorbis \
- --enable-faad \
- --enable-a52 \
- --enable-a52bin \
- --enable-pp \
+ --enable-libmp3lame \
+ --enable-libvorbis \
+ --disable-libfaad \
+ --enable-liba52 \
+ --enable-liba52bin \
+ --enable-libogg \
+ --enable-pp \
--enable-shared \
--enable-pthreads \
--enable-gpl \
@@ -32,10 +33,12 @@ EXTRA_OECONF = " \
--disable-debug \
--disable-ffserver \
--disable-ffplay \
+ --disable-strip \
\
--cross-prefix=${TARGET_PREFIX} \
\
--cpu=${PACKAGE_ARCH} \
+ --arch=${PACKAGE_ARCH} \
"
@@ -48,6 +51,8 @@ do_configure_prepend() {
}
oe_runconf () {
+ # make ffmpeg detect arm targets that don't end in 'l'
+ sed -i -e s:'armv\[4567\]\*l':'armv\[4567\]\*':g ${S}/configure
if [ -x ${S}/configure ] ; then
cfgcmd="${S}/configure \
--prefix=${prefix} \