aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorMichael Lauer <mickey@vanille-media.de>2007-08-07 12:45:15 +0000
committerMichael Lauer <mickey@vanille-media.de>2007-08-07 12:45:15 +0000
commit2c0ccf8938c260f11360d9559544075da1a4693f (patch)
tree9c1bd940989a7e28eea23c8485d9e16d1b0793f4 /packages
parent23837f3256a8230816c7c9911a84d0f566c958a9 (diff)
downloadopenembedded-2c0ccf8938c260f11360d9559544075da1a4693f.tar.gz
uboot-openmoko|linux-gta01: softlink to the latest binary in the deploy directory
Diffstat (limited to 'packages')
-rw-r--r--packages/linux/linux-gta01.inc1
-rw-r--r--packages/uboot/uboot-openmoko_svn.bb2
2 files changed, 3 insertions, 0 deletions
diff --git a/packages/linux/linux-gta01.inc b/packages/linux/linux-gta01.inc
index 7cc6c58b6b..8554d2413c 100644
--- a/packages/linux/linux-gta01.inc
+++ b/packages/linux/linux-gta01.inc
@@ -93,6 +93,7 @@ do_deploy() {
rm -f linux.bin.gz
gzip -9 linux.bin
${STAGING_BINDIR_NATIVE}/uboot-mkimage -A arm -O linux -T kernel -C gzip -a 30008000 -e 30008000 -n "OpenMoko Kernel Image Neo1973(GTA01)" -d linux.bin.gz ${DEPLOY_DIR_IMAGE}/uImage-${PV}-${PR}-${MACHINE}.bin
+ ln -sf ${DEPLOY_DIR_IMAGE}/uImage-${PV}-${PR}-${MACHINE}.bin ${DEPLOY_DIR_IMAGE}/uImage-${MACHINE}-latest.bin
rm -f linux.bin.gz
}
diff --git a/packages/uboot/uboot-openmoko_svn.bb b/packages/uboot/uboot-openmoko_svn.bb
index 06c15c14c2..d7a07a7d00 100644
--- a/packages/uboot/uboot-openmoko_svn.bb
+++ b/packages/uboot/uboot-openmoko_svn.bb
@@ -73,8 +73,10 @@ do_deploy () {
for mach in ${UBOOT_MACHINES}
do
install -m 0644 ${S}/u-boot_${mach}.bin ${DEPLOY_DIR_IMAGE}/u-boot-${mach}-${PV}-${PR}.bin
+ ln -sf ${DEPLOY_DIR_IMAGE}/u-boot-${mach}-${PV}-${PR}.bin ${DEPLOY_DIR_IMAGE}/uboot-${mach}-latest.bin
if [ -f ${S}/lowlevel_foo_${mach}.bin ]; then
install -m 0644 ${S}/lowlevel_foo_${mach}.bin ${DEPLOY_DIR_IMAGE}/lowlevel_foo-${mach}-${PV}-${PR}.bin
+ ln -sf ${DEPLOY_DIR_IMAGE}/lowlevel_foo-${mach}-${PV}-${PR}.bin ${DEPLOY_DIR_IMAGE}/lowlevel-foo-${mach}-latest.bin
fi
done
install -m 0755 tools/mkimage ${STAGING_BINDIR_NATIVE}/uboot-mkimage