aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-12-21 09:13:13 +0000
committerKoen Kooi <koen@openembedded.org>2006-12-21 09:13:13 +0000
commit2e0c4e30549ba25d9a353cb2c8437d22da90c7cc (patch)
treef6809cd90c67216152ce37c6839a3d1a9e64b32d /packages
parent2431508da0e4c9982679df090d44ee477b7c9355 (diff)
downloadopenembedded-2e0c4e30549ba25d9a353cb2c8437d22da90c7cc.tar.gz
glib-2.0: update to 2.12.6
* also create glib.inc
Diffstat (limited to 'packages')
-rw-r--r--packages/glib-2.0/glib-2.0_2.12.6.bb6
-rw-r--r--packages/glib-2.0/glib.inc40
2 files changed, 46 insertions, 0 deletions
diff --git a/packages/glib-2.0/glib-2.0_2.12.6.bb b/packages/glib-2.0/glib-2.0_2.12.6.bb
new file mode 100644
index 0000000000..aae16bf2f5
--- /dev/null
+++ b/packages/glib-2.0/glib-2.0_2.12.6.bb
@@ -0,0 +1,6 @@
+require glib.inc
+
+SRC_URI = "http://ftp.gnome.org/pub/GNOME/sources/glib/2.12/glib-${PV}.tar.bz2 \
+ file://glibconfig-sysdefs.h \
+ file://configure-libtool.patch;patch=1"
+
diff --git a/packages/glib-2.0/glib.inc b/packages/glib-2.0/glib.inc
new file mode 100644
index 0000000000..6a33291d52
--- /dev/null
+++ b/packages/glib-2.0/glib.inc
@@ -0,0 +1,40 @@
+DESCRIPTION = "GLib is a general-purpose utility library, \
+which provides many useful data types, macros, \
+type conversions, string utilities, file utilities, a main \
+loop abstraction, and so on. It works on many \
+UNIX-like platforms, Windows, OS/2 and BeOS."
+LICENSE = "LGPL"
+SECTION = "libs"
+PRIORITY = "optional"
+DEPENDS += "glib-2.0-native gtk-doc"
+DEPENDS += "virtual/libiconv virtual/libintl"
+PACKAGES =+ "glib-2.0-utils "
+
+LEAD_SONAME = "libglib-2.0.*"
+FILES_glib-2.0-utils = "${bindir}/*"
+
+EXTRA_OECONF = "--disable-debug"
+
+S = "${WORKDIR}/glib-${PV}"
+
+inherit autotools pkgconfig gettext
+
+require glib-2.0.inc
+
+acpaths = ""
+do_configure_prepend () {
+ install -m 0644 ${WORKDIR}/glibconfig-sysdefs.h .
+}
+
+do_stage () {
+ oe_libinstall -so -C glib libglib-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gmodule libgmodule-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gthread libgthread-2.0 ${STAGING_LIBDIR}
+ oe_libinstall -so -C gobject libgobject-2.0 ${STAGING_LIBDIR}
+ autotools_stage_includes
+ install -d ${STAGING_INCDIR}/glib-2.0/glib
+ install -m 0755 ${S}/glibconfig.h ${STAGING_INCDIR}/glib-2.0/glibconfig.h
+ install -d ${STAGING_DATADIR}/aclocal
+ install -m 0644 ${S}/m4macros/glib-2.0.m4 ${STAGING_DATADIR}/aclocal/glib-2.0.m4
+ install -m 0644 ${S}/m4macros/glib-gettext.m4 ${STAGING_DATADIR}/aclocal/glib-gettext.m4
+}