aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2006-12-21 09:15:54 +0000
committerKoen Kooi <koen@openembedded.org>2006-12-21 09:15:54 +0000
commit3fe155e8e7e33029f87eae1132f764998e9e7b4a (patch)
treec838fea5578702bbf7d3cab5569117d05fceea71 /packages
parent2e0c4e30549ba25d9a353cb2c8437d22da90c7cc (diff)
downloadopenembedded-3fe155e8e7e33029f87eae1132f764998e9e7b4a.tar.gz
pango: update to 1.15.2, create pango.inc
Higlights from the announcement: * Optimizations: - Avoid some floating-point operations. Should cut the number of float ops per expose event in pangocairo to a half. - Cache ink and logical extents for PangoLayout
Diffstat (limited to 'packages')
-rw-r--r--packages/pango/pango.inc51
-rw-r--r--packages/pango/pango_1.15.2.bb1
2 files changed, 52 insertions, 0 deletions
diff --git a/packages/pango/pango.inc b/packages/pango/pango.inc
new file mode 100644
index 0000000000..4b4d859372
--- /dev/null
+++ b/packages/pango/pango.inc
@@ -0,0 +1,51 @@
+DESCRIPTION = "The goal of the Pango project is to provide an \
+Open Source framework for the layout and rendering of \
+internationalized text."
+LICENSE = "LGPL"
+
+inherit gnome
+
+
+SECTION = "x11/libs"
+
+DEPENDS = "glib-2.0 fontconfig freetype zlib virtual/libx11 libxft gtk-doc cairo"
+
+PACKAGES_DYNAMIC = "pango-module-*"
+
+RRECOMMENDS_${PN} = "pango-module-basic-x pango-module-basic-fc"
+
+# seems to go wrong with default cflags
+FULL_OPTIMIZATION_arm = "-O2"
+
+SRC_URI += "file://no-tests.patch;patch=1 \
+ "
+
+EXTRA_OECONF = "--disable-glibtest \
+ --enable-explicit-deps=no \
+ --disable-debug"
+
+LEAD_SONAME = "libpango-1.0*"
+LIBV = "1.6.0"
+
+FILES_${PN} = "/etc ${bindir}/* ${libdir}/libpango*.so.*"
+FILES_${PN}-dbg += "${libdir}/pango/${LIBV}/modules/.debug"
+FILES_${PN}-dev += "${libdir}/pango/${LIBV}/modules/*.la"
+
+do_stage () {
+ autotools_stage_all
+}
+
+postinst_prologue() {
+if [ "x$D" != "x" ]; then
+ exit 1
+fi
+
+}
+
+python populate_packages_prepend () {
+ prologue = bb.data.getVar("postinst_prologue", d, 1)
+
+ modules_root = bb.data.expand('${libdir}/pango/${LIBV}/modules', d)
+
+ do_split_packages(d, modules_root, '^pango-(.*)\.so$', 'pango-module-%s', 'Pango module %s', prologue + 'pango-querymodules > /etc/pango/pango.modules')
+}
diff --git a/packages/pango/pango_1.15.2.bb b/packages/pango/pango_1.15.2.bb
new file mode 100644
index 0000000000..8e3e8e7d3a
--- /dev/null
+++ b/packages/pango/pango_1.15.2.bb
@@ -0,0 +1 @@
+require pango.inc