aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorLeon Woestenberg <leon.woestenberg@gmail.com>2007-05-17 16:59:11 +0000
committerLeon Woestenberg <leon.woestenberg@gmail.com>2007-05-17 16:59:11 +0000
commit6e321f8e4907d1f55ccc0635329d4691f720b9e2 (patch)
tree81098996aac54e3af1ede3e07a38d05e8e72e828 /packages
parent435dc70aa0e43b448804045a9aa358856bc67bb8 (diff)
downloadopenembedded-6e321f8e4907d1f55ccc0635329d4691f720b9e2.tar.gz
disapproval of revision '1d3cbf1f69da57387c0d0eb4329fc5054a9ccec0'
Diffstat (limited to 'packages')
-rw-r--r--packages/helloworld/.mtn2git_empty0
-rw-r--r--packages/helloworld/helloworld_1.0.0.bb25
-rw-r--r--packages/images/angstrom-minimal-image.bb18
-rw-r--r--packages/images/helloworld-image.bb14
4 files changed, 15 insertions, 42 deletions
diff --git a/packages/helloworld/.mtn2git_empty b/packages/helloworld/.mtn2git_empty
deleted file mode 100644
index e69de29bb2..0000000000
--- a/packages/helloworld/.mtn2git_empty
+++ /dev/null
diff --git a/packages/helloworld/helloworld_1.0.0.bb b/packages/helloworld/helloworld_1.0.0.bb
deleted file mode 100644
index 9e68b0bd61..0000000000
--- a/packages/helloworld/helloworld_1.0.0.bb
+++ /dev/null
@@ -1,25 +0,0 @@
-DESCRIPTION = "Minimal statically compiled Hello world!"
-LICENSE = "GPL"
-PR = "r0"
-
-S = "${WORKDIR}/${P}"
-
-do_fetch () {
- mkdir -p ${WORKDIR}/${P}
- cd ${WORKDIR}/${P}
- echo -e "#include <stdio.h>\nint main(void)\n{\n\tprintf(\"Hello world!\\\n\");\twhile(1);\n\treturn 0;\n}\n" >helloworld.c
-}
-
-do_compile () {
- ${CC} -o helloworld helloworld.c -static
-}
-
-do_install () {
- install -d ${D}${bindir}
- install -m 0755 helloworld ${D}${bindir}/
- # /bin/init is on purpose, it is tried after /sbin/init and /etc/init
- # so if a sysvinit is installed, it will be used instead of helloworld
- install -d ${D}${base_bindir}
- ln -sf ${bindir}/helloworld ${D}${base_bindir}/init
-}
-
diff --git a/packages/images/angstrom-minimal-image.bb b/packages/images/angstrom-minimal-image.bb
index 54f7ff2c89..90f46a1e01 100644
--- a/packages/images/angstrom-minimal-image.bb
+++ b/packages/images/angstrom-minimal-image.bb
@@ -1,10 +1,22 @@
-# Hello world image
-# gives you a small image with a statically linked
+#Angstrom minimalist image
+#gives you a small images with ssh access
LICENSE = "MIT"
PR = "r0"
-export IMAGE_BASENAME = "helloworld-image"
+ANGSTROM_EXTRA_INSTALL ?= ""
+DISTRO_SSH_DAEMON ?= "dropbear"
+
+DEPENDS = "task-base \
+ ${DISTRO_SSH_DAEMON} \
+ "
+
+RDEPENDS = "task-boot \
+ ${DISTRO_SSH_DAEMON} \
+ "
+
+export IMAGE_BASENAME = "minimalist-image"
export IMAGE_LINGUAS = ""
+export PACKAGE_INSTALL = "${RDEPENDS}"
inherit image
diff --git a/packages/images/helloworld-image.bb b/packages/images/helloworld-image.bb
deleted file mode 100644
index 5154752f75..0000000000
--- a/packages/images/helloworld-image.bb
+++ /dev/null
@@ -1,14 +0,0 @@
-# Hello world image
-# Contains *only* a statically linked hello world init program
-LICENSE = "MIT"
-PR = "r0"
-
-RDEPENDS = "helloworld"
-
-export IMAGE_BASENAME = "helloworld-image"
-export IMAGE_LINGUAS = ""
-
-PACKAGE_INSTALL = ${RDEPENDS}
-
-inherit image
-