aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2007-09-03 12:22:20 +0000
committerHolger Freyther <zecke@selfish.org>2007-09-03 12:22:20 +0000
commit7217b0c316ec2caacf1d1d7d8eeb539f86dc16e0 (patch)
tree0fd1771ffb85bd69d4d73cdbee29a3ba7f3289ba /packages
parent9f7aa9e4b86d68aa5a931d945299d25015e87390 (diff)
downloadopenembedded-7217b0c316ec2caacf1d1d7d8eeb539f86dc16e0.tar.gz
classes/{qmake*,qt4x11}.bbclass: Add a qmake2.bbclass to use qmake version two
Add a qmake2.bbclass which currently takes over the role of qt4x11.bbclass with setting the QTDIR, MOC, UIC properly. qmake2 and qmake now share qmake-base.bbclass this is why some var assignments and functions have been moved around. Make webkit-gtk use qmake2 to eliminate the Qt3 and Qt4/X11 dependency.
Diffstat (limited to 'packages')
-rw-r--r--packages/webkit/webkit-gtk_svn.bb6
1 files changed, 3 insertions, 3 deletions
diff --git a/packages/webkit/webkit-gtk_svn.bb b/packages/webkit/webkit-gtk_svn.bb
index 8a6480d54f..112c45c1e3 100644
--- a/packages/webkit/webkit-gtk_svn.bb
+++ b/packages/webkit/webkit-gtk_svn.bb
@@ -1,10 +1,10 @@
-DEPENDS = "flex-native gperf-native gperf perl-native curl icu uicmoc4-native qmake2-native libxml2 sqlite3 cairo libxslt libidn gnutls gtk+"
+DEPENDS = "flex-native gperf-native gperf perl-native curl icu libxml2 sqlite3 cairo libxslt libidn gnutls gtk+"
# Yes, this is wrong...
PV = "0.0+svn${SRCDATE}"
PR = "r1"
-inherit qmake qt4x11 pkgconfig
+inherit qmake2 pkgconfig
SRC_URI = "\
svn://svn.webkit.org/repository/webkit/trunk/;module=JavaScriptCore;proto=http \
@@ -21,7 +21,7 @@ SRC_URI = "\
"
S = "${WORKDIR}/"
-do_configure_append() {
+do_configure() {
qmake2 -spec ${QMAKESPEC} CONFIG+=gdk-port CONFIG-=qt CONFIG-=release CONFIG+=debug
mkdir -p WebKitBuilds/Debug
cd WebKitBuilds/Debug