aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorRolf Leggewie <oe-devel@rolf.leggewie.biz>2006-12-19 12:51:21 +0000
committerRolf Leggewie <oe-devel@rolf.leggewie.biz>2006-12-19 12:51:21 +0000
commit7c45c11af2e21babb3a4a12db9522cffb5893fa7 (patch)
tree93459eaa3b5ec7da881c2cd0c60fc710971f4a38 /packages
parentf9843b4116d14b60aeb06a1ea151e19d1d0123f6 (diff)
downloadopenembedded-7c45c11af2e21babb3a4a12db9522cffb5893fa7.tar.gz
btsco: unify
Diffstat (limited to 'packages')
-rw-r--r--packages/btsco/btsco-module.inc19
-rw-r--r--packages/btsco/btsco-module_0.41.bb21
-rw-r--r--packages/btsco/btsco-module_0.42.bb21
-rw-r--r--packages/btsco/btsco.inc12
-rw-r--r--packages/btsco/btsco_0.41.bb12
-rw-r--r--packages/btsco/btsco_0.42.bb14
6 files changed, 37 insertions, 62 deletions
diff --git a/packages/btsco/btsco-module.inc b/packages/btsco/btsco-module.inc
new file mode 100644
index 0000000000..5c38fb1719
--- /dev/null
+++ b/packages/btsco/btsco-module.inc
@@ -0,0 +1,19 @@
+DESCRIPTION = "Bluetooth-alsa headset module"
+SECTION = "kernel/modules"
+HOMEPAGE = "http://bluetooth-alsa.sourceforge.net/"
+LICENSE = "GPL"
+DEPENDS = "alsa-lib bluez-libs"
+
+inherit module
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bluetooth-alsa/btsco-${PV}.tar.gz \
+ file://makefile.patch;patch=1"
+
+S = "${WORKDIR}/btsco-${PV}/kernel"
+
+MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
+
+do_install() {
+ install -m 0755 -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
+ install -m 0644 ${S}/snd-bt-sco${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
+}
diff --git a/packages/btsco/btsco-module_0.41.bb b/packages/btsco/btsco-module_0.41.bb
index 4122bf86c4..46f647998b 100644
--- a/packages/btsco/btsco-module_0.41.bb
+++ b/packages/btsco/btsco-module_0.41.bb
@@ -1,20 +1,3 @@
-DESCRIPTION = "Bluetooth-alsa headset module"
-SECTION = "kernel/modules"
-HOMEPAGE = "http://bluetooth-alsa.sourceforge.net/"
-LICENSE = "GPL"
-DEPENDS = "alsa-lib bluez-libs"
-PR = "r1"
-
-inherit module
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/bluetooth-alsa/btsco-0.41.tar.gz \
- file://makefile.patch;patch=1"
+require btsco-module.inc
-S = "${WORKDIR}/btsco-${PV}/kernel"
-
-MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
-
-do_install() {
- install -m 0755 -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
- install -m 0644 ${S}/snd-bt-sco${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
-}
+PR = "r1"
diff --git a/packages/btsco/btsco-module_0.42.bb b/packages/btsco/btsco-module_0.42.bb
index 68c13a33d0..85b7790342 100644
--- a/packages/btsco/btsco-module_0.42.bb
+++ b/packages/btsco/btsco-module_0.42.bb
@@ -1,20 +1 @@
-DESCRIPTION = "Bluetooth-alsa headset module"
-SECTION = "kernel/modules"
-HOMEPAGE = "http://bluetooth-alsa.sourceforge.net/"
-LICENSE = "GPL"
-DEPENDS = "alsa-lib bluez-libs"
-PR = "r0"
-
-inherit module
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/bluetooth-alsa/btsco-${PV}.tar.gz \
- file://makefile.patch;patch=1"
-
-S = "${WORKDIR}/btsco-${PV}/kernel"
-
-MAKE_TARGETS = "KERNEL_PATH=${STAGING_KERNEL_DIR} MAKE='make -e'"
-
-do_install() {
- install -m 0755 -d ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra
- install -m 0644 ${S}/snd-bt-sco${KERNEL_OBJECT_SUFFIX} ${D}${base_libdir}/modules/${KERNEL_VERSION}/extra/
-}
+require btsco-module.inc
diff --git a/packages/btsco/btsco.inc b/packages/btsco/btsco.inc
new file mode 100644
index 0000000000..32009b9a26
--- /dev/null
+++ b/packages/btsco/btsco.inc
@@ -0,0 +1,12 @@
+DESCRIPTION = "Bluetooth-alsa headset tool"
+HOMEPAGE = "http://bluetooth-alsa.sourceforge.net/"
+LICENSE = "GPL"
+DEPENDS = "alsa-lib bluez-libs"
+
+inherit autotools pkgconfig
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/bluetooth-alsa/btsco-${PV}.tar.gz"
+
+S = "${WORKDIR}/${PN}-${PV}"
+
+CFLAGS += " -I${STAGING_INCDIR} "
diff --git a/packages/btsco/btsco_0.41.bb b/packages/btsco/btsco_0.41.bb
index 04c8ae16ff..46c388a83f 100644
--- a/packages/btsco/btsco_0.41.bb
+++ b/packages/btsco/btsco_0.41.bb
@@ -1,11 +1,3 @@
-DESCRIPTION = "Bluetooth-alsa headset tool"
-HOMEPAGE = "http://bluetooth-alsa.sourceforge.net/"
-LICENSE = "GPL"
-DEPENDS = "alsa-lib bluez-libs"
-PR = "r2"
-
-inherit autotools pkgconfig
+require btsco.inc
-SRC_URI = "${SOURCEFORGE_MIRROR}/bluetooth-alsa/btsco-0.41.tar.gz"
-
-S = "${WORKDIR}/${PN}-${PV}"
+PR = "r2"
diff --git a/packages/btsco/btsco_0.42.bb b/packages/btsco/btsco_0.42.bb
index a4dd11b197..1a8061ce07 100644
--- a/packages/btsco/btsco_0.42.bb
+++ b/packages/btsco/btsco_0.42.bb
@@ -1,16 +1,4 @@
-DESCRIPTION = "Bluetooth-alsa headset tool"
-HOMEPAGE = "http://bluetooth-alsa.sourceforge.net/"
-LICENSE = "GPL"
-DEPENDS = "alsa-lib bluez-libs"
-PR = "r0"
-
-inherit autotools pkgconfig
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/bluetooth-alsa/btsco-${PV}.tar.gz"
-
-S = "${WORKDIR}/${PN}-${PV}"
-
-CFLAGS += " -I${STAGING_INCDIR} "
+require btsco.inc
#there are some bogus macros putting -I/usr/include into C(PP)FLAGS, lets fix that
do_configure() {