aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorJamie Lenehan <lenehan@twibble.org>2006-09-10 23:17:34 +0000
committerJamie Lenehan <lenehan@twibble.org>2006-09-10 23:17:34 +0000
commit8982d9f961d1829ce21701fc3e1e3f641e9f6105 (patch)
tree2cf29b7907d0bc435b0214175ad5869995622753 /packages
parent8d91acabb3dc731462508d790404be41f4e401c3 (diff)
downloadopenembedded-8982d9f961d1829ce21701fc3e1e3f641e9f6105.tar.gz
lilo-sh 21: Run sanitize.py over the recipe.
Diffstat (limited to 'packages')
-rw-r--r--packages/lilo-sh/lilo-sh_21.bb37
1 files changed, 19 insertions, 18 deletions
diff --git a/packages/lilo-sh/lilo-sh_21.bb b/packages/lilo-sh/lilo-sh_21.bb
index e426e7b12a..e1d1561e36 100644
--- a/packages/lilo-sh/lilo-sh_21.bb
+++ b/packages/lilo-sh/lilo-sh_21.bb
@@ -5,37 +5,38 @@
# partition on the disk. Tested on the NP51R (Titan) booting from the
# onboard flash
#
-DESCRIPTION="LILO (LInux LOader) is a basic system program which \
+DESCRIPTION = "LILO (LInux LOader) is a basic system program which \
boots your Linux system. LILO loads the Linux kernel from a floppy or \
a hard drive, boots the kernel, and passes control of the system to \
the kernel. LILO can also boot other operating systems. LILO-sh is a \
port of LILO to the SH processor."
-SECTION="bootloaders"
+SECTION = "bootloaders"
MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
LICENSE = "MIT"
PR = "r0"
SRC_URI = "http://twibble.org/dist/sh4/src/lilosh/lilo-21.tar.gz \
- file://lilo-0.21-include.patch;patch=1 \
- file://lilo-0.21-1.1.patch;patch=1 \
- file://lilo.patch;patch=1 \
- file://lilo.raid1;patch=1 \
- file://lilo-0.21-loopdev.patch;patch=1 \
- file://lilo-0.21-second.patch;patch=1;pnum=0 \
- file://lilo-sh-linux.patch;patch=1 \
- file://lilo-linkgear.patch;patch=1 \
- file://lilo-noconfig-h.patch;patch=1"
+ file://lilo-0.21-include.patch;patch=1 \
+ file://lilo-0.21-1.1.patch;patch=1 \
+ file://lilo.patch;patch=1 \
+ file://lilo.raid1;patch=1 \
+ file://lilo-0.21-loopdev.patch;patch=1 \
+ file://lilo-0.21-second.patch;patch=1;pnum=0 \
+ file://lilo-sh-linux.patch;patch=1 \
+ file://lilo-linkgear.patch;patch=1 \
+ file://lilo-noconfig-h.patch;patch=1"
+
S = "${WORKDIR}/lilo"
EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
-# Include /boot in the package
-FILES_${PN} = "${base_sbindir} /boot"
-
do_install() {
- # Create the base directores
- mkdir -p ${D}${sysconfdir} ${D}${sbindir}
+ # Create the base directores
+ mkdir -p ${D}${sysconfdir} ${D}${sbindir}
oe_runmake ROOT=${D} install
- # We don't ship this file
- rm ${D}/usr/sbin/keytab-lilo.pl
+ # We don't ship this file
+ rm ${D}/usr/sbin/keytab-lilo.pl
}
+
+# Include /boot in the package
+FILES_${PN} = "${base_sbindir} /boot"