aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorHolger Freyther <zecke@selfish.org>2008-03-12 10:49:22 +0000
committerHolger Freyther <zecke@selfish.org>2008-03-12 10:49:22 +0000
commit9b6378f85f45219de8153203e97f94c6524716ab (patch)
treecbb7a06882faaf14b71381f95c6f8b13cfae65db /packages
parent093d01d708c2f09213f1667ca45cd165c282e435 (diff)
parentd274c014ee11521bfb84fb4b2b713a85189b8b9a (diff)
downloadopenembedded-9b6378f85f45219de8153203e97f94c6524716ab.tar.gz
merge of '8e91c5efc3e57c7b54e4a849b3b21eaf9a7dfe75'
and '9db805dedc7ef9df0a7c5cd755837e4917852f70'
Diffstat (limited to 'packages')
-rw-r--r--packages/espeak/espeak_1.30.bb52
-rw-r--r--packages/espeak/espeak_1.35.bb42
-rw-r--r--packages/speech-dispatcher/speech-dispatcher_0.6.6.bb (renamed from packages/speech-dispatcher/speech-dispatcher_0.6.5.bb)4
3 files changed, 44 insertions, 54 deletions
diff --git a/packages/espeak/espeak_1.30.bb b/packages/espeak/espeak_1.30.bb
deleted file mode 100644
index 523acc77cb..0000000000
--- a/packages/espeak/espeak_1.30.bb
+++ /dev/null
@@ -1,52 +0,0 @@
-#! /bin/sh
-#
-# Copyright Matthias Hentges <devel@hentges.net> (c) 2008
-# License: MIT (see http://www.opensource.org/licenses/mit-license.php
-# for a copy of the license)
-#
-# Filename: espeak_1.30.bb
-# Date: 20080104 (YMD)
-
-DESCRIPTION = "eSpeak is a compact open source software speech synthesizer"
-SECTION = "base"
-LICENSE = "GPL"
-
-DEPENDS = "portaudio-v19"
-
-######################################################################################
-
-PR = "r2"
-
-SRC_URI = "${SOURCEFORGE_MIRROR}/espeak/espeak-${PV}-source.zip"
-
-S = "${WORKDIR}/${PN}-${PV}-source"
-
-FILES_${PN} += " /usr/share/espeak-data/ "
-
-do_configure() {
- # espeak supports portaudio in APIs V18 and V19
- cp ${S}/src/portaudio19.h ${S}/src/portaudio.h
-}
-
-do_compile() {
- cd src
- oe_runmake
-}
-
-do_install() {
- install -d ${D}${bindir}
- install -d ${D}${libdir}
- install -d ${D}${includedir}
- install -d ${D}/usr/share/espeak-data
-
- install -m 0755 ${S}/src/espeak ${D}${bindir}
- oe_libinstall -so -C src libespeak ${D}${libdir}
-
- cp -prf ${S}/espeak-data/* ${D}/usr/share/espeak-data
-}
-
-do_stage() {
- install -d ${STAGING_INCDIR}/espeak
- install -m 0644 ${S}/src/speak_lib.h ${STAGING_INCDIR}/espeak/
- oe_libinstall -so -C src libespeak ${STAGING_LIBDIR}
-}
diff --git a/packages/espeak/espeak_1.35.bb b/packages/espeak/espeak_1.35.bb
new file mode 100644
index 0000000000..8d7b18a890
--- /dev/null
+++ b/packages/espeak/espeak_1.35.bb
@@ -0,0 +1,42 @@
+DESCRIPTION = "eSpeak is a compact open source software speech synthesizer"
+SECTION = "base"
+LICENSE = "GPL"
+DEPENDS = "portaudio-v19"
+
+PR = "r0"
+
+SRC_URI = "${SOURCEFORGE_MIRROR}/espeak/espeak-${PV}-source.zip"
+
+S = "${WORKDIR}/${PN}-${PV}-source"
+
+FILES_${PN} += "${datadir}/espeak-data"
+
+do_configure() {
+ # "speak" binary, a TTS engine, uses portaudio in either APIs V18 or V19
+ cp ${S}/src/portaudio19.h ${S}/src/portaudio.h
+}
+
+do_compile() {
+ cd src
+ oe_runmake
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${libdir}
+ install -d ${D}${includedir}
+ install -d ${D}${datadir}/espeak-data
+
+ # we do not ship "speak" binary though.
+ install -m 0755 ${S}/src/espeak ${D}${bindir}
+ install -m 0644 ${S}/src/speak_lib.h ${D}${includedir}
+ oe_libinstall -so -C src libespeak ${D}${libdir}
+
+ cp -prf ${S}/espeak-data/* ${D}${datadir}/espeak-data
+}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/espeak
+ install -m 0644 ${S}/src/speak_lib.h ${STAGING_INCDIR}/espeak/
+ oe_libinstall -so -C src libespeak ${STAGING_LIBDIR}
+}
diff --git a/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb b/packages/speech-dispatcher/speech-dispatcher_0.6.6.bb
index 7b8ba73750..302f642d67 100644
--- a/packages/speech-dispatcher/speech-dispatcher_0.6.5.bb
+++ b/packages/speech-dispatcher/speech-dispatcher_0.6.6.bb
@@ -5,7 +5,7 @@ LICENSE = "GPLv2"
DEPENDS = "espeak flite pulseaudio libdotconf glib-2.0"
RPROVIDES_${PN} += "speechd"
-PR = "r8"
+PR = "r0"
inherit autotools update-rc.d
@@ -16,7 +16,7 @@ SRC_URI = "http://www.freebsoft.org/pub/projects/speechd/${PN}-${PV}.tar.gz \
file://configSpeechd.conf.in_00.patch;patch=1"
LEAD_SONAME = "libspeechd.so"
-EXTRA_OECONF = " --with-espeak=yes --with-flite=yes --with-ibmtts=no --with-nas=no --with-alsa=yes --with-pulse=yes "
+EXTRA_OECONF = " --with-espeak --with-flite --without-ibmtts --without-nas --with-alsa --with-pulse "
INITSCRIPT_NAME = "speech-dispatcher"
INITSCRIPT_PARAMS = "defaults 45"