aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorStelios Koroneos <skoroneos@digital-opsis.com>2006-12-21 16:46:40 +0000
committerStelios Koroneos <skoroneos@digital-opsis.com>2006-12-21 16:46:40 +0000
commit9e8c7b70df3478246249f987c9388b3cd00cb8c5 (patch)
tree9c12b3a16e53ce037c0766c8c9b2c9aeffe9bdb5 /packages
parent2e42e0b62c93c454332403036baffca348dfd06d (diff)
downloadopenembedded-9e8c7b70df3478246249f987c9388b3cd00cb8c5.tar.gz
Set corect path to kernel headers for uclibc_svn
Add patch to allow gettext to compile
Diffstat (limited to 'packages')
-rw-r--r--packages/uclibc/uclibc-cvs/error_print_progname.patch11
-rw-r--r--packages/uclibc/uclibc_svn.bb6
2 files changed, 14 insertions, 3 deletions
diff --git a/packages/uclibc/uclibc-cvs/error_print_progname.patch b/packages/uclibc/uclibc-cvs/error_print_progname.patch
new file mode 100644
index 0000000000..6c10ec6b3c
--- /dev/null
+++ b/packages/uclibc/uclibc-cvs/error_print_progname.patch
@@ -0,0 +1,11 @@
+--- /libc/misc/error/orig-error.c 2006-11-29 14:28:13.000000000 -0500
++++ /libc/misc/error/error.c 2006-12-20 22:54:16.000000000 -0500
+@@ -44,7 +44,7 @@
+ /* If NULL, error will flush stdout, then print on stderr the program
+ name, a colon and a space. Otherwise, error will call this
+ function without parameters instead. */
+-/* void (*error_print_progname) (void) = NULL; */
++ void (*error_print_progname) (void) = NULL;
+
+ extern __typeof(error) __error attribute_hidden;
+ void __error (int status, int errnum, const char *message, ...)
diff --git a/packages/uclibc/uclibc_svn.bb b/packages/uclibc/uclibc_svn.bb
index 568f8d46ee..10855e6749 100644
--- a/packages/uclibc/uclibc_svn.bb
+++ b/packages/uclibc/uclibc_svn.bb
@@ -21,12 +21,12 @@ PROVIDES += "virtual/${TARGET_PREFIX}libc-for-gcc"
PACKAGE_ARCH = "${MACHINE_ARCH}"
FILESPATH = "${@base_set_filespath([ '${FILE_DIRNAME}/uclibc-cvs', '${FILE_DIRNAME}/uclibc-${UCLIBC_BASE}', '${FILE_DIRNAME}/files', '${FILE_DIRNAME}' ], d)}"
-# This is the correct KERNEL_SOURCE location, if the uClibc
-# fix_includes.sh script is run (see nokernelheader.patch below)
-# this must be correct.
+#as stated above, uclibc needs real kernel-headers
+#however: we can't depend on virtual/kernel when nptl hits due to depends deadlocking ....
KERNEL_SOURCE = "${CROSS_DIR}/${TARGET_SYS}"
SRC_URI += "svn://uclibc.org/trunk;module=uClibc"
+SRC_URI += " file://error_print_progname.patch;patch=1"
S = "${WORKDIR}/uClibc"