aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorRod Whitby <rod@whitby.id.au>2006-09-15 16:43:19 +0000
committerRod Whitby <rod@whitby.id.au>2006-09-15 16:43:19 +0000
commitb2dbeda18d0fa29db619367015edd3eb5aa07795 (patch)
treea4165add2089b0959589ccc3671c1c9b6dd76f7d /packages
parent08585d3a71b174aa70a438a61935c0c0f38d9a47 (diff)
downloadopenembedded-b2dbeda18d0fa29db619367015edd3eb5aa07795.tar.gz
ixp4xx-npe: Added 2.3 version of the microcode package
Diffstat (limited to 'packages')
-rw-r--r--packages/ixp4xx/ixp4xx-npe-native-2.3/.mtn2git_empty0
-rw-r--r--packages/ixp4xx/ixp4xx-npe-native-2.3/header.patch121
-rw-r--r--packages/ixp4xx/ixp4xx-npe-native_2.3.bb18
-rw-r--r--packages/ixp4xx/ixp4xx-npe_2.3.bb46
4 files changed, 149 insertions, 36 deletions
diff --git a/packages/ixp4xx/ixp4xx-npe-native-2.3/.mtn2git_empty b/packages/ixp4xx/ixp4xx-npe-native-2.3/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/ixp4xx/ixp4xx-npe-native-2.3/.mtn2git_empty
diff --git a/packages/ixp4xx/ixp4xx-npe-native-2.3/header.patch b/packages/ixp4xx/ixp4xx-npe-native-2.3/header.patch
new file mode 100644
index 0000000000..6dfb464ea8
--- /dev/null
+++ b/packages/ixp4xx/ixp4xx-npe-native-2.3/header.patch
@@ -0,0 +1,121 @@
+diff -Naur a/IxNpeMicrocode.h b/IxNpeMicrocode.h
+--- a/IxNpeMicrocode.h 1970-01-01 01:00:00.000000000 +0100
++++ b/IxNpeMicrocode.h 2006-08-24 14:26:31.000000000 +0100
+@@ -0,0 +1,117 @@
++/*
++ * IxNpeMicrocode.h - Headerfile for compiling the Intel microcode C file
++ *
++ * Copyright (C) 2006 Christian Hohnstaedt <chohnstaedt@innominate.com>
++ *
++ * This file is released under the GPLv2
++ *
++ *
++ * compile with
++ *
++ * gcc -Wall IxNpeMicrocode.c -o IxNpeMicrocode
++ *
++ * Executing the resulting binary on your build-host creates the
++ * "NPE-[ABC].xxxxxxxx" files containing the selected microcode
++ *
++ * fetch the IxNpeMicrocode.c from the Intel Access Library.
++ * It will include this header.
++ *
++ * select Images for every NPE from the following
++ * (used C++ comments for easy uncommenting ....)
++ */
++
++// #define IX_NPEDL_NPEIMAGE_NPEA_ETH_SPAN_MASK_FIREWALL_VLAN_QOS_HDR_CONV_EXTMIB
++// #define IX_NPEDL_NPEIMAGE_NPEA_ETH_SPAN_VLAN_QOS_HDR_CONV_EXTMIB
++// #define IX_NPEDL_NPEIMAGE_NPEA_ETH_LEARN_FILTER_SPAN_MASK_FIREWALL_VLAN_QOS_EXTMIB
++// #define IX_NPEDL_NPEIMAGE_NPEA_HSS_TSLOT_SWITCH
++// #define IX_NPEDL_NPEIMAGE_NPEA_ETH_SPAN_FIREWALL_VLAN_QOS_HDR_CONV
++// #define IX_NPEDL_NPEIMAGE_NPEA_ETH_LEARN_FILTER_SPAN_FIREWALL_VLAN_QOS
++#define IX_NPEDL_NPEIMAGE_NPEA_ETH_LEARN_FILTER_SPAN_FIREWALL
++// #define IX_NPEDL_NPEIMAGE_NPEA_HSS_2_PORT
++// #define IX_NPEDL_NPEIMAGE_NPEA_DMA
++// #define IX_NPEDL_NPEIMAGE_NPEA_ATM_MPHY_12_PORT
++// #define IX_NPEDL_NPEIMAGE_NPEA_HSS0_ATM_MPHY_1_PORT
++// #define IX_NPEDL_NPEIMAGE_NPEA_HSS0_ATM_SPHY_1_PORT
++// #define IX_NPEDL_NPEIMAGE_NPEA_HSS0
++// #define IX_NPEDL_NPEIMAGE_NPEA_WEP
++
++
++// #define IX_NPEDL_NPEIMAGE_NPEB_ETH_SPAN_MASK_FIREWALL_VLAN_QOS_HDR_CONV_EXTMIB
++#define IX_NPEDL_NPEIMAGE_NPEB_ETH_SPAN_VLAN_QOS_HDR_CONV_EXTMIB
++// #define IX_NPEDL_NPEIMAGE_NPEB_ETH_LEARN_FILTER_SPAN_MASK_FIREWALL_VLAN_QOS_EXTMIB
++// #define IX_NPEDL_NPEIMAGE_NPEB_DMA
++// #define IX_NPEDL_NPEIMAGE_NPEB_ETH_SPAN_FIREWALL_VLAN_QOS_HDR_CONV
++// #define IX_NPEDL_NPEIMAGE_NPEB_ETH_LEARN_FILTER_SPAN_FIREWALL_VLAN_QOS
++// #define IX_NPEDL_NPEIMAGE_NPEB_ETH_LEARN_FILTER_SPAN_FIREWALL
++
++
++// #define IX_NPEDL_NPEIMAGE_NPEC_ETH_SPAN_MASK_FIREWALL_VLAN_QOS_HDR_CONV_EXTMIB
++// #define IX_NPEDL_NPEIMAGE_NPEC_ETH_SPAN_VLAN_QOS_HDR_CONV_EXTMIB
++// #define IX_NPEDL_NPEIMAGE_NPEC_ETH_LEARN_FILTER_SPAN_MASK_FIREWALL_VLAN_QOS_EXTMIB
++// #define IX_NPEDL_NPEIMAGE_NPEC_DMA
++// #define IX_NPEDL_NPEIMAGE_NPEC_CRYPTO_AES_ETH_LEARN_FILTER_SPAN
++#define IX_NPEDL_NPEIMAGE_NPEC_CRYPTO_AES_ETH_LEARN_FILTER_FIREWALL
++// #define IX_NPEDL_NPEIMAGE_NPEC_CRYPTO_AES_CCM_ETH
++// #define IX_NPEDL_NPEIMAGE_NPEC_CRYPTO_ETH_LEARN_FILTER_SPAN_FIREWALL
++// #define IX_NPEDL_NPEIMAGE_NPEC_ETH_SPAN_FIREWALL_VLAN_QOS_HDR_CONV
++// #define IX_NPEDL_NPEIMAGE_NPEC_ETH_LEARN_FILTER_SPAN_FIREWALL_VLAN_QOS
++// #define IX_NPEDL_NPEIMAGE_NPEC_ETH_LEARN_FILTER_SPAN_FIREWALL
++
++
++#include <stdio.h>
++#include <unistd.h>
++#include <netinet/in.h>
++#include <sys/types.h>
++#include <sys/stat.h>
++#include <fcntl.h>
++#include <errno.h>
++
++struct dl_image {
++ unsigned magic;
++ unsigned id;
++ unsigned size;
++ unsigned data[0];
++};
++
++const unsigned IxNpeMicrocode_array[];
++
++int main(int argc, char *argv[])
++{
++ struct dl_image *image = (struct dl_image *)IxNpeMicrocode_array;
++ int imgsiz, i, fd, cnt;
++ const unsigned *arrayptr = IxNpeMicrocode_array;
++ const char *names[] = { "IXP425", "IXP465", "unknown" };
++
++ for (image = (struct dl_image *)arrayptr, cnt=0;
++ (image->id != 0xfeedf00d) && (image->magic == 0xfeedf00d);
++ image = (struct dl_image *)(arrayptr), cnt++)
++ {
++ unsigned char field[4];
++ imgsiz = image->size + 3;
++ *(unsigned*)field = ntohl(image->id);
++ char filename[40], slnk[10];
++
++ sprintf(filename, "NPE-%c.%08x", (field[0] & 0xf) + 'A',
++ image->id);
++ sprintf(slnk, "NPE-%c", (field[0] & 0xf) + 'A');
++ printf("Writing image: %s.NPE_%c Func: %2x Rev: %02x.%02x "
++ "Size: %5d to: '%s'\n",
++ names[field[0] >> 4], (field[0] & 0xf) + 'A',
++ field[1], field[2], field[3], imgsiz*4, filename);
++ fd = open(filename, O_CREAT | O_RDWR | O_TRUNC, 0644);
++ if (fd >= 0) {
++ for (i=0; i<imgsiz; i++) {
++ *(unsigned*)field = ntohl(arrayptr[i]);
++ write(fd, field, sizeof(field));
++ }
++ close(fd);
++ unlink(slnk);
++ symlink(filename, slnk);
++ } else {
++ perror(filename);
++ }
++ arrayptr += imgsiz;
++ }
++ close(fd);
++ return 0;
++}
diff --git a/packages/ixp4xx/ixp4xx-npe-native_2.3.bb b/packages/ixp4xx/ixp4xx-npe-native_2.3.bb
new file mode 100644
index 0000000000..ef1743ebff
--- /dev/null
+++ b/packages/ixp4xx/ixp4xx-npe-native_2.3.bb
@@ -0,0 +1,18 @@
+DESCRIPTION = "Firmware converter for the IXP4xx line of devices"
+MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org>"
+LICENSE = "Intel Public Licence"
+PR = "r1"
+
+SRC_URI = "http://www.intel.com/Please-Read-The-BB-File/IPL_ixp400NpeLibrary-2_3.zip"
+SRC_URI += "file://header.patch;patch=1"
+inherit native
+S = ${WORKDIR}/ixp400_xscale_sw/src/npeDl
+
+do_compile() {
+ ${CC} -Wall IxNpeMicrocode.c -o IxNpeMicrocode
+}
+
+do_stage() {
+ install -d ${STAGING_BINDIR}/
+ install -m 0755 IxNpeMicrocode ${STAGING_BINDIR}/IxNpeMicrocode
+}
diff --git a/packages/ixp4xx/ixp4xx-npe_2.3.bb b/packages/ixp4xx/ixp4xx-npe_2.3.bb
index 6270cd58eb..0885aec81b 100644
--- a/packages/ixp4xx/ixp4xx-npe_2.3.bb
+++ b/packages/ixp4xx/ixp4xx-npe_2.3.bb
@@ -1,46 +1,20 @@
-DESCRIPTION = "Firmware for the IXP4xx line of devices"
+DESCRIPTION = "NPE firmware for the IXP4xx line of devices"
MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org>"
-HOMEPAGE = "http://www.intel.com/design/network/products/npfamily/ixp420.htm"
-LICENSE = "http://www.intel.com/design/network/swsup/np_sla/ixp400.htm"
-LICENSE_HOMEPAGE = "http://www.intel.com/design/network/products/npfamily/ixp425swr1.htm"
-PR = "r2"
-
-# You must download the following software to your OpenEmbedded downloads
-# directory before using this package:
-#
-# IPL_ixp400NpeLibrary-2_3.zip
-#
-# To do this go to the LICENSE_HOMEPAGE above, register/login (using a
-# web browser which is supported by the login page), this will give you
-# access to the web page from which you can download the software - you
-# need the: "IntelĀ® IXP400 Software and RedBoot* Boot Loader" and, from
-# this the "NPE Microcode" (version 2.3, encryption is not required.)
-#
-# Store the file with the names given below in your downloads directory
-# and store the 32 character md5sum of the file in a file of the same
-# name with the additional extension .md5:
-#
-# IPL_ixp400NpeLibrary-2_3.zip.md5
-#
-
-SRC_URI = "http://downloadmirror.intel.com/df-support/11190/eng/BSD_ixp400AccessLibrary-2_3.zip \
- http://www.intel.com/Please-Read-The-BB-File/IPL_ixp400NpeLibrary-2_3.zip \
- http://www.hohnstaedt.de/ixp_npe/IxNpeMicrocode.h"
-
-inherit native
+LICENSE = "Intel Public Licence"
+PR = "r1"
+DEPENDS = "ixp4xx-npe-native"
+SRC_URI = "http://www.intel.com/Please-Read-The-BB-File/IPL_ixp400NpeLibrary-2_3.zip"
S = ${WORKDIR}/ixp400_xscale_sw/src/npeDl
+FILES_${PN} = "${base_libdir}/firmware/NPE-B/NPE-B.010c0200"
+
do_compile() {
- cp ${S}/../../../IxNpeMicrocode.h ${S}/IxNpeMicrocode.h
- ${CC} -Wall ${S}/IxNpeMicrocode.c -o ${S}/IxNpeMicrocode
- ${S}/IxNpeMicrocode
+ ${STAGING_BINDIR}/IxNpeMicrocode
}
do_install() {
- install -d ${D}/lib/firmware
- install ${S}/NPE-B ${D}/lib/firmware/
+ install -d ${D}/${base_libdir}/firmware/NPE-B
+ install ${S}/NPE-B.010c0200 ${D}/${base_libdir}/firmware/NPE-B/
}
-do_stage() {
-} \ No newline at end of file