aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorKoen Kooi <koen@openembedded.org>2007-08-08 10:36:21 +0000
committerKoen Kooi <koen@openembedded.org>2007-08-08 10:36:21 +0000
commitd1d793ed3ddad6ea1a20864be64719e5e6443291 (patch)
tree9ffbf68f0f2e88d560f0fc73206d9810ddb750d0 /packages
parent6e41414105c5e7cc21c4085ba59cc349c97ee7bd (diff)
downloadopenembedded-d1d793ed3ddad6ea1a20864be64719e5e6443291.tar.gz
roadmap: add gtk2 version
Diffstat (limited to 'packages')
-rw-r--r--packages/roadmap/.mtn2git_empty0
-rw-r--r--packages/roadmap/files/.mtn2git_empty0
-rw-r--r--packages/roadmap/roadmap-gtk2_cvs.bb44
3 files changed, 44 insertions, 0 deletions
diff --git a/packages/roadmap/.mtn2git_empty b/packages/roadmap/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/roadmap/.mtn2git_empty
diff --git a/packages/roadmap/files/.mtn2git_empty b/packages/roadmap/files/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/roadmap/files/.mtn2git_empty
diff --git a/packages/roadmap/roadmap-gtk2_cvs.bb b/packages/roadmap/roadmap-gtk2_cvs.bb
new file mode 100644
index 0000000000..cb81a44ae8
--- /dev/null
+++ b/packages/roadmap/roadmap-gtk2_cvs.bb
@@ -0,0 +1,44 @@
+DESCRIPTION = "RoadMap is a program that provides a car navigation for Linux and UNIX. \
+It displays a map of the streets, tracks the position provided by a NMEA-compliant \
+GPS receiver, identifies the street matching this GPS position and announces the name \
+of the crossing street at the next intersection."
+AUTHOR = "Pascal Martin <pascal.martin@iname.com>"
+HOMEPAGE = "http://roadmap.digitalomaha.net/maps.html"
+DEPENDS = "popt expat gtk+"
+LICENSE = "GPL"
+PV = "1.0.12+cvs${SRCDATE}"
+PR = "r0"
+
+SRC_URI = "cvs://anonymous:@roadmap.cvs.sf.net/cvsroot/roadmap;module=roadmap \
+ file://cross.patch;patch=1;pnum=2 \
+ http://roadmap.digitalomaha.net/maps/usdir.rdm.tgz \
+ "
+
+S = "${WORKDIR}/roadmap/src"
+
+PARALLEL_MAKE = ""
+CFLAGS += " -I${S} "
+
+
+do_compile() {
+ oe_runmake
+ oe_runmake gtk2
+}
+
+do_install() {
+ install -d ${D}${bindir}
+ install -d ${D}${datadir}/applications
+ install -d ${D}${datadir}/pixmaps
+ install -d ${D}${datadir}/roadmap
+
+ install -m 0755 gtk2/gtkroad* ${D}${bindir}
+
+ install -m 0644 icons/*png ${D}${datadir}/pixmaps
+
+ install -m 0644 sprites preferences ${D}${datadir}/roadmap
+ install -m 0644 ${WORKDIR}/usdir.rdm ${D}${datadir}/roadmap/
+}
+
+
+FILES_${PN} += "${datadir}/roadmap"
+