aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorPaul Sokolovsky <pmiscml@gmail.com>2006-09-11 08:09:51 +0000
committerPaul Sokolovsky <pmiscml@gmail.com>2006-09-11 08:09:51 +0000
commitebc8713c6fbefba94680d0663b52fae92d9554b4 (patch)
treed4fd4dc5bf57b4e7d05a0294d957107d706fe982 /packages
parent50a77421cf16aa2297ec4438401e4b345324d935 (diff)
parentc686df53390a3e4031deb166c85fe3fb52a6c005 (diff)
downloadopenembedded-ebc8713c6fbefba94680d0663b52fae92d9554b4.tar.gz
merge of '34210cbb1abcf24cee31bdf8e8ba63f998c30e1d'
and '78bcf1f7c1dacd879c13e6220422420e63c82aed'
Diffstat (limited to 'packages')
-rw-r--r--packages/lilo-sh/lilo-sh_21.bb37
-rw-r--r--packages/openntpd/openntpd_3.6.1p1.bb15
-rw-r--r--packages/openntpd/openntpd_3.7p1.bb22
-rw-r--r--packages/openswan/openswan_2.2.0.bb5
-rw-r--r--packages/qte/qte-common_2.3.10.inc2
-rw-r--r--packages/quagga/quagga-0.99.2/ospfd-no-opaque-lsa-fix.patch16
-rw-r--r--packages/quagga/quagga.inc186
-rw-r--r--packages/quagga/quagga_0.99.2.bb4
-rw-r--r--packages/quagga/quagga_0.99.3.bb3
-rw-r--r--packages/quagga/quagga_0.99.4.bb3
-rw-r--r--packages/wakelan/wakelan_1.1.bb18
-rw-r--r--packages/watchdog/watchdog_5.2.bb8
-rw-r--r--packages/xchat/xchat_2.6.1.bb4
13 files changed, 147 insertions, 176 deletions
diff --git a/packages/lilo-sh/lilo-sh_21.bb b/packages/lilo-sh/lilo-sh_21.bb
index eb4ba0cccf..e1d1561e36 100644
--- a/packages/lilo-sh/lilo-sh_21.bb
+++ b/packages/lilo-sh/lilo-sh_21.bb
@@ -5,37 +5,38 @@
# partition on the disk. Tested on the NP51R (Titan) booting from the
# onboard flash
#
-DESCRIPTION="LILO (LInux LOader) is a basic system program which \
+DESCRIPTION = "LILO (LInux LOader) is a basic system program which \
boots your Linux system. LILO loads the Linux kernel from a floppy or \
a hard drive, boots the kernel, and passes control of the system to \
the kernel. LILO can also boot other operating systems. LILO-sh is a \
port of LILO to the SH processor."
-SECTION="bootloader"
+SECTION = "bootloaders"
MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
LICENSE = "MIT"
PR = "r0"
SRC_URI = "http://twibble.org/dist/sh4/src/lilosh/lilo-21.tar.gz \
- file://lilo-0.21-include.patch;patch=1 \
- file://lilo-0.21-1.1.patch;patch=1 \
- file://lilo.patch;patch=1 \
- file://lilo.raid1;patch=1 \
- file://lilo-0.21-loopdev.patch;patch=1 \
- file://lilo-0.21-second.patch;patch=1;pnum=0 \
- file://lilo-sh-linux.patch;patch=1 \
- file://lilo-linkgear.patch;patch=1 \
- file://lilo-noconfig-h.patch;patch=1"
+ file://lilo-0.21-include.patch;patch=1 \
+ file://lilo-0.21-1.1.patch;patch=1 \
+ file://lilo.patch;patch=1 \
+ file://lilo.raid1;patch=1 \
+ file://lilo-0.21-loopdev.patch;patch=1 \
+ file://lilo-0.21-second.patch;patch=1;pnum=0 \
+ file://lilo-sh-linux.patch;patch=1 \
+ file://lilo-linkgear.patch;patch=1 \
+ file://lilo-noconfig-h.patch;patch=1"
+
S = "${WORKDIR}/lilo"
EXTRA_OEMAKE = "CROSS_COMPILE=${TARGET_PREFIX}"
-# Include /boot in the package
-FILES_${PN} = "${base_sbindir} /boot"
-
do_install() {
- # Create the base directores
- mkdir -p ${D}${sysconfdir} ${D}${sbindir}
+ # Create the base directores
+ mkdir -p ${D}${sysconfdir} ${D}${sbindir}
oe_runmake ROOT=${D} install
- # We don't ship this file
- rm ${D}/usr/sbin/keytab-lilo.pl
+ # We don't ship this file
+ rm ${D}/usr/sbin/keytab-lilo.pl
}
+
+# Include /boot in the package
+FILES_${PN} = "${base_sbindir} /boot"
diff --git a/packages/openntpd/openntpd_3.6.1p1.bb b/packages/openntpd/openntpd_3.6.1p1.bb
deleted file mode 100644
index b924b4a0c6..0000000000
--- a/packages/openntpd/openntpd_3.6.1p1.bb
+++ /dev/null
@@ -1,15 +0,0 @@
-DEPENDS += "openssl"
-DESCRIPTION = "OpenNTPD is a FREE, easy to use implementation of the \
-Network Time Protocol."
-HOMEPAGE = "http://www.openntpd.org/"
-LICENSE = "BSD"
-SECTION = "console/network"
-MAINTAINER = "Chris Larson <kergoth@handhelds.org>"
-
-SRC_URI = "ftp://ftp.openbsd.org/pub/OpenBSD/OpenNTPD/openntpd-${PV}.tar.gz \
- file://autofoo.patch;patch=1"
-S = "${WORKDIR}/openntpd-${PV}"
-
-inherit autotools
-
-EXTRA_OECONF += "--disable-strip"
diff --git a/packages/openntpd/openntpd_3.7p1.bb b/packages/openntpd/openntpd_3.7p1.bb
index 4001eb7dae..d13f6d3520 100644
--- a/packages/openntpd/openntpd_3.7p1.bb
+++ b/packages/openntpd/openntpd_3.7p1.bb
@@ -1,12 +1,12 @@
-DEPENDS += "openssl"
DESCRIPTION = "OpenNTPD is a FREE, easy to use implementation of the \
Network Time Protocol."
HOMEPAGE = "http://www.openntpd.org/"
-LICENSE = "BSD"
SECTION = "console/network"
MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org>"
+LICENSE = "BSD"
+DEPENDS += "openssl"
DEPENDS = "timezones"
-PR="r13"
+PR = "r13"
SRC_URI = "http://www.zip.com.au/~dtucker/openntpd/release/openntpd-${PV}.tar.gz \
file://autofoo.patch;patch=1 \
@@ -18,9 +18,6 @@ S = "${WORKDIR}/openntpd-${PV}"
inherit autotools update-rc.d
-INITSCRIPT_NAME = "openntpd"
-INITSCRIPT_PARAMS = "defaults"
-
EXTRA_OECONF += "CFLAGS=-DUSE_ADJTIMEX --disable-strip --prefix=/usr \
--sysconfdir=/etc --with-privsep-path=/${localstatedir}/shared/empty \
--with-privsep-user=ntpd \
@@ -30,17 +27,20 @@ EXTRA_OECONF += "CFLAGS=-DUSE_ADJTIMEX --disable-strip --prefix=/usr \
do_install_prepend() {
install -d ${D}${sysconfdir}/init.d
}
-
do_install_append() {
install -c -m 755 ${WORKDIR}/init ${D}${sysconfdir}/init.d/openntpd
}
-pkg_postrm () {
- grep ntpd ${sysconfdir}/passwd && deluser ntpd
-}
-
pkg_postinst () {
[ ! -d ${localstatedir}/shared ] && mkdir -p ${localstatedir}/shared
grep ntpd ${sysconfdir}/passwd || adduser --disabled-password --home=${localstatedir}/shared/empty --ingroup nogroup ntpd
chown root:root ${localstatedir}/shared/empty
}
+
+pkg_postrm () {
+ grep ntpd ${sysconfdir}/passwd && deluser ntpd
+}
+
+INITSCRIPT_NAME = "openntpd"
+
+INITSCRIPT_PARAMS = "defaults"
diff --git a/packages/openswan/openswan_2.2.0.bb b/packages/openswan/openswan_2.2.0.bb
index 197fed95f6..268ec805d0 100644
--- a/packages/openswan/openswan_2.2.0.bb
+++ b/packages/openswan/openswan_2.2.0.bb
@@ -7,7 +7,7 @@ MAINTAINER = "Bruno Randolf <bruno.randolf@4g-systems.biz>"
DEPENDS = "gmp flex-native"
RRECOMMENDS = "kernel-module-ipsec"
RDEPENDS_nylon = "perl"
-PR = "r4"
+PR = "r5"
SRC_URI = "http://www.openswan.org/download/old/openswan-${PV}.tar.gz \
file://openswan-2.2.0-gentoo.patch;patch=1 \
@@ -32,6 +32,7 @@ do_install () {
oe_runmake install
}
-FILES_${PN} += "${libdir}/ipsec/"
+FILES_${PN} = "${sysconfdir} ${libdir}/ipsec/* ${sbindir}/* ${libexecdir}/ipsec/*"
+FILES_${PN}-dbg += "${libdir}/ipsec/.debug ${libexecdir}/ipsec/.debug"
CONFFILES_${PN} = "${sysconfdir}/ipsec/ipsec.conf"
diff --git a/packages/qte/qte-common_2.3.10.inc b/packages/qte/qte-common_2.3.10.inc
index 9cbdaed04d..a1ea049737 100644
--- a/packages/qte/qte-common_2.3.10.inc
+++ b/packages/qte/qte-common_2.3.10.inc
@@ -11,7 +11,7 @@ PROVIDES = "virtual/libqte2"
FILESDIR = "${@os.path.dirname(bb.data.getVar('FILE',d,1))}/qte-${PV}"
-SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}-free.tar.gz;md5sum=af7ad30113afc500cab7f5b2f4dec0d7 \
+SRC_URI = "ftp://ftp.trolltech.com/pub/qt/source/qt-embedded-${PV}-free.tar.gz;md5sum=1f7ad30113afc500cab7f5b2f4dec0d7 \
file://qpe.patch;patch=1 \
file://vt-switch.patch;patch=1 \
file://daemonize.patch;patch=1 \
diff --git a/packages/quagga/quagga-0.99.2/ospfd-no-opaque-lsa-fix.patch b/packages/quagga/quagga-0.99.2/ospfd-no-opaque-lsa-fix.patch
deleted file mode 100644
index 3c9972988a..0000000000
--- a/packages/quagga/quagga-0.99.2/ospfd-no-opaque-lsa-fix.patch
+++ /dev/null
@@ -1,16 +0,0 @@
-If you try to build without opaque LSA support you'll hit this error. I now
-turn this on in the makefile so this isn't really needed but it's here just
-because I fixed it before changing the configuration.
-
---- quagga-0.99.2/ospfd/ospfd.c.orig 2005-11-13 13:28:39.000000000 +1100
-+++ quagga-0.99.2/ospfd/ospfd.c 2005-11-13 13:28:57.000000000 +1100
-@@ -466,7 +466,9 @@
- OSPF_TIMER_OFF (ospf->t_lsa_refresher);
- OSPF_TIMER_OFF (ospf->t_read);
- OSPF_TIMER_OFF (ospf->t_write);
-+#ifdef HAVE_OPAQUE_LSA
- OSPF_TIMER_OFF (ospf->t_opaque_lsa_self);
-+#endif
-
- close (ospf->fd);
- stream_free(ospf->ibuf);
diff --git a/packages/quagga/quagga.inc b/packages/quagga/quagga.inc
index 34eb9bec0d..2c3d79074b 100644
--- a/packages/quagga/quagga.inc
+++ b/packages/quagga/quagga.inc
@@ -9,139 +9,139 @@ SECTION = "network"
MAINTAINER = "Jamie Lenehan <lenehan@twibble.org>"
LICENSE = "GPL"
DEPENDS = "readline ncurses perl-native"
+# Each of the per-protocol packages depends on the main package
+RDEPENDS_${PN}-ospfd = ${PN}
+RDEPENDS_${PN}-ospf6d = ${PN}
+RDEPENDS_${PN}-bgpd = ${PN}
+RDEPENDS_${PN}-ripd = ${PN}
+RDEPENDS_${PN}-ripngd = ${PN}
+RDEPENDS_${PN}-isisd = ${PN}
+RDEPENDS_${PN}-ospfclient = ${PN}
+RDEPENDS_${PN}-doc = ""
+RDEPENDS_${PN}-watchquagga = ${PN}
+# the "ip" command from busybox is not sufficient (flush by protocol flushes all routes)
+RDEPENDS_${PN} += "iproute2"
+# These are required for vtysh
+RDEPENDS_${PN} += "ncurses readline"
# ${QUAGGASUBDIR} is deal with old versions. Set to "/attic" for old
# versions and leave it empty for recent versions.
SRC_URI = "http://www.quagga.net/download${QUAGGASUBDIR}/quagga-${PV}.tar.gz \
- file://fix-for-lib-inpath.patch;patch=1 \
- file://quagga.init \
- file://quagga.default \
- file://watchquagga.init \
- file://watchquagga.default"
-
-# Main init script starts all deamons
-# Seperate init script for watchquagga
-INITSCRIPT_PACKAGES = "${PN} ${PN}-watchquagga"
-INITSCRIPT_NAME_${PN} = "quagga"
-INITSCRIPT_PARAMS_${PN} = "defaults 15 85"
-INITSCRIPT_NAME_${PN}-watchquagga = "watchquagga"
-INITSCRIPT_PARAMS_${PN}-watchquagga = "defaults 90 10"
+ file://fix-for-lib-inpath.patch;patch=1 \
+ file://quagga.init \
+ file://quagga.default \
+ file://watchquagga.init \
+ file://watchquagga.default"
inherit autotools update-rc.d
# Turn on options and changes paths.
# This matches the layout and configuration of the debian quagga package
EXTRA_OECONF = "--prefix=${prefix} \
- --libexecdir=${libexecdir}/quagga \
- --sbindir=${libdir}/quagga \
- --sysconfdir=${sysconfdir}/quagga \
- --localstatedir=${localstatedir}/run/quagga \
- --enable-exampledir=${docdir}/quagga/examples/ \
- --enable-vtysh \
- --enable-isisd \
- --enable-watchquagga \
- --enable-ospf-te \
- --enable-opaque-lsa \
- --enable-ipv6 \
- --enable-ospfclient=yes \
- --enable-multipath=64 \
- --enable-user=quagga \
- --enable-group=quagga \
- --enable-vty-group=quaggavty \
- --enable-configfile-mask=0640 \
- --enable-logfile-mask=0640 \
- --enable-rtadv \
- --enable-tcp-md5"
-
-# Split into a main package and seperate per-protocol packages
-PACKAGES = "${PN} \
- ${PN}-ospfd ${PN}-ospf6d ${PN}-bgpd ${PN}-ripd ${PN}-ripngd ${PN}-isisd \
- ${PN}-ospfclient ${PN}-watchquagga ${PN}-dev ${PN}-doc"
-FILES_${PN}-ospfd = "${libdir}/quagga/ospfd /usr/lib/libospf.so.*"
-FILES_${PN}-ospf6d = "${libdir}/quagga/ospf6d"
-FILES_${PN}-bgpd = "${libdir}/quagga/bgpd"
-FILES_${PN}-ripd = "${libdir}/quagga/ripd"
-FILES_${PN}-ripngd = "${libdir}/quagga/ripngd"
-FILES_${PN}-isisd = "${libdir}/quagga/isisd"
-FILES_${PN}-ospfclient = "${libdir}/quagga/ospfclient /usr/lib/libospfapiclient.so.*"
-FILES_${PN}-dev = "/usr/include /usr/lib/lib*.so /usr/lib/*.la /usr/lib/*.a"
-FILES_${PN}-doc = "/usr/share/doc /usr/share/man /usr/share/info"
-FILES_${PN}-watchquagga = "${libdir}/quagga/watchquagga ${sysconfdir}/default/watchquagga \
- ${sysconfdir}/init.d/watchquagga"
-FILES_${PN} = "${bindir}/vtysh ${libdir}/quagga/zebra /usr/lib/libzebra*.so.* \
- ${sysconfdir}/quagga \
- ${sysconfdir}/default/quagga ${sysconfdir}/init.d/quagga"
+ --libexecdir=${libexecdir}/quagga \
+ --sbindir=${libdir}/quagga \
+ --sysconfdir=${sysconfdir}/quagga \
+ --localstatedir=${localstatedir}/run/quagga \
+ --enable-exampledir=${docdir}/quagga/examples/ \
+ --enable-vtysh \
+ --enable-isisd \
+ --enable-watchquagga \
+ --enable-ospf-te \
+ --enable-opaque-lsa \
+ --enable-ipv6 \
+ --enable-ospfclient=yes \
+ --enable-multipath=64 \
+ --enable-user=quagga \
+ --enable-group=quagga \
+ --enable-vty-group=quaggavty \
+ --enable-configfile-mask=0640 \
+ --enable-logfile-mask=0640 \
+ --enable-rtadv \
+ --enable-tcp-md5"
-# Stop the names being rewritten due to the internal shared libraries
-PKG_${PN}-ospfd = ${PN}-ospfd
-PKG_${PN}-ospfclient = ${PN}-ospfclient
+do_install () {
+ # Install init script and default settings
+ install -m 0755 -d ${D}${sysconfdir}/default ${D}${sysconfdir}/init.d ${D}${sysconfdir}/quagga
+ install -m 0644 ${WORKDIR}/quagga.default ${D}${sysconfdir}/default/quagga
+ install -m 0644 ${WORKDIR}/watchquagga.default ${D}${sysconfdir}/default/watchquagga
+ install -m 0755 ${WORKDIR}/quagga.init ${D}${sysconfdir}/init.d/quagga
+ install -m 0755 ${WORKDIR}/watchquagga.init ${D}${sysconfdir}/init.d/watchquagga
+ # Install quagga
+ oe_runmake install DESTDIR=${D} prefix=${prefix} \
+ libexecdir=${libexecdir}/quagga \
+ sbindir=${libdir}/quagga \
+ sysconfdir=${sysconfdir}/quagga \
+ localstatedir=${localstatedir}/run/quagga
+}
-# Each of the per-protocol packages depends on the main package
-RDEPENDS_${PN}-ospfd = ${PN}
-RDEPENDS_${PN}-ospf6d = ${PN}
-RDEPENDS_${PN}-bgpd = ${PN}
-RDEPENDS_${PN}-ripd = ${PN}
-RDEPENDS_${PN}-ripngd = ${PN}
-RDEPENDS_${PN}-isisd = ${PN}
-RDEPENDS_${PN}-ospfclient = ${PN}
-RDEPENDS_${PN}-doc = ""
-RDEPENDS_${PN}-watchquagga = ${PN}
-# the "ip" command from busybox is not sufficient (flush by protocol flushes all routes)
-RDEPENDS_${PN} += "iproute2"
-# These are required for vtysh
-RDEPENDS_${PN} += "ncurses readline"
+# Split into a main package and seperate per-protocol packages
+PACKAGES = "${PN}-dbg ${PN} \
+ ${PN}-ospfd ${PN}-ospf6d ${PN}-bgpd ${PN}-ripd ${PN}-ripngd ${PN}-isisd \
+ ${PN}-ospfclient ${PN}-watchquagga ${PN}-dev ${PN}-doc"
+
+FILES_${PN}-ospfd = "${libdir}/quagga/ospfd /usr/lib/libospf.so.*"
+FILES_${PN}-ospf6d = "${libdir}/quagga/ospf6d"
+FILES_${PN}-bgpd = "${libdir}/quagga/bgpd"
+FILES_${PN}-ripd = "${libdir}/quagga/ripd"
+FILES_${PN}-ripngd = "${libdir}/quagga/ripngd"
+FILES_${PN}-isisd = "${libdir}/quagga/isisd"
+FILES_${PN}-ospfclient = "${libdir}/quagga/ospfclient /usr/lib/libospfapiclient.so.*"
+FILES_${PN}-dev = "/usr/include /usr/lib/lib*.so /usr/lib/*.la /usr/lib/*.a"
+FILES_${PN}-doc = "/usr/share/doc /usr/share/man /usr/share/info"
+FILES_${PN}-watchquagga = "${libdir}/quagga/watchquagga ${sysconfdir}/default/watchquagga \
+ ${sysconfdir}/init.d/watchquagga"
+FILES_${PN} = "${bindir}/vtysh ${libdir}/quagga/zebra /usr/lib/libzebra*.so.* \
+ ${sysconfdir}/quagga \
+ ${sysconfdir}/default/quagga ${sysconfdir}/init.d/quagga"
# Indicate that the default files are configuration files
CONFFILES_${PN} = "${sysconfdir}/default/quagga"
CONFFILES_${PN}-watchquagga = "${sysconfdir}/default/watchquagga"
-do_install () {
- # Install init script and default settings
- install -m 0755 -d ${D}${sysconfdir}/default ${D}${sysconfdir}/init.d ${D}${sysconfdir}/quagga
- install -m 0644 ${WORKDIR}/quagga.default ${D}${sysconfdir}/default/quagga
- install -m 0644 ${WORKDIR}/watchquagga.default ${D}${sysconfdir}/default/watchquagga
- install -m 0755 ${WORKDIR}/quagga.init ${D}${sysconfdir}/init.d/quagga
- install -m 0755 ${WORKDIR}/watchquagga.init ${D}${sysconfdir}/init.d/watchquagga
- # Install quagga
- oe_runmake install DESTDIR=${D} prefix=${prefix} \
- libexecdir=${libexecdir}/quagga \
- sbindir=${libdir}/quagga \
- sysconfdir=${sysconfdir}/quagga \
- localstatedir=${localstatedir}/run/quagga
-}
+# Stop the names being rewritten due to the internal shared libraries
+PKG_${PN}-ospfd = ${PN}-ospfd
+PKG_${PN}-ospfclient = ${PN}-ospfclient
+
+# Main init script starts all deamons
+# Seperate init script for watchquagga
+INITSCRIPT_PACKAGES = "${PN} ${PN}-watchquagga"
+INITSCRIPT_NAME_${PN} = "quagga"
+INITSCRIPT_PARAMS_${PN} = "defaults 15 85"
+INITSCRIPT_NAME_${PN}-watchquagga = "watchquagga"
+INITSCRIPT_PARAMS_${PN}-watchquagga = "defaults 90 10"
# Add quagga's user and groups
pkg_postinst_${PN} () {
- grep -q quagga: /etc/group || addgroup quagga
- grep -q quaggavty: /etc/group || addgroup quaggavty
- grep -q quagga: /etc/passwd || adduser --disabled-password --home=/var/run/quagga/ --ingroup quagga -g "Quagga routing suite" quagga
+ grep -q quagga: /etc/group || addgroup quagga
+ grep -q quaggavty: /etc/group || addgroup quaggavty
+ grep -q quagga: /etc/passwd || adduser --disabled-password --home=/var/run/quagga/ --ingroup quagga -g "Quagga routing suite" quagga
}
# Stop apps before uninstall
pkg_prerm_${PN} () {
- ${sysconfdir}/init.d/quagga stop
+ ${sysconfdir}/init.d/quagga stop
}
pkg_prerm_${PN}-ospfd () {
- ${sysconfdir}/init.d/quagga stop ospfd
+ ${sysconfdir}/init.d/quagga stop ospfd
}
pkg_prerm_${PN}-ospf6d () {
- ${sysconfdir}/init.d/quagga stop ospf6d
+ ${sysconfdir}/init.d/quagga stop ospf6d
}
pkg_prerm_${PN}-bgpd () {
- ${sysconfdir}/init.d/quagga stop bgpd
+ ${sysconfdir}/init.d/quagga stop bgpd
}
pkg_prerm_${PN}-ripd () {
- ${sysconfdir}/init.d/quagga stop ripd
+ ${sysconfdir}/init.d/quagga stop ripd
}
pkg_prerm_${PN}-ripngd () {
- ${sysconfdir}/init.d/quagga stop ripngd
+ ${sysconfdir}/init.d/quagga stop ripngd
}
pkg_prerm_${PN}-isisd () {
- ${sysconfdir}/init.d/quagga stop isisd
+ ${sysconfdir}/init.d/quagga stop isisd
}
diff --git a/packages/quagga/quagga_0.99.2.bb b/packages/quagga/quagga_0.99.2.bb
deleted file mode 100644
index a14ef1ad1a..0000000000
--- a/packages/quagga/quagga_0.99.2.bb
+++ /dev/null
@@ -1,4 +0,0 @@
-QUAGGASUBDIR = "/attic"
-require quagga.inc
-PR = "r2"
-SRC_URI += "file://ospfd-no-opaque-lsa-fix.patch;patch=1"
diff --git a/packages/quagga/quagga_0.99.3.bb b/packages/quagga/quagga_0.99.3.bb
index 9f76edb5e3..138c8ce98f 100644
--- a/packages/quagga/quagga_0.99.3.bb
+++ b/packages/quagga/quagga_0.99.3.bb
@@ -1,2 +1,3 @@
+PR = "r3"
+
require quagga.inc
-PR = "r2"
diff --git a/packages/quagga/quagga_0.99.4.bb b/packages/quagga/quagga_0.99.4.bb
index cba544fdfd..0595a3c94b 100644
--- a/packages/quagga/quagga_0.99.4.bb
+++ b/packages/quagga/quagga_0.99.4.bb
@@ -1,2 +1,3 @@
+PR = "r2"
+
require quagga.inc
-PR = "r1"
diff --git a/packages/wakelan/wakelan_1.1.bb b/packages/wakelan/wakelan_1.1.bb
index 34b14c8a28..48241df085 100644
--- a/packages/wakelan/wakelan_1.1.bb
+++ b/packages/wakelan/wakelan_1.1.bb
@@ -1,16 +1,20 @@
-LICENSE = "GPL"
-MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org>"
+## Warning: unknown variable/routine "INHIBIT_AUTO_STAGE = "1""
+## Reminder: Tabs should not be used (use spaces instead) in : install -d ${D}${bindir}
+## Reminder: Tabs should not be used (use spaces instead) in : install -m 0755 ${WORKDIR}/${PN}-${PV}/wakelan ${D}${bindir}/wakelan
DESCRIPTION = "Wakelan sends a magic packet to wake up remote PC's"
+MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org>"
+LICENSE = "GPL"
PR = "r2"
-FILES = "${bindir}/wakelan"
SRC_URI = "http://www.ibiblio.org/pub/Linux/system/network/misc/${PN}-${PV}.tar.gz"
inherit autotools
-INHIBIT_AUTO_STAGE = "1"
-
do_install () {
- install -d ${D}${bindir}
- install -m 0755 ${WORKDIR}/${PN}-${PV}/wakelan ${D}${bindir}/wakelan
+ install -d ${D}${bindir}
+ install -m 0755 ${WORKDIR}/${PN}-${PV}/wakelan ${D}${bindir}/wakelan
}
+
+FILES = "${bindir}/wakelan"
+
+INHIBIT_AUTO_STAGE = "1"
diff --git a/packages/watchdog/watchdog_5.2.bb b/packages/watchdog/watchdog_5.2.bb
index 12f41b6ee7..592f86af39 100644
--- a/packages/watchdog/watchdog_5.2.bb
+++ b/packages/watchdog/watchdog_5.2.bb
@@ -1,14 +1,12 @@
+#CONFFILES = "${sysconfdir}/watchdog.conf"
DESCRIPTION = "Software watchdog"
MAINTAINER = "Oyvind Repvik <nail@nslu2-linux.org>"
-PR = "r3"
LICENSE = "GPL"
+PR = "r3"
SRC_URI = "http://www.ibiblio.org/pub/Linux/system/daemons/watchdog/${PN}-${PV}.tar.gz"
-
SRC_URI += "file://mkinstalldirs.patch;patch=1"
-FILES = "${sysconfdir}/watchdog.conf ${sbindir}/watchdog"
-#CONFFILES = "${sysconfdir}/watchdog.conf"
-
inherit autotools
+FILES = "${sysconfdir}/watchdog.conf ${sbindir}/watchdog"
diff --git a/packages/xchat/xchat_2.6.1.bb b/packages/xchat/xchat_2.6.1.bb
index f26cf2f025..bd40b7449c 100644
--- a/packages/xchat/xchat_2.6.1.bb
+++ b/packages/xchat/xchat_2.6.1.bb
@@ -1,10 +1,10 @@
DESCRIPTION = "Full-featured IRC chat client with scripting support"
LICENSE = "GPL"
HOMEPAGE = "http://www.xchat.org"
-SECTION "x11/network"
+SECTION = "x11/network"
MAINTAINER = "Koen Kooi <koen@linuxtogo.org>"
DEPENDS = "libgcrypt zlib gtk+"
-PR = "r1"
+PR = "r2"
SRC_URI = "http://www.xchat.org/files/source/2.6/xchat-${PV}.tar.bz2"