aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorSimon Vogl <vogl@soft.uni-linz.ac.at>2007-01-19 21:49:19 +0000
committerKoen Kooi <koen@openembedded.org>2007-01-19 21:49:19 +0000
commitfc22fb2a81b6ae52e795bcc09c59c0911681c600 (patch)
treeeed9454462a7dab2ce6a8cc25a464f05d4bc0795 /packages
parent18d709ecc5d28f6021f6cefc49b74a352b81950a (diff)
downloadopenembedded-fc22fb2a81b6ae52e795bcc09c59c0911681c600.tar.gz
vincent: add opengl/es implementation, needs some finetuning, closes #1596
Diffstat (limited to 'packages')
-rw-r--r--packages/vincent/.mtn2git_empty0
-rw-r--r--packages/vincent/vincent_svn.bb25
2 files changed, 25 insertions, 0 deletions
diff --git a/packages/vincent/.mtn2git_empty b/packages/vincent/.mtn2git_empty
new file mode 100644
index 0000000000..e69de29bb2
--- /dev/null
+++ b/packages/vincent/.mtn2git_empty
diff --git a/packages/vincent/vincent_svn.bb b/packages/vincent/vincent_svn.bb
new file mode 100644
index 0000000000..87e111875a
--- /dev/null
+++ b/packages/vincent/vincent_svn.bb
@@ -0,0 +1,25 @@
+DESCRIPTION = "Vincent OpenGL-ES library "
+HOMEPAGE = "http://sourceforge.net/projects/ogl-es/"
+LICENSE = "BSD"
+
+PV = "0.0+svn${SRCDATE}"
+PR = "r0"
+
+SRC_URI = "svn://svn.sourceforge.net/svnroot/ogl-es/branches;module=linux_nokia_770;proto=https"
+
+S = "${WORKDIR}/linux_nokia_770/ogles/projects/linux-x11"
+
+TOP = "${WORKDIR}/linux_nokia_770/ogles/"
+
+inherit autotools pkgconfig
+
+# PACKAGES = ${PN}
+
+do_stage() {
+ install -d ${STAGING_INCDIR}/GLES
+
+ install -m 0644 ${TOP}/include/ug.h ${STAGING_INCDIR}
+ install -m 0644 ${TOP}/include/GLES/* ${STAGING_INCDIR}/GLES/
+
+ oe_libinstall -so libvincent ${STAGING_LIBDIR}
+}