aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorFelix Domke <tmbinc@elitedvb.ne>2008-02-27 01:07:56 +0000
committerFelix Domke <tmbinc@elitedvb.ne>2008-02-27 01:07:56 +0000
commit0ae3165e3d5c0a36e08ed759545c937135327e1d (patch)
treec2a2865156feedc852cbf124d24d408cd57f8ff6 /packages
parent614fdc102443301eb8eb9fb42343bdbe5a3252b9 (diff)
downloadopenembedded-0ae3165e3d5c0a36e08ed759545c937135327e1d.tar.gz
hotplug-ng: add hotplug-ng from http://hotplug-ng.schwerkraft.elitedvb.net/
Diffstat (limited to 'packages')
-rw-r--r--packages/hotplug-ng/hotplug-ng.bb26
1 files changed, 26 insertions, 0 deletions
diff --git a/packages/hotplug-ng/hotplug-ng.bb b/packages/hotplug-ng/hotplug-ng.bb
new file mode 100644
index 0000000000..8b79cc2d37
--- /dev/null
+++ b/packages/hotplug-ng/hotplug-ng.bb
@@ -0,0 +1,26 @@
+DESCRIPTION = "This collection of code replaces the existing linux-hotplug \
+package with very tiny, compiled executable programs, instead of the \
+existing bash scripts."
+LICENSE = "GPL"
+RPROVIDES_${PN} = "hotplug"
+RCONFLICTS_${PN} = "hotplug"
+RREPLACES_${PN} = "hotplug"
+
+SRC_URI = "svn://svn.schwerkraft.elitedvb.net/svnroot;module=hotplug-ng"
+SRCDATE = "20080228"
+
+S = "${WORKDIR}/hotplug-ng/trunk"
+
+LD = "${CC}"
+export HOSTCC = "${BUILD_CC}"
+CFLAGS = " -I${S}/libsysfs/sysfs"
+# Stripping should be done when _packaging_, not building
+EXTRA_OEMAKE += "'STRIP=/bin/true'"
+
+export etcdir = "${sysconfdir}"
+export sbindir = "${base_sbindir}"
+export bindir = "${base_bindir}"
+
+do_install () {
+ oe_runmake 'DESTDIR=${D}' install
+}