aboutsummaryrefslogtreecommitdiffstats
path: root/packages
diff options
context:
space:
mode:
authorKristoffer Ericson <kristoffer_e1@hotmail.com>2006-06-07 15:08:46 +0000
committerOpenEmbedded Project <openembedded-devel@lists.openembedded.org>2006-06-07 15:08:46 +0000
commit334d5a0b10527453ff9f13352f862df94f0e7c3f (patch)
tree238687aef5f3a50e3aa8f3789d959b4bfd98e0ba /packages
parent31c9b1a52ca1136c19df230aa014d307d782c7d0 (diff)
downloadopenembedded-334d5a0b10527453ff9f13352f862df94f0e7c3f.tar.gz
bootsplash: Fixing so it builds again
* Gcc issues that refuses to build bootsplash should remove some warnings messages on 3.3.x and finally work for 4.1.x.
Diffstat (limited to 'packages')
-rw-r--r--packages/bootsplash/bootsplash_3.0.7.bb3
-rw-r--r--packages/bootsplash/files/gcc-issues.patch22
2 files changed, 24 insertions, 1 deletions
diff --git a/packages/bootsplash/bootsplash_3.0.7.bb b/packages/bootsplash/bootsplash_3.0.7.bb
index 9ffa97d4d5..da6f75b4d3 100644
--- a/packages/bootsplash/bootsplash_3.0.7.bb
+++ b/packages/bootsplash/bootsplash_3.0.7.bb
@@ -7,7 +7,8 @@ HOMEPAGE="http://www.bootsplash.org"
SECTION = "media-gfx"
LICENSE = "GPL"
SRC_URI="ftp://ftp.openbios.org/pub/bootsplash/rpm-sources/bootsplash/bootsplash-${PV}.tar.bz2 \
- file://freetype2.patch;patch=1"
+ file://freetype2.patch;patch=1 \
+ file://gcc-issues.patch;patch=1"
DEPENDS="freetype libmng"
PR = "r1"
diff --git a/packages/bootsplash/files/gcc-issues.patch b/packages/bootsplash/files/gcc-issues.patch
new file mode 100644
index 0000000000..c667fde329
--- /dev/null
+++ b/packages/bootsplash/files/gcc-issues.patch
@@ -0,0 +1,22 @@
+--- bootsplash-3.0.7/Utilities/mng.c_orig 2006-06-07 15:03:47.000000000 +0000
++++ bootsplash-3.0.7/Utilities/mng.c 2006-06-07 15:04:46.000000000 +0000
+@@ -228,7 +228,8 @@
+ a = a * mymng->alpha / 100;
+ switch (mymng->fbbpp) {
+ case 16:
+- input = *((unsigned short *) background)++;
++ input = *((unsigned short *) background);
++ input = input++;
+
+ br = (input >> mng->fbredo) << (8 - mng->fbredl);
+ bg = (input >> mng->fbgreeno) << (8 -
+@@ -279,7 +280,8 @@
+ fbgreeno) | (b << mng->
+ fbblueo);
+
+- *((unsigned short *) dest)++ = output;
++ output = *((unsigned short *) dest);
++ output = output++;
+ break;
+ case 24:
+ *dest++ = b;